about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/enlightenment/efl.nix4
-rw-r--r--pkgs/desktops/gnome-2/platform/libgnome/default.nix6
-rw-r--r--pkgs/desktops/gnome-2/platform/libgnomeui/default.nix10
-rw-r--r--pkgs/desktops/gnome-3/core/evolution-data-server/default.nix2
-rw-r--r--pkgs/desktops/gnome-3/core/gucharmap/default.nix19
-rw-r--r--pkgs/desktops/gnome-3/core/gucharmap/src.nix6
-rw-r--r--pkgs/desktops/gnome-3/core/gucharmap/unicode-data.nix44
-rw-r--r--pkgs/desktops/gnome-3/core/nautilus/default.nix10
-rw-r--r--pkgs/desktops/gnome-3/misc/libgda/default.nix8
9 files changed, 90 insertions, 19 deletions
diff --git a/pkgs/desktops/enlightenment/efl.nix b/pkgs/desktops/enlightenment/efl.nix
index 67840a4c9e61..d011012e010a 100644
--- a/pkgs/desktops/enlightenment/efl.nix
+++ b/pkgs/desktops/enlightenment/efl.nix
@@ -8,11 +8,11 @@
 
 stdenv.mkDerivation rec {
   name = "efl-${version}";
-  version = "1.20.3";
+  version = "1.20.4";
 
   src = fetchurl {
     url = "http://download.enlightenment.org/rel/libs/efl/${name}.tar.xz";
-    sha256 = "148i8awjdrqzd0xqfc6q4qvhhs46jl15nx7n2nii7lrwzx502wqj";
+    sha256 = "1jxha61gsil6hs9zb72zsyh3gmdipvfnlc9v3palb2bm0b23aq9i";
   };
 
   nativeBuildInputs = [ pkgconfig ];
diff --git a/pkgs/desktops/gnome-2/platform/libgnome/default.nix b/pkgs/desktops/gnome-2/platform/libgnome/default.nix
index 1bffa6211dca..a9957c41ff5d 100644
--- a/pkgs/desktops/gnome-2/platform/libgnome/default.nix
+++ b/pkgs/desktops/gnome-2/platform/libgnome/default.nix
@@ -11,9 +11,11 @@ stdenv.mkDerivation rec {
     sha256 = "197pnq8y0knqjhm2fg4j6hbqqm3qfzfnd0irhwxpk1b4hqb3kimj";
   };
 
-  outputs = [ "out" "dev" ];
-
   patches = [ ./new-glib.patch ];
+  /* There's a comment containing an invalid utf-8 sequence, breaking glib-mkenums. */
+  postPatch = "sed '/returns the true filename/d' -i libgnome/gnome-config.h";
+
+  outputs = [ "out" "dev" ];
 
   nativeBuildInputs = [ pkgconfig ];
   buildInputs = [ popt zlib intltool GConf gnome_vfs libcanberra libtool ];
diff --git a/pkgs/desktops/gnome-2/platform/libgnomeui/default.nix b/pkgs/desktops/gnome-2/platform/libgnomeui/default.nix
index d30c38a2cfc4..24cd851eef6a 100644
--- a/pkgs/desktops/gnome-2/platform/libgnomeui/default.nix
+++ b/pkgs/desktops/gnome-2/platform/libgnomeui/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, pkgconfig, libxml2, xorg, glib, pango
+{ stdenv, fetchurl, fetchpatch, pkgconfig, libxml2, xorg, glib, pango
 , intltool, libgnome, libgnomecanvas, libbonoboui, GConf, libtool
 , gnome_vfs, libgnome_keyring, libglade }:
 
@@ -13,6 +13,14 @@ stdenv.mkDerivation rec {
 
   outputs = [ "out" "dev" ];
 
+  patches = [
+    (fetchpatch {
+      name = "0001-gnome-scores.h-Convert-to-UTF-8.patch";
+      url = https://github.com/GNOME/libgnomeui/commit/30334c28794ef85d8973f4ed0779b5ceed6594f2.diff;
+      sha256 = "1sn8j8dkam14wfkpw8nga3gk63wniff243mzv3jp0fvv52q8sqhk";
+    })
+  ];
+
   nativeBuildInputs = [ pkgconfig intltool ];
   buildInputs =
     [ xorg.xlibsWrapper libxml2 GConf pango glib libgnome_keyring libglade libtool ];
diff --git a/pkgs/desktops/gnome-3/core/evolution-data-server/default.nix b/pkgs/desktops/gnome-3/core/evolution-data-server/default.nix
index 9d51dc969d33..e2472a403699 100644
--- a/pkgs/desktops/gnome-3/core/evolution-data-server/default.nix
+++ b/pkgs/desktops/gnome-3/core/evolution-data-server/default.nix
@@ -16,7 +16,7 @@ stdenv.mkDerivation rec {
   propagatedBuildInputs = [ libsecret nss nspr libical db ];
 
   # uoa irrelevant for now
-  cmakeFlags = [ "-DENABLE_UOA=OFF" "-DENABLE_GOA=OFF" ]
+  cmakeFlags = [ "-DENABLE_UOA=OFF" ]
                    ++ stdenv.lib.optionals valaSupport [
                      "-DENABLE_VALA_BINDINGS=ON" "-DENABLE_INTROSPECTION=ON"
                      "-DCMAKE_SKIP_BUILD_RPATH=OFF" ];
diff --git a/pkgs/desktops/gnome-3/core/gucharmap/default.nix b/pkgs/desktops/gnome-3/core/gucharmap/default.nix
index 39c1181a52ab..58d9901ad012 100644
--- a/pkgs/desktops/gnome-3/core/gucharmap/default.nix
+++ b/pkgs/desktops/gnome-3/core/gucharmap/default.nix
@@ -1,6 +1,7 @@
 { stdenv, intltool, fetchurl, pkgconfig, gtk3
 , glib, desktop_file_utils, bash, appdata-tools
-, makeWrapper, gnome3, file, itstool, libxml2 }:
+, wrapGAppsHook, gnome3, itstool, libxml2
+, callPackage, unzip }:
 
 # TODO: icons and theme still does not work
 # use packaged gnome3.adwaita-icon-theme
@@ -12,17 +13,17 @@ stdenv.mkDerivation rec {
 
   propagatedUserEnvPkgs = [ gnome3.gnome_themes_standard ];
 
-  preConfigure = "substituteInPlace ./configure --replace /usr/bin/file ${file}/bin/file";
+  preConfigure = "patchShebangs gucharmap/gen-guch-unicode-tables.pl";
+
+  nativeBuildInputs = [ pkgconfig wrapGAppsHook unzip ];
 
-  nativeBuildInputs = [ pkgconfig ];
   buildInputs = [ gtk3 intltool itstool glib appdata-tools
-                  gnome3.yelp_tools libxml2 file desktop_file_utils
-                  gnome3.gsettings_desktop_schemas makeWrapper ];
+                  gnome3.yelp_tools libxml2 desktop_file_utils
+                  gnome3.gsettings_desktop_schemas ];
+
+  unicode-data = callPackage ./unicode-data.nix {};
 
-  preFixup = ''
-    wrapProgram "$out/bin/gucharmap" \
-      --prefix XDG_DATA_DIRS : "${gnome3.gnome_themes_standard}/share:$out/share:$GSETTINGS_SCHEMAS_PATH"
-  '';
+  configureFlags = "--with-unicode-data=${unicode-data}";
 
   meta = with stdenv.lib; {
     homepage = https://wiki.gnome.org/Apps/Gucharmap;
diff --git a/pkgs/desktops/gnome-3/core/gucharmap/src.nix b/pkgs/desktops/gnome-3/core/gucharmap/src.nix
index 69c0dd600251..67d00c269f53 100644
--- a/pkgs/desktops/gnome-3/core/gucharmap/src.nix
+++ b/pkgs/desktops/gnome-3/core/gucharmap/src.nix
@@ -1,10 +1,10 @@
 # Autogenerated by maintainers/scripts/gnome.sh update
 
 fetchurl: {
-  name = "gucharmap-3.18.2";
+  name = "gucharmap-10.0.1";
 
   src = fetchurl {
-    url = mirror://gnome/sources/gucharmap/3.18/gucharmap-3.18.2.tar.xz;
-    sha256 = "80141d3e892c3c4812c1a8fad8f89978559ef19e933843267e6e9a5524c09ec9";
+    url = mirror://gnome/sources/gucharmap/10.0/gucharmap-10.0.1.tar.xz;
+    sha256 = "51a2bf91c4590ea2159f828156864f088a0bd4c12e7a1c396002a23d48b2d5e2";
   };
 }
diff --git a/pkgs/desktops/gnome-3/core/gucharmap/unicode-data.nix b/pkgs/desktops/gnome-3/core/gucharmap/unicode-data.nix
new file mode 100644
index 000000000000..84770a17162c
--- /dev/null
+++ b/pkgs/desktops/gnome-3/core/gucharmap/unicode-data.nix
@@ -0,0 +1,44 @@
+{fetchurl, stdenv}:
+stdenv.mkDerivation {
+  name = "unicode-data-10.0.0";
+  srcs = [
+    (fetchurl {
+      url = "http://www.unicode.org/Public/10.0.0/ucd/Blocks.txt";
+      sha256 = "19zf2kd198mcv1paa194c1zf36hay1irbxssi35yi2pd8ad69qas";
+    })
+    (fetchurl {
+      url = "http://www.unicode.org/Public/10.0.0/ucd/DerivedAge.txt";
+      sha256 = "1h9p1g0wnh686l6cqar7cmky465vwc6vjzzn1s7v0i9zcjaqkr4h";
+    })
+    (fetchurl {
+      url = "http://www.unicode.org/Public/10.0.0/ucd/NamesList.txt";
+      sha256 = "0gvpcyq852rnlqmx4y5i1by7bavvcw6rj40i54w48yc7xr3zmgd1";
+    })
+    (fetchurl {
+      url = "http://www.unicode.org/Public/10.0.0/ucd/Scripts.txt";
+      sha256 = "0b9prz2hs6w61afqaplcxnv115f8yk4d5hn9dc5hks8nqpj28bnh";
+    })
+    (fetchurl {
+      url = "http://www.unicode.org/Public/10.0.0/ucd/UnicodeData.txt";
+      sha256 = "1cfak1j753zcrbgixwgppyxhm4w8vda8vxhqymi7n5ljfi6kwhjj";
+    })
+    (fetchurl {
+      url = "http://www.unicode.org/Public/10.0.0/ucd/Unihan.zip";
+      sha256 = "199kz6laypkvc0ykms6d7bkb571jmpds39sv2p7kd5jjm1ij08q1";
+    })
+  ];
+  phases = "installPhase";
+  installPhase = with stdenv.lib; ''
+    mkdir $out
+    for f in $srcs;do
+      cp $f $out/$(stripHash $f)
+    done
+  '';
+  meta = with stdenv.lib; {
+    homepage = http://www.unicode.org/ucd/;
+    description = "Unicode Character Database";
+    maintainers = gnome3.maintainers;
+    license = licenses.mit;
+    platforms = platforms.all;
+  };
+}
diff --git a/pkgs/desktops/gnome-3/core/nautilus/default.nix b/pkgs/desktops/gnome-3/core/nautilus/default.nix
index d508f1483598..f987df460349 100644
--- a/pkgs/desktops/gnome-3/core/nautilus/default.nix
+++ b/pkgs/desktops/gnome-3/core/nautilus/default.nix
@@ -1,6 +1,6 @@
 { stdenv, fetchurl, pkgconfig, libxml2, dbus_glib, shared_mime_info, libexif
 , gtk, gnome3, libunique, intltool, gobjectIntrospection, gnome-autoar, glib
-, libnotify, wrapGAppsHook, exempi, librsvg, tracker, libselinux }:
+, libnotify, wrapGAppsHook, exempi, librsvg, tracker, libselinux, gdk_pixbuf }:
 
 stdenv.mkDerivation rec {
   inherit (import ./src.nix fetchurl) name src;
@@ -16,6 +16,14 @@ stdenv.mkDerivation rec {
   # fatal error: gio/gunixinputstream.h: No such file or directory
   NIX_CFLAGS_COMPILE = "-I${glib.dev}/include/gio-unix-2.0";
 
+  preFixup = ''
+    gappsWrapperArgs+=(
+      # Thumbnailers
+      --prefix XDG_DATA_DIRS : "${gdk_pixbuf}/share"
+      --prefix XDG_DATA_DIRS : "${librsvg}/share"
+    )
+  '';
+
 #  hardeningDisable = [ "format" ];
   enableParallelBuilding = true;
 
diff --git a/pkgs/desktops/gnome-3/misc/libgda/default.nix b/pkgs/desktops/gnome-3/misc/libgda/default.nix
index e9249978d851..f477c13c7bae 100644
--- a/pkgs/desktops/gnome-3/misc/libgda/default.nix
+++ b/pkgs/desktops/gnome-3/misc/libgda/default.nix
@@ -3,6 +3,14 @@
 stdenv.mkDerivation rec {
   inherit (import ./src.nix fetchurl) name src;
 
+  patches = [
+    (fetchurl {
+      name = "libgda-fix-encoding-of-copyright-headers.patch";
+      url = https://bug787685.bugzilla-attachments.gnome.org/attachment.cgi?id=359901;
+      sha256 = "11qj7f7zsiw8jy18vlwz2prlxpg4iq350sws3qwfwsv0lnmncmfq";
+    })
+  ];
+
   configureFlags = [
     "--enable-gi-system-install=no"
   ];