about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/icons/reversal-icon-theme/default.nix77
-rw-r--r--pkgs/data/misc/hackage/pin.json8
2 files changed, 81 insertions, 4 deletions
diff --git a/pkgs/data/icons/reversal-icon-theme/default.nix b/pkgs/data/icons/reversal-icon-theme/default.nix
new file mode 100644
index 000000000000..b636bba4a301
--- /dev/null
+++ b/pkgs/data/icons/reversal-icon-theme/default.nix
@@ -0,0 +1,77 @@
+{ lib
+, stdenvNoCC
+, fetchFromGitHub
+, gtk3
+, jdupes
+, adwaita-icon-theme
+, hicolor-icon-theme
+, numix-icon-theme-circle
+, gitUpdater
+, allColorVariants ? false
+, colorVariants ? []
+}:
+
+let
+  pname = "reversal-icon-theme";
+in
+lib.checkListOfEnum "${pname}: color variants" [ "-blue" "-red" "-pink" "-purple" "-green" "-orange" "-brown" "-grey" "-black" "-cyan" ] colorVariants
+
+stdenvNoCC.mkDerivation rec {
+  inherit pname;
+  version = "unstable-2023-05-13";
+
+  src = fetchFromGitHub {
+    owner = "yeyushengfan258";
+    repo = pname;
+    rev = "bdae2ea365731b25a869fc2c8c6a1fb849eaf5b2";
+    hash = "sha256-Cd+1ggyS+Y2Sk8w5zifc4IFOwbFrbjL6S6awES/W0EE=";
+  };
+
+  nativeBuildInputs = [
+    gtk3
+    jdupes
+  ];
+
+  propagatedBuildInputs = [
+    adwaita-icon-theme
+    hicolor-icon-theme
+    numix-icon-theme-circle
+  ];
+
+  dontDropIconThemeCache = true;
+
+  # These fixup steps are slow and unnecessary for this package.
+  # Package may install many small files.
+  dontPatchELF = true;
+  dontRewriteSymlinks = true;
+
+  postPatch = ''
+    patchShebangs install.sh
+  '';
+
+  installPhase = ''
+    runHook preInstall
+
+    mkdir -p $out/share/icons
+
+    name= ./install.sh \
+      ${if allColorVariants then "-a" else builtins.toString colorVariants} \
+      -d $out/share/icons
+
+    rm $out/share/icons/*/{AUTHORS,COPYING}
+
+    jdupes --quiet --link-soft --recurse $out/share
+
+    runHook postInstall
+  '';
+
+  passthru.updateScript = gitUpdater { };
+
+  meta = with lib; {
+    description = "A colorful Design Rectangle icon theme";
+    homepage = "https://github.com/yeyushengfan258/Reversal-icon-theme";
+    license = licenses.gpl3Plus;
+    platforms = platforms.all;
+    maintainers = with maintainers; [ romildo ];
+  };
+}
diff --git a/pkgs/data/misc/hackage/pin.json b/pkgs/data/misc/hackage/pin.json
index fd0f1b564733..cbfd42dfc874 100644
--- a/pkgs/data/misc/hackage/pin.json
+++ b/pkgs/data/misc/hackage/pin.json
@@ -1,6 +1,6 @@
 {
-  "commit": "d37311b9195c41b254b2d71c74c93e51f6ccebab",
-  "url": "https://github.com/commercialhaskell/all-cabal-hashes/archive/d37311b9195c41b254b2d71c74c93e51f6ccebab.tar.gz",
-  "sha256": "1m2xcnyz6y03m5l5qdxc0avi4gi53g82hq4ab9qcjbxi82g3qn4v",
-  "msg": "Update from Hackage at 2023-10-04T18:27:12Z"
+  "commit": "49d09494dd24eae895fe1260e2c26157f740e451",
+  "url": "https://github.com/commercialhaskell/all-cabal-hashes/archive/49d09494dd24eae895fe1260e2c26157f740e451.tar.gz",
+  "sha256": "1f0m4wni61v6679ya0mb9mw3vxhak9yvjxjm6wfs7wryayb4i5ba",
+  "msg": "Update from Hackage at 2023-10-21T19:49:07Z"
 }