about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/dt/dtcmp/package.nix30
-rw-r--r--pkgs/by-name/li/libcircle/package.nix34
-rw-r--r--pkgs/by-name/ll/llama-cpp/package.nix4
-rw-r--r--pkgs/by-name/lw/lwgrp/package.nix27
-rw-r--r--pkgs/by-name/mp/mpifileutils/package.nix47
-rw-r--r--pkgs/by-name/nn/nncp/package.nix77
-rw-r--r--pkgs/by-name/we/websecprobe/package.nix42
7 files changed, 259 insertions, 2 deletions
diff --git a/pkgs/by-name/dt/dtcmp/package.nix b/pkgs/by-name/dt/dtcmp/package.nix
new file mode 100644
index 000000000000..cd8f54e25d31
--- /dev/null
+++ b/pkgs/by-name/dt/dtcmp/package.nix
@@ -0,0 +1,30 @@
+{ lib, stdenv, fetchFromGitHub, autoreconfHook, pkg-config, mpi, lwgrp }:
+
+stdenv.mkDerivation rec {
+  pname = "dtcmp";
+  version = "1.1.5";
+
+  src = fetchFromGitHub {
+    owner = "LLNL";
+    repo = "dtcmp";
+    rev = "v${version}";
+    hash = "sha256-Dc+c8JCc5D23CtpwiWkHCqngywEZXw7cYsRiSYiQdWk=";
+  };
+
+  outputs = [ "out" "dev" ];
+
+  nativeBuildInputs = [ autoreconfHook pkg-config ];
+  buildInputs = [ lwgrp ];
+
+  configureFlags = [ "--with-lwgrp=${lib.getDev lwgrp}" ];
+
+  propagatedBuildInputs = [ mpi ];
+
+  meta = with lib; {
+    description = "MPI datatype comparison library";
+    homepage = "https://github.com/LLNL/dtcmp";
+    platforms = platforms.linux;
+    license = licenses.bsd3;
+    maintainers = [ maintainers.markuskowa ];
+  };
+}
diff --git a/pkgs/by-name/li/libcircle/package.nix b/pkgs/by-name/li/libcircle/package.nix
new file mode 100644
index 000000000000..d176bbacc89f
--- /dev/null
+++ b/pkgs/by-name/li/libcircle/package.nix
@@ -0,0 +1,34 @@
+{ lib
+, stdenv
+, fetchFromGitHub
+, autoreconfHook
+, pkg-config
+, mpi
+, lwgrp
+}:
+
+stdenv.mkDerivation rec {
+  pname = "libcircle";
+  version = "0.3";
+
+  src = fetchFromGitHub {
+    owner = "hpc";
+    repo = "libcircle";
+    rev = "v${version}";
+    hash = "sha256-EfnoNL6wo6qQES6XzMtpTpYcsJ8V2gy32i26wiTldH0=";
+  };
+
+  outputs = [ "out" "dev" ];
+
+  nativeBuildInputs = [ autoreconfHook pkg-config ];
+
+  propagatedBuildInputs = [ mpi ];
+
+  meta = with lib; {
+    description = "API for distributing embarrassingly parallel workloads using self-stabilization";
+    homepage = "http://hpc.github.io/libcircle/";
+    platforms = platforms.linux;
+    license = licenses.bsd3;
+    maintainers = [ maintainers.markuskowa ];
+  };
+}
diff --git a/pkgs/by-name/ll/llama-cpp/package.nix b/pkgs/by-name/ll/llama-cpp/package.nix
index 1c96f5d83a60..e4782d2eed46 100644
--- a/pkgs/by-name/ll/llama-cpp/package.nix
+++ b/pkgs/by-name/ll/llama-cpp/package.nix
@@ -37,13 +37,13 @@ let
 in
 stdenv.mkDerivation (finalAttrs: {
   pname = "llama-cpp";
-  version = "1469";
+  version = "1483";
 
   src = fetchFromGitHub {
     owner = "ggerganov";
     repo = "llama.cpp";
     rev = "refs/tags/b${finalAttrs.version}";
-    hash = "sha256-budBvpX2SnKekGTWHomvhW+4grB8EPd9OJbufNynHsc=";
+    hash = "sha256-TYklPkqwXLt+80FSHBDA2r3xTXlmgqB7sOt2mNnVNso=";
   };
 
   postPatch = ''
diff --git a/pkgs/by-name/lw/lwgrp/package.nix b/pkgs/by-name/lw/lwgrp/package.nix
new file mode 100644
index 000000000000..c9c657bee32a
--- /dev/null
+++ b/pkgs/by-name/lw/lwgrp/package.nix
@@ -0,0 +1,27 @@
+{ lib, stdenv, fetchFromGitHub, mpi, autoreconfHook }:
+
+stdenv.mkDerivation rec {
+  pname = "lwgrp";
+  version = "1.0.5";
+
+  src = fetchFromGitHub {
+    owner = "LLNL";
+    repo = "lwgrp";
+    rev = "v${version}";
+    hash = "sha256-f0tYn9FbrOz8iMoG8Is8vYDNfYHTfxLKNnyxJA+Msdk=";
+  };
+
+  outputs = [ "out" "dev" ];
+
+  nativeBuildInputs = [ autoreconfHook ];
+
+  propagatedBuildInputs = [ mpi ];
+
+  meta = with lib; {
+    description = "Data structures and operations to group MPI processes as an ordered set";
+    homepage = "https://github.com/LLNL/lwgrp";
+    platforms = platforms.linux;
+    license = licenses.bsd3;
+    maintainers = [ maintainers.markuskowa ];
+  };
+}
diff --git a/pkgs/by-name/mp/mpifileutils/package.nix b/pkgs/by-name/mp/mpifileutils/package.nix
new file mode 100644
index 000000000000..92300592c2fa
--- /dev/null
+++ b/pkgs/by-name/mp/mpifileutils/package.nix
@@ -0,0 +1,47 @@
+{ lib
+, stdenv
+, fetchFromGitHub
+, cmake
+, pkg-config
+, mpi
+, attr
+, dtcmp
+, libarchive
+, libcircle
+, bzip2
+, openssl
+}:
+
+stdenv.mkDerivation rec {
+  pname = "mpifileutils";
+  version = "0.11.1";
+
+  src = fetchFromGitHub {
+    owner = "hpc";
+    repo = "mpifileutils";
+    rev = "v${version}";
+    hash = "sha256-3nls82awMMCwlfafsOy3AY8OvT9sE+BvvsDOY14YvQc=";
+  };
+
+  outputs = [ "out" "dev" "man" ];
+
+  nativeBuildInputs = [ cmake pkg-config ];
+  buildInputs = [
+    attr
+    dtcmp
+    libarchive
+    libcircle
+    bzip2
+    openssl
+  ];
+
+  propagatedBuildInputs = [ mpi ];
+
+  meta = with lib; {
+    description = "Suite of MPI-based tools to manage large datasets";
+    homepage = "https://hpc.github.io/mpifileutils";
+    platforms = platforms.linux;
+    license = licenses.bsd3;
+    maintainers = [ maintainers.markuskowa ];
+  };
+}
diff --git a/pkgs/by-name/nn/nncp/package.nix b/pkgs/by-name/nn/nncp/package.nix
new file mode 100644
index 000000000000..902b78272da0
--- /dev/null
+++ b/pkgs/by-name/nn/nncp/package.nix
@@ -0,0 +1,77 @@
+{ cfgPath ? "/etc/nncp.hjson"
+, curl
+, fetchurl
+, lib
+, genericUpdater
+, go
+, perl
+, stdenv
+, writeShellScript
+}:
+
+stdenv.mkDerivation (finalAttrs: {
+  pname = "nncp";
+  version = "8.10.0";
+  outputs = [ "out" "doc" "info" ];
+
+  src = fetchurl {
+    url = "http://www.nncpgo.org/download/nncp-${finalAttrs.version}.tar.xz";
+    sha256 = "154e13ba15c0ea93f54525793b0699e496b2db7281e1555f08d785a528f3f7fc";
+  };
+
+  nativeBuildInputs = [
+    go
+  ];
+
+  # Build parameters
+  CFGPATH = cfgPath;
+  SENDMAIL = "sendmail";
+
+  preConfigure = "export GOCACHE=$NIX_BUILD_TOP/gocache";
+
+  buildPhase = ''
+    runHook preBuild
+    ./bin/build
+    runHook postBuild
+  '';
+
+  installPhase = ''
+    runHook preInstall
+    PREFIX=$out ./install
+    runHook postInstall
+  '';
+
+  enableParallelBuilding = true;
+
+  passthru.updateScript = genericUpdater {
+    versionLister = writeShellScript "nncp-versionLister" ''
+      ${curl}/bin/curl -s ${finalAttrs.meta.downloadPage} | ${perl}/bin/perl -lne 'print $1 if /Release.*>([0-9.]+)</'
+    '';
+  };
+
+  meta = {
+    broken = stdenv.isDarwin;
+    changelog = "http://www.nncpgo.org/News.html";
+    description = "Secure UUCP-like store-and-forward exchanging";
+    downloadPage = "http://www.nncpgo.org/Tarballs.html";
+    homepage = "http://www.nncpgo.org/";
+    license = lib.licenses.gpl3Only;
+    longDescription = ''
+      This utilities are intended to help build up small size (dozens of
+      nodes) ad-hoc friend-to-friend (F2F) statically routed darknet
+      delay-tolerant networks for fire-and-forget secure reliable files,
+      file requests, Internet mail and commands transmission. All
+      packets are integrity checked, end-to-end encrypted, explicitly
+      authenticated by known participants public keys. Onion encryption
+      is applied to relayed packets. Each node acts both as a client and
+      server, can use push and poll behaviour model.
+
+      Out-of-box offline sneakernet/floppynet, dead drops, sequential
+      and append-only CD-ROM/tape storages, air-gapped computers
+      support. But online TCP daemon with full-duplex resumable data
+      transmission exists.
+    '';
+    maintainers = with lib.maintainers; [ ehmry woffs ];
+    platforms = lib.platforms.all;
+  };
+})
diff --git a/pkgs/by-name/we/websecprobe/package.nix b/pkgs/by-name/we/websecprobe/package.nix
new file mode 100644
index 000000000000..fb81063526cf
--- /dev/null
+++ b/pkgs/by-name/we/websecprobe/package.nix
@@ -0,0 +1,42 @@
+{ lib
+, python3
+, fetchPypi
+}:
+
+python3.pkgs.buildPythonApplication rec {
+  pname = "websecprobe";
+  version = "0.0.10";
+  pyproject = true;
+
+  src = fetchPypi {
+    pname = "WebSecProbe";
+    inherit version;
+    hash = "sha256-QvXOyQUptMyim/bgvhihjgGs7vX0qX8MqK2ol8q9ePc=";
+  };
+
+  nativeBuildInputs = with python3.pkgs; [
+    setuptools
+    wheel
+  ];
+
+  propagatedBuildInputs = with python3.pkgs; [
+    requests
+    tabulate
+  ];
+
+  postInstall = ''
+    mv $out/bin/WebSecProbe $out/bin/$pname
+  '';
+
+  pythonImportsCheck = [
+    "WebSecProbe"
+  ];
+
+  meta = with lib; {
+    description = "Web Security Assessment Tool";
+    homepage = "https://github.com/spyboy-productions/WebSecProbe/";
+    license = licenses.mit;
+    maintainers = with maintainers; [ fab ];
+    mainProgram = "websecprobe";
+  };
+}