about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/ladspa-plugins/default.nix45
-rw-r--r--pkgs/applications/audio/qjackctl/default.nix18
-rw-r--r--pkgs/applications/audio/sonic-visualizer/default.nix32
-rw-r--r--pkgs/applications/graphics/exrdisplay/default.nix24
-rw-r--r--pkgs/applications/misc/freemind/default.nix40
-rw-r--r--pkgs/applications/misc/rxvt_unicode/default.nix33
-rw-r--r--pkgs/applications/misc/xneur/0.8.nix20
-rw-r--r--pkgs/applications/misc/xneur/default.nix22
-rw-r--r--pkgs/applications/misc/yate/default.nix34
-rw-r--r--pkgs/applications/networking/twinkle/default.nix22
-rw-r--r--pkgs/applications/office/scribus/default.nix22
-rw-r--r--pkgs/applications/science/biology/arb/default.nix28
-rw-r--r--pkgs/applications/video/cinelerra/default.nix35
13 files changed, 192 insertions, 183 deletions
diff --git a/pkgs/applications/audio/ladspa-plugins/default.nix b/pkgs/applications/audio/ladspa-plugins/default.nix
index 17174fbebbf8..94e1e72d0f55 100644
--- a/pkgs/applications/audio/ladspa-plugins/default.nix
+++ b/pkgs/applications/audio/ladspa-plugins/default.nix
@@ -1,27 +1,22 @@
-args: with args;
-	let localDefs = builderDefs.passthru.function {
-		src = 
-		fetchurl {
-			url = http://plugin.org.uk/releases/0.4.15/swh-plugins-0.4.15.tar.gz;
-			sha256 = "0h462s4mmqg4iw7zdsihnrmz2vjg0fd49qxw2a284bnryjjfhpnh";
-		};
-		buildInputs = [fftw ladspaH pkgconfig];
-		configureFlags = [];
-	};
-	in with localDefs;
-let
-	postInstall = fullDepEntry ("
-		ensureDir \$out/share/ladspa/
-		ln -s \$out/lib/ladspa \$out/share/ladspa/lib
-	") [minInit defEnsureDir];
-in
+{ stdenv, fetchurl, fftw, ladspaH, pkgconfig }:
+
 stdenv.mkDerivation {
-	name = "swh-plugins-0.4.15";
-	builder = writeScript "swh-plugins-0.4.15-builder"
-		(textClosure localDefs [doConfigure doMakeInstall 
-			postInstall doForceShare]);
-	meta = {
-		description = "LADSPA format audio plugins";
-		inherit src;
-	};
+  name = "swh-plugins-0.4.15";
+
+  src = fetchurl {
+    url = http://plugin.org.uk/releases/0.4.15/swh-plugins-0.4.15.tar.gz;
+    sha256 = "0h462s4mmqg4iw7zdsihnrmz2vjg0fd49qxw2a284bnryjjfhpnh";
+  };
+  
+  buildInputs = [fftw ladspaH pkgconfig];
+
+  postInstall =
+    ''
+      ensureDir $out/share/ladspa/
+      ln -s $out/lib/ladspa $out/share/ladspa/lib
+    '';
+
+  meta = {
+    description = "LADSPA format audio plugins";
+  };
 }
diff --git a/pkgs/applications/audio/qjackctl/default.nix b/pkgs/applications/audio/qjackctl/default.nix
index 828fdc0bdde6..dbe32f862f26 100644
--- a/pkgs/applications/audio/qjackctl/default.nix
+++ b/pkgs/applications/audio/qjackctl/default.nix
@@ -1,20 +1,20 @@
-args:
-args.stdenv.mkDerivation {
-
-  # some dependencies such as killall have to be installed additionally
+{ stdenv, fetchurl, qt4, alsaLib, jackaudio }:
 
+stdenv.mkDerivation {
   name = "qjackctl-0.3.3";
 
-  src = args.fetchurl {
+  # some dependencies such as killall have to be installed additionally
+
+  src = fetchurl {
     url = http://downloads.sourceforge.net/qjackctl/qjackctl-0.3.3.tar.gz;
     sha256 = "1z9v208fs79ka6ni3p5v5xb0k5y1wqqm2a9cf903387b9p3fhpxj";
   };
 
-  buildInputs =(with args; [qt4 alsaLib jackaudio]);
+  buildInputs = [ qt4 alsaLib jackaudio ];
 
   meta = { 
-      description = "qt jackd control gui tool";
-      homepage = http://qjackctl.sourceforge.net/;
-      license = "GPL";
+    description = "qt jackd control gui tool";
+    homepage = http://qjackctl.sourceforge.net/;
+    license = "GPL";
   };
 }
diff --git a/pkgs/applications/audio/sonic-visualizer/default.nix b/pkgs/applications/audio/sonic-visualizer/default.nix
index 08b300b1c115..6e40baa1c360 100644
--- a/pkgs/applications/audio/sonic-visualizer/default.nix
+++ b/pkgs/applications/audio/sonic-visualizer/default.nix
@@ -1,11 +1,10 @@
 # TODO add plugins having various licenses, see http://www.vamp-plugins.org/download.html
 
-args: with args;
+{ stdenv, fetchurl, libsndfile, qt, fftw, librdf, rubberband
+, libsamplerate, vampSDK, alsaLib, librdf_raptor, librdf_rasqal
+, redland, jackaudio, pulseaudio, libmad, libogg, liblo, bzip2 }:
 
 stdenv.mkDerivation {
-
-#TODO add plugins!
-
   name = "sonic-visualizer-1.6";
 
   src = fetchurl {
@@ -13,16 +12,17 @@ stdenv.mkDerivation {
     sha256 = "1dbqqa7anii2jnjpfwm4sr83nn4bwmz68xw4n6clycsz5iqk52f5";
   };
 
-  buildInputs = [libsndfile qt fftw /* should be fftw3f ??*/ bzip2 librdf rubberband
-    libsamplerate vampSDK alsaLib librdf_raptor librdf_rasqal redland
-    # optional
-    jackaudio
-    # portaudio
-    pulseaudio
-    libmad
-    libogg # ?
-    # fishsound
-    liblo
+  buildInputs =
+    [ libsndfile qt fftw /* should be fftw3f ??*/ bzip2 librdf rubberband
+      libsamplerate vampSDK alsaLib librdf_raptor librdf_rasqal redland
+      # optional
+      jackaudio
+      # portaudio
+      pulseaudio
+      libmad
+      libogg # ?
+      # fishsound
+      liblo
     ];
 
   buildPhase = ''
@@ -39,7 +39,7 @@ stdenv.mkDerivation {
     description = "View and analyse contents of music audio files";
     homepage = http://www.sonicvisualiser.org/;
     license = "GPLv2";
-    maintainers = [args.lib.maintainers.marcweber];
-    platforms = args.lib.platforms.linux;
+    maintainers = [ stdenv.lib.maintainers.marcweber ];
+    platforms = stdenv.lib.platforms.linux;
   };
 }
diff --git a/pkgs/applications/graphics/exrdisplay/default.nix b/pkgs/applications/graphics/exrdisplay/default.nix
index 6a8b3d6499bd..65c86a6cf97a 100644
--- a/pkgs/applications/graphics/exrdisplay/default.nix
+++ b/pkgs/applications/graphics/exrdisplay/default.nix
@@ -1,8 +1,8 @@
-args: with args;
+{ stdenv, fetchurl, pkgconfig, fltk, openexr, mesa, which, openexr_ctl }:
 
 assert fltk.glSupport;
-stdenv.mkDerivation {
 
+stdenv.mkDerivation {
   name ="openexr_viewers-1.0.1";
 
   src = fetchurl {
@@ -10,18 +10,18 @@ stdenv.mkDerivation {
     sha256 = "1w5qbcdp7sw48z1wk2v07f7p14vqqb1m2ncxyxnbkm9f4ab0ymg6";
   };
 
-  inherit fltk mesa;
-
-  configurePhase = "
-    # don't know why.. adding these flags it works
-    #export CXXFLAGS=`fltk-config --use-gl --cxxflags --ldflags`
-    ./configure --prefix=\$out --with-fltk-config=\$fltk/bin/fltk-config";
+  configurePhase =
+    ''
+      # don't know why.. adding these flags it works
+      #export CXXFLAGS=`fltk-config --use-gl --cxxflags --ldflags`
+      ./configure --prefix=$out --with-fltk-config=${fltk}/bin/fltk-config
+    '';
 
-  buildInputs = [openexr fltk pkgconfig mesa which openexr_ctl];
+  buildInputs = [ openexr fltk pkgconfig mesa which openexr_ctl ];
 
   meta = { 
-      description = "tool to view OpenEXR images";
-      homepage = http://openexr.com;
-      license = "BSD-like";
+    description = "Tool to view OpenEXR images";
+    homepage = http://openexr.com;
+    license = "BSD-like";
   };
 }
diff --git a/pkgs/applications/misc/freemind/default.nix b/pkgs/applications/misc/freemind/default.nix
index f0e5f6ab0780..dd6f205eca88 100644
--- a/pkgs/applications/misc/freemind/default.nix
+++ b/pkgs/applications/misc/freemind/default.nix
@@ -1,4 +1,5 @@
-args: with args;
+{ stdenv, fetchurl, jdk, jre, ant, coreutils, gnugrep }:
+
 stdenv.mkDerivation {
   name = "freemind-0.9.0_RC_6";
 
@@ -7,43 +8,44 @@ stdenv.mkDerivation {
     sha256 = "0qxpwqmb4xd8c83zh76gczmx0hsx5m209k7p60kh7c4f25snhngf";
   };
 
-  buildInputs = [jdk ant];
+  buildInputs = [ jdk ant ];
 
-  phases="unpackPhase patchPhase buildPhase installPhase";
+  phases = "unpackPhase patchPhase buildPhase installPhase";
 
-  patchPhase=''
+  patchPhase = ''
     # There is a complain about this. I don't understand it.
     mkdir plugins/plugins
   '';
 
   buildPhase="ant dist";
-# LIBXCB_ALLOW_SLOPPY_LOCK=true :
-# don't know yet what this option really means but I'm no longer getting
-#   Checking Java Version...
-#   Locking assertion failure.  Backtrace:
-#   java: xcb_xlib.c:82: xcb_xlib_unlock: Assertion `c->xlib.lock' failed
-# this way
-# reference and more info https://bugs.launchpad.net/ubuntu/+source/sun-java5/+bug/86103
-# JDK 7 beta seems to have fixed this (bug ?)
-
-  installPhase=''
+  
+  # LIBXCB_ALLOW_SLOPPY_LOCK=true :
+  # don't know yet what this option really means but I'm no longer getting
+  #   Checking Java Version...
+  #   Locking assertion failure.  Backtrace:
+  #   java: xcb_xlib.c:82: xcb_xlib_unlock: Assertion `c->xlib.lock' failed
+  # this way
+  # reference and more info https://bugs.launchpad.net/ubuntu/+source/sun-java5/+bug/86103
+  # JDK 7 beta seems to have fixed this (bug ?)
+
+  installPhase = ''
     ensureDir $out/{bin,nix-support}
     cp -r ../bin/dist $out/nix-support
     sed -i 's/which/type -p/' $out/nix-support/dist/freemind.sh
     cat > $out/bin/freemind << EOF
     #!/bin/sh
-    export PATH=${args.coreutils}/bin:${args.gnugrep}/bin:"$PATH"
+    export PATH=${coreutils}/bin:${gnugrep}/bin:"$PATH"
     export JAVA_HOME="${jre}"
     export LIBXCB_ALLOW_SLOPPY_LOCK=true
     $out/nix-support/dist/freemind.sh
     EOF
 
     chmod +x $out/{bin/freemind,nix-support/dist/freemind.sh}
-    '';
+  '';
 
   meta = {
-      description = "mind mapping software";
-      homepage = http://freemind.sourceforge.net/wiki/index.php/Main_Page;
-      license = "GPL";
+    description = "Mind-mapping software";
+    homepage = http://freemind.sourceforge.net/wiki/index.php/Main_Page;
+    license = "GPL";
   }; 
 }
diff --git a/pkgs/applications/misc/rxvt_unicode/default.nix b/pkgs/applications/misc/rxvt_unicode/default.nix
index 74eead5e782c..029d8675ddf6 100644
--- a/pkgs/applications/misc/rxvt_unicode/default.nix
+++ b/pkgs/applications/misc/rxvt_unicode/default.nix
@@ -1,11 +1,11 @@
-args: with args;
-# args.perlSupport: enables perl interpreter support
-# see man urxvtperl for details
+{ stdenv, fetchurl, perlSupport, libX11, libXt, libXft, ncurses, perl }:
+
 let 
   name = "rxvt-unicode";
   version = "9.07";
   n = "${name}-${version}";
 in
+
 stdenv.mkDerivation (rec {
 
   name = "${n}${if perlSupport then "-with-perl" else ""}";
@@ -15,26 +15,25 @@ stdenv.mkDerivation (rec {
     sha256 = "18y5mb3cm1gawjm723q5r7yk37s9drzg39kna036i694m2667865";
   };
 
-  buildInputs = [ libX11 libXt libXft ncurses /* required to build the terminfo file */ ]
-          ++ lib.optional perlSupport perl;
+  buildInputs =
+    [ libX11 libXt libXft ncurses /* required to build the terminfo file */ ]
+    ++ stdenv.lib.optional perlSupport perl;
 
-  preConfigure=''
-    configureFlags="${if perlSupport then "--enable-perl" else "--disable-perl"}";
-    export TERMINFO=$out/share/terminfo # without this the terminfo won't be compiled by tic, see man tic
-  ''
-  # make urxvt find its perl file lib/perl5/site_perl is added to PERL5LIB automatically
-  + (if perlSupport then ''
+  preConfigure =
+    ''
+      configureFlags="${if perlSupport then "--enable-perl" else "--disable-perl"}";
+      export TERMINFO=$out/share/terminfo # without this the terminfo won't be compiled by tic, see man tic
+    ''
+    # make urxvt find its perl file lib/perl5/site_perl is added to PERL5LIB automatically
+    + stdenv.lib.optionalString perlSupport ''
       ensureDir $out/lib/perl5
       ln -s $out/{lib/urxvt,lib/perl5/site_perl}
-  '' else "");
-
-  postInstall = ''
-  '';
+    '';
 
   meta = {
-    description = "rxvt-unicode is a clone of the well known terminal emulator rxvt.";
+    description = "A clone of the well-known terminal emulator rxvt";
     longDescription = "
-      you should put this into your .bashrc
+      You should put this into your ~/.bashrc:
       export TERMINFO=~/.nix-profile/share/terminfo
     ";
     homepage = "http://software.schmorp.de/pkg/rxvt-unicode.html";
diff --git a/pkgs/applications/misc/xneur/0.8.nix b/pkgs/applications/misc/xneur/0.8.nix
index b4279bccbe5c..af942529d32f 100644
--- a/pkgs/applications/misc/xneur/0.8.nix
+++ b/pkgs/applications/misc/xneur/0.8.nix
@@ -1,26 +1,28 @@
-args: with args;
+{ stdenv, fetchurl, pkgconfig, pcre, GStreamer, glib, libxml2, aspell
+, imlib2, xorg, xosd }:
 
 stdenv.mkDerivation {
   name = "xneur-0.8.0";
+  
   src = fetchurl {
     url = http://dists.xneur.ru/release-0.8.0/tgz/xneur-0.8.0.tar.bz2;
     sha256 = "1f05bm4vqdrlm8rxwgqv89k5lhc236xg841aw4snw514g0hi2sl8";
   };
 
-  buildInputs = [libX11 pkgconfig pcre GStreamer glib libxml2 aspell
-    libXpm imlib2 xosd libXt libXext];
-
-  inherit aspell imlib2 xosd;
+  buildInputs =
+    [ xorg.libX11 pkgconfig pcre GStreamer glib libxml2 aspell
+      xorg.libXpm imlib2 xosd xorg.libXt xorg.libXext
+    ];
 
   preConfigure = ''
     sed -e 's/-Werror//' -i configure
-    sed -e 's/for aspell_dir in/for aspell_dir in $aspell /' -i configure
-    sed -e 's/for imlib2_dir in/for imlib2_dir in $imlib2 /' -i configure
-    sed -e 's/for xosd_dir in/for xosd_dir in $xosd /' -i configure
+    sed -e 's/for aspell_dir in/for aspell_dir in ${aspell} /' -i configure
+    sed -e 's/for imlib2_dir in/for imlib2_dir in ${imlib2} /' -i configure
+    sed -e 's/for xosd_dir in/for xosd_dir in ${xosd} /' -i configure
   '';
 
   meta = {
-    description = "xneur is the keyboard layout switcher.";
+    description = "Utility for switching between keyboard layouts";
   };
 
 }
diff --git a/pkgs/applications/misc/xneur/default.nix b/pkgs/applications/misc/xneur/default.nix
index 5a4bdefdea5a..e341ae6cd055 100644
--- a/pkgs/applications/misc/xneur/default.nix
+++ b/pkgs/applications/misc/xneur/default.nix
@@ -1,4 +1,5 @@
-args: with args;
+{ stdenv, fetchurl, pkgconfig, xorg, pcre, GStreamer, glib, libxml2
+, aspell, cairo, imlib2, xosd, libnotify, gtk, pango, atk }:
 
 let s = import ./src-for-default.nix; in
 
@@ -9,17 +10,17 @@ stdenv.mkDerivation rec {
     sha256 = s.hash;
   };
 
-  buildInputs = [libX11 pkgconfig pcre GStreamer glib libxml2 aspell
-    libXpm imlib2 xosd libXt libXext libXi libnotify gtk pango
-    cairo];
-
-  inherit aspell imlib2 xosd;
+  buildInputs =
+    [ xorg.libX11 pkgconfig pcre GStreamer glib libxml2 aspell cairo
+      xorg.libXpm imlib2 xosd xorg.libXt xorg.libXext xorg.libXi libnotify
+      gtk pango
+    ];
 
   preConfigure = ''
     sed -e 's/-Werror//' -i configure
-    sed -e 's/for aspell_dir in/for aspell_dir in $aspell /' -i configure
-    sed -e 's/for imlib2_dir in/for imlib2_dir in $imlib2 /' -i configure
-    sed -e 's/for xosd_dir in/for xosd_dir in $xosd /' -i configure
+    sed -e 's/for aspell_dir in/for aspell_dir in ${aspell} /' -i configure
+    sed -e 's/for imlib2_dir in/for imlib2_dir in ${imlib2} /' -i configure
+    sed -e 's/for xosd_dir in/for xosd_dir in ${xosd} /' -i configure
 
     export NIX_CFLAGS_COMPILE="$NIX_CFLAGS_COMPILE -I${gtk}/include/gtk-2.0"
     export NIX_CFLAGS_COMPILE="$NIX_CFLAGS_COMPILE -I${gtk}/lib/gtk-2.0/include"
@@ -31,11 +32,10 @@ stdenv.mkDerivation rec {
   '';
 
   meta = {
-    description = "xneur is the keyboard layout switcher.";
+    description = "Utility for switching between keyboard layouts";
     homepage = http://xneur.ru;
     license = "GPL2+";
     maintainers = [ stdenv.lib.maintainers.raskin ];
     platforms = stdenv.lib.platforms.linux;
   };
-
 }
diff --git a/pkgs/applications/misc/yate/default.nix b/pkgs/applications/misc/yate/default.nix
index 4f793b04fc85..2994ca190652 100644
--- a/pkgs/applications/misc/yate/default.nix
+++ b/pkgs/applications/misc/yate/default.nix
@@ -1,9 +1,8 @@
-args: with args;
+{ composableDerivation, fetchurl, lib, qt, openssl, autoconf, automake, pkgconfig }:
 
-let inherit (args.composableDerivation) composableDerivation edf wwf; in
-
-composableDerivation {} ( fixed : {
+let inherit (composableDerivation) edf wwf; in
 
+composableDerivation.composableDerivation {} ( fixed : {
   name = "yate2";
 
   src = fetchurl {
@@ -12,28 +11,29 @@ composableDerivation {} ( fixed : {
   };
 
   # TODO zaptel ? postgres ?
-  buildInputs = [qt openssl autoconf automake pkgconfig];
+  buildInputs = [ qt openssl autoconf automake pkgconfig ];
 
   # /dev/null is used when linking which is a impure path for the wrapper
-  preConfigure = "
-  
-  sed -i 's@,/dev/null@@' configure
-  "; 
+  preConfigure =
+    ''
+      sed -i 's@,/dev/null@@' configure
+    ''; 
 
   # --unresolved-symbols=ignore-in-shared-libs makes ld no longer find --library=yate? Why?
-  preBuild = ''
-    export NIX_LDFLAGS="-L$TMP/yate $NIX_LDFLAGS"
-    find . -type f -iname Makefile | xargs sed -i \
-      -e 's@-Wl,--unresolved-symbols=ignore-in-shared-libs@@' \
-      -e 's@-Wl,--retain-symbols-file@@'
-  '';
+  preBuild =
+    ''
+      export NIX_LDFLAGS="-L$TMP/yate $NIX_LDFLAGS"
+      find . -type f -iname Makefile | xargs sed -i \
+        -e 's@-Wl,--unresolved-symbols=ignore-in-shared-libs@@' \
+        -e 's@-Wl,--retain-symbols-file@@'
+    '';
 
   meta = { 
     description = "YATE - Yet Another Telephony Engine";
     homepage = http://yate.null.ro/;
     license = ["GPL" "MPL"]; # Yate's license is GPL with an exception for linking with OpenH323 and PWlib (licensed under MPL).
-    maintainers = [args.lib.maintainers.marcweber];
-    platforms = args.lib.platforms.linux;
+    maintainers = [ lib.maintainers.marcweber ];
+    platforms = lib.platforms.linux;
   };
 
 } )
diff --git a/pkgs/applications/networking/twinkle/default.nix b/pkgs/applications/networking/twinkle/default.nix
index 04141a51984f..905f7efc43ab 100644
--- a/pkgs/applications/networking/twinkle/default.nix
+++ b/pkgs/applications/networking/twinkle/default.nix
@@ -1,4 +1,7 @@
-args: with args;
+{ stdenv, fetchurl, pkgconfig, commoncpp2, ccrtp, openssl, boost
+, libsndfile, libxml2, libjpeg, readline, qt, perl, file
+, alsaLib, speex, libzrtpcpp, xorg }:
+        
 stdenv.mkDerivation {
   name = "twinkle-1.4.2";
 
@@ -9,19 +12,18 @@ stdenv.mkDerivation {
 
   configureFlags = "--with-extra-includes=${libjpeg}/include";
 
-  buildInputs = [pkgconfig commoncpp2 ccrtp openssl boost libsndfile
-    libxml2 libjpeg readline qt libjpeg perl file
-    # optional ? :
-    alsaLib
-    speex libzrtpcpp libX11 libXaw libICE libXext
+  buildInputs =
+    [ pkgconfig commoncpp2 ccrtp openssl boost libsndfile
+      libxml2 libjpeg readline qt perl file
+      # optional ? :
+      alsaLib
+      speex libzrtpcpp xorg.libX11 xorg.libXaw xorg.libICE xorg.libXext
     ];
 
-
   meta = { 
-    description = "softphone for your voice over IP";
     homepage = http://www.xs4all.nl/~mfnboer/twinkle/index.html;
     license = "GPL";
-    maintainers = [args.lib.maintainers.marcweber];
-    platforms = args.lib.platforms.linux;
+    maintainers = [ stdenv.lib.maintainers.marcweber ];
+    platforms = stdenv.lib.platforms.linux;
   };
 }
diff --git a/pkgs/applications/office/scribus/default.nix b/pkgs/applications/office/scribus/default.nix
index 93f8fd79fb1e..8123f8717a8e 100644
--- a/pkgs/applications/office/scribus/default.nix
+++ b/pkgs/applications/office/scribus/default.nix
@@ -1,4 +1,6 @@
-args: with args;
+{ stdenv, fetchurl, pkgconfig, freetype, lcms, libtiff, libxml2
+, libart_lgpl, qt, python, cups, fontconfig, libjpeg
+, zlib, libpng, xorg, cairo, cmake }:
 
 assert stdenv.gcc.gcc != null;
 
@@ -8,13 +10,9 @@ assert stdenv.gcc.gcc != null;
 # will be released with the next version of scribus - So don't miss them
 # when upgrading this package
 
-#let useCairo = true;
-let useCairo = false;
-
-in
+let useCairo = false; in
 
 stdenv.mkDerivation {
-
   name = "scribus-1.3.3.14";
 
   src = fetchurl {
@@ -35,9 +33,9 @@ stdenv.mkDerivation {
   buildInputs =
     [ pkgconfig /*<- required fro cairo only?*/ cmake freetype lcms libtiff libxml2 libart_lgpl qt
       python cups fontconfig
-      libXaw libXext libX11 libXtst libXi libXinerama
-      libjpeg libtiff zlib libpng
-    ] ++ lib.optional useCairo cairo;
+      xorg.libXaw xorg.libXext xorg.libX11 xorg.libXtst xorg.libXi xorg.libXinerama
+      libjpeg zlib libpng
+    ] ++ stdenv.lib.optional useCairo cairo;
 
   # fix rpath which is removed by cmake..
   postFixup = ''
@@ -49,9 +47,9 @@ stdenv.mkDerivation {
   '';
 
   meta = {
-    maintainers = [lib.maintainers.marcweber];
-    platforms = lib.platforms.linux;
-    description = "Desktop Publishing (DTP) and Layout program for Linux.";
+    maintainers = [ stdenv.lib.maintainers.marcweber ];
+    platforms = stdenv.lib.platforms.linux;
+    description = "Desktop Publishing (DTP) and Layout program for Linux";
     homepage = http://www.scribus.net;
     license = "GPLv2";
   };
diff --git a/pkgs/applications/science/biology/arb/default.nix b/pkgs/applications/science/biology/arb/default.nix
index 4a732e7750cc..4543fce48160 100644
--- a/pkgs/applications/science/biology/arb/default.nix
+++ b/pkgs/applications/science/biology/arb/default.nix
@@ -1,4 +1,5 @@
-args: with args;
+{ stdenv, fetchurl, glew, mesa, libpng, lesstif, lynx, freeglut
+, libtiff, rxp, sablotron, perl, jdk, transfig, gv, gnuplot, xorg }:
 
 # NOTE: This package does not build on 64-bit systems. Because of some faulty
 # int->pointer arithmatic. The build scripts are abnormal - but it appears to
@@ -6,6 +7,7 @@ args: with args;
 
 stdenv.mkDerivation {
   name = "arb-2007-Dec-07";
+  
   src = fetchurl {
     url = http://download.arb-home.de/release/2007_12_07/arbsrc.tgz;
     sha256 = "04l7qj0wigg1h56a9d70hxhdr343v3dg5dhqrc7fahc1v4h8f1rd";
@@ -13,7 +15,11 @@ stdenv.mkDerivation {
 
   patches = [ ./makefile.patch ];
 
-  buildInputs = [ glew mesa libpng libXpm lesstif lynx freeglut libtiff rxp sablotron libXaw perl jdk transfig libX11 libXext libXt gv gnuplot ];
+  buildInputs =
+    [ glew mesa libpng xorg.libXpm lesstif lynx freeglut libtiff rxp
+      sablotron xorg.libXaw perl jdk transfig xorg.libX11 xorg.libXext
+      xorg.libXt gv gnuplot
+    ];
 
   unpackPhase = ''
     tar xzf $src
@@ -49,20 +55,22 @@ stdenv.mkDerivation {
     chmod a+rwx $shareddir/lib/pixmaps
     # bulk copy
     cp -vau * $out
+    
     # replace arb script
     mv $out/bin/arb $out/bin/arb.orig
     cat > $out/bin/arb << ARB 
-#!/bin/sh
+    #!/bin/sh
 
-echo Starting Nix compiled arb from $out
-echo Shared databases are located in $shareddir
-# sometimes local profiles override these:
-export ARBHOME=$out
-export LD_LIBRARY=$ARBHOME/lib   
+    echo Starting Nix compiled arb from $out
+    echo Shared databases are located in $shareddir
+    # sometimes local profiles override these:
+    export ARBHOME=$out
+    export LD_LIBRARY=$ARBHOME/lib   
 
-$out/bin/arb_ntree $*
+    $out/bin/arb_ntree $*
 
-ARB
+    ARB
+    
     chmod +x $out/bin/arb
   '';
 
diff --git a/pkgs/applications/video/cinelerra/default.nix b/pkgs/applications/video/cinelerra/default.nix
index 7d8b2dca2721..58a84d91b83e 100644
--- a/pkgs/applications/video/cinelerra/default.nix
+++ b/pkgs/applications/video/cinelerra/default.nix
@@ -1,6 +1,11 @@
-args:
-with args;
-args.stdenv.mkDerivation {
+{ stdenv, fetchurl, sourceFromHead, autoconf, automake, libtool
+, pkgconfig, faad2, faac, a52dec, alsaLib, fftw, lame, libavc1394
+, libiec61883, libraw1394, libsndfile, libvorbis, libogg, libjpeg
+, libtiff, freetype, mjpegtools, x264, gettext, openexr, esound 
+, libXxf86vm, libXv, libXi, libX11, xextproto, libtheora, libpng
+, libdv, nasm, perl, e2fsprogs }:
+        
+stdenv.mkDerivation {
   name = "cinelerra-git";
 
   # REGION AUTO UPDATE:    { name="cinelerra"; type="git"; url="git://git.cinelerra.org/j6t/cinelerra.git"; }
@@ -8,35 +13,33 @@ args.stdenv.mkDerivation {
                (fetchurl { url = "http://mawercer.de/~nix/repos/cinelerra-9f9adf2ad5472886d5bc43a05c6aa8077cabd967.tar.gz"; sha256 = "0b264e2a770d2257550c9a23883a060afcaff12293fe43828954e7373f5f4fb4"; });
   # END
 
-  perl = args.perl;
-
   # touch confi.rpath: work around bug in automake 1.10 ?
   preConfigure = ''
-    find -type f -print0 | xargs --null sed -e "s@/usr/bin/perl@$perl/bin/perl@" -i
+    find -type f -print0 | xargs --null sed -e "s@/usr/bin/perl@${perl}/bin/perl@" -i
     touch config.rpath
     ./autogen.sh
-    '';
-  configureOptions = ["--enable-freetype2"];
+  '';
+  
+  configureFlags = [ "--enable-freetype2" ];
 
-  buildInputs =(with args; [
-      automake
+  buildInputs =
+    [ automake
       autoconf libtool pkgconfig
       faad2 faac
       a52dec alsaLib   fftw lame libavc1394 libiec61883
       libraw1394 libsndfile libvorbis libogg libjpeg libtiff freetype
       mjpegtools x264 gettext openexr esound 
-      #
       libXxf86vm libXv libXi libX11 xextproto
       libtheora libpng libdv
       nasm
       perl
       e2fsprogs
-  ]);
+    ];
 
   meta = { 
-      description = "Cinelerra - Video Editor";
-      homepage = http://www.cinelerra.org;
-      maintainers = [lib.maintainers.marcweber];
-      license = "GPLv2";
+    description = "Cinelerra - Video Editor";
+    homepage = http://www.cinelerra.org;
+    maintainers = [ stdenv.lib.maintainers.marcweber ];
+    license = "GPLv2";
   };
 }