about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/ladspa-plugins/default.nix2
-rw-r--r--pkgs/applications/misc/hello/ex-2/default.nix2
-rw-r--r--pkgs/applications/misc/mysql-workbench/default.nix4
-rw-r--r--pkgs/applications/misc/xneur/default.nix4
-rw-r--r--pkgs/applications/misc/xneur/src-for-default.nix8
-rw-r--r--pkgs/applications/networking/browsers/chromium/default.nix57
-rw-r--r--pkgs/applications/networking/ekiga/default.nix2
-rw-r--r--pkgs/applications/networking/instant-messengers/gajim/default.nix4
-rw-r--r--pkgs/applications/science/electronics/verilog/default.nix2
-rw-r--r--pkgs/applications/science/logic/cvc3/default.nix54
-rw-r--r--pkgs/applications/science/logic/iprover/default.nix58
-rw-r--r--pkgs/applications/science/logic/isabelle/default.nix4
-rw-r--r--pkgs/applications/science/logic/isabelle/settings.patch2
-rw-r--r--pkgs/applications/science/logic/leo2/default.nix62
-rw-r--r--pkgs/applications/science/logic/minisat/default.nix57
-rw-r--r--pkgs/applications/science/logic/opensmt/default.nix51
-rw-r--r--pkgs/applications/science/logic/satallax/default.nix72
-rw-r--r--pkgs/applications/science/logic/spass/default.nix49
-rw-r--r--pkgs/applications/science/math/pari/default.nix50
-rw-r--r--pkgs/applications/science/math/singular/default.nix61
-rw-r--r--pkgs/applications/version-management/subversion/default.nix7
-rw-r--r--pkgs/applications/video/kmplayer/default.nix6
-rw-r--r--pkgs/applications/virtualization/virtualbox/guest-additions/default.nix14
-rw-r--r--pkgs/applications/window-managers/openbox/default.nix18
24 files changed, 584 insertions, 66 deletions
diff --git a/pkgs/applications/audio/ladspa-plugins/default.nix b/pkgs/applications/audio/ladspa-plugins/default.nix
index 94e1e72d0f55..1557913f4017 100644
--- a/pkgs/applications/audio/ladspa-plugins/default.nix
+++ b/pkgs/applications/audio/ladspa-plugins/default.nix
@@ -13,7 +13,7 @@ stdenv.mkDerivation {
   postInstall =
     ''
       ensureDir $out/share/ladspa/
-      ln -s $out/lib/ladspa $out/share/ladspa/lib
+      ln -sv $out/lib/ladspa $out/share/ladspa/lib
     '';
 
   meta = {
diff --git a/pkgs/applications/misc/hello/ex-2/default.nix b/pkgs/applications/misc/hello/ex-2/default.nix
index a7cf2b19762f..62b0059c7ac4 100644
--- a/pkgs/applications/misc/hello/ex-2/default.nix
+++ b/pkgs/applications/misc/hello/ex-2/default.nix
@@ -2,6 +2,8 @@
 
 stdenv.mkDerivation rec {
   name = "hello-2.6";
+
+  x = 108;
   
   src = fetchurl {
     url = "mirror://gnu/hello/${name}.tar.gz";
diff --git a/pkgs/applications/misc/mysql-workbench/default.nix b/pkgs/applications/misc/mysql-workbench/default.nix
index f3aac956c366..e373392155a7 100644
--- a/pkgs/applications/misc/mysql-workbench/default.nix
+++ b/pkgs/applications/misc/mysql-workbench/default.nix
@@ -6,12 +6,12 @@
 
 stdenv.mkDerivation rec {
   pname = "mysql-workbench";
-  version = "5.2.28";
+  version = "5.2.30";
   name = "${pname}-${version}";
 
   src = fetchurl {
     url = "http://mirror.services.wisc.edu/mysql/Downloads/MySQLGUITools/mysql-workbench-gpl-${version}-src.tar.gz";
-    sha256 = "1i7icrf3z09rijlvlg99w6m1n3xw0650840hk95ymgrb95kc3437";
+    sha256 = "0dlhnq7pv2ccgm0d7a3hzf9jxa09jzw36h0ljs9vw9q5nyd5kq71";
   };
 
   buildInputs = [ autoconf automake boost file gettext glib glibc gnome_keyring gtk gtkmm intltool
diff --git a/pkgs/applications/misc/xneur/default.nix b/pkgs/applications/misc/xneur/default.nix
index 5a0c5fc12734..c7a302c6589f 100644
--- a/pkgs/applications/misc/xneur/default.nix
+++ b/pkgs/applications/misc/xneur/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, pkgconfig, xorg, pcre, GStreamer, glib, libxml2
-, aspell, cairo, imlib2, xosd, libnotify, gtk, pango, atk }:
+, aspell, cairo, imlib2, xosd, libnotify, gtk, pango, atk, enchant }:
 
 let s = import ./src-for-default.nix; in
 
@@ -13,7 +13,7 @@ stdenv.mkDerivation rec {
   buildInputs =
     [ xorg.libX11 pkgconfig pcre GStreamer glib libxml2 aspell cairo
       xorg.libXpm imlib2 xosd xorg.libXt xorg.libXext xorg.libXi libnotify
-      gtk pango
+      gtk pango enchant
     ];
 
   preConfigure = ''
diff --git a/pkgs/applications/misc/xneur/src-for-default.nix b/pkgs/applications/misc/xneur/src-for-default.nix
index 497d2adfd2c2..04a22cea79ab 100644
--- a/pkgs/applications/misc/xneur/src-for-default.nix
+++ b/pkgs/applications/misc/xneur/src-for-default.nix
@@ -1,9 +1,9 @@
 rec {
-   version="0.10.0";
-   name="xneur-0.10.0";
-   hash="1jh40awnc5bvdj07jv99ymiln8nzr5ac5ahz9v4w0m560b7qq48f";
+   version="0.11.1";
+   name="xneur-0.11.1";
+   hash="12r2wv1glnx3ilqkrypff9r3mxzk1m3yma3khmam1b0z32lfbxxx";
    url="http://dists.xneur.ru/release-${version}/tgz/xneur-${version}.tar.bz2";
-   advertisedUrl="http://dists.xneur.ru/release-0.10.0/tgz/xneur-0.10.0.tar.bz2";
+   advertisedUrl="http://dists.xneur.ru/release-0.11.1/tgz/xneur-0.11.1.tar.bz2";
   
   
 }
diff --git a/pkgs/applications/networking/browsers/chromium/default.nix b/pkgs/applications/networking/browsers/chromium/default.nix
index caa8430f0cd2..db8adeeb45fc 100644
--- a/pkgs/applications/networking/browsers/chromium/default.nix
+++ b/pkgs/applications/networking/browsers/chromium/default.nix
@@ -1,61 +1,37 @@
-{ stdenv
-, fetchurl
-, ffmpeg
-, cairo
-, pango
-, glib
-, libXrender
-, libXScrnSaver
-, gtk
-, nspr
-, nss
-, fontconfig
-, freetype
-, alsaLib
-, libX11
-, GConf
-, libXext
-, libXt
-, atk
-, makeWrapper
-, unzip
-, expat
-, zlib
-, libjpeg
-, bzip2
-, libpng
-, dbus
-, dbus_glib
-, patchelf
-, cups
-, libgcrypt
-}:
+{ GConf, alsaLib, atk, bzip2, cairo, cups, dbus, dbus_glib,
+  expat, fetchurl, ffmpeg, fontconfig, freetype, glib, gtk,
+  libX11, libXScrnSaver, libXdamage, libXext, libXrender, libXt,
+  libgcrypt, libjpeg, libpng, makeWrapper, nspr, nss, pango,
+  patchelf, stdenv, unzip, zlib }:
 
 assert stdenv.system == "i686-linux" || stdenv.system == "x86_64-linux" ;
 
 stdenv.mkDerivation rec {
   name = "chrome-${version}";
   version = "65039";
-  src = 
-    if stdenv.system == "x86_64-linux" then 
+  src =
+    if stdenv.system == "x86_64-linux" then
       fetchurl {
         url = "http://build.chromium.org/buildbot/snapshots/chromium-rel-linux-64/${version}/chrome-linux.zip";
         sha256 = "1ad7kwd1w1958mb3pwzhshawrf2nlxdsf0gy7d2q4qnx5d809vws";
-      } 
-    else if stdenv.system == "i686-linux" then 
+      }
+    else if stdenv.system == "i686-linux" then
       fetchurl {
         url = "http://build.chromium.org/buildbot/snapshots/chromium-rel-linux/${version}/chrome-linux.zip";
         sha256 = "06hz3gvv3623ldrj141w3mnzw049yylvv9b9q5r6my8icm722phf";
-      } 
+      }
     else throw "Chromium is not supported on this platform.";
 
   phases = "unpackPhase installPhase";
 
   buildInputs = [makeWrapper unzip];
 
-  libPath = 
+  libPath =
     stdenv.lib.makeLibraryPath
-       [ stdenv.gcc.libc stdenv.gcc.gcc ffmpeg cairo pango glib libXrender gtk nspr nss fontconfig freetype alsaLib libX11 GConf libXext atk libXt expat zlib libjpeg bzip2 libpng libXScrnSaver dbus dbus_glib cups libgcrypt] ;
+       [ GConf alsaLib atk bzip2 cairo cups dbus dbus_glib expat
+         ffmpeg fontconfig freetype glib gtk libX11 libXScrnSaver
+         libXdamage libXext libXrender libXt libgcrypt libjpeg libpng
+         nspr nss pango stdenv.gcc.gcc zlib stdenv.gcc.libc ];
 
   installPhase = ''
     ensureDir $out/bin
@@ -64,8 +40,7 @@ stdenv.mkDerivation rec {
 
     cp -R * $out/chrome
     ln -s $out/chrome/chrome $out/bin/chrome
-    ${patchelf}/bin/patchelf --interpreter "$(cat $NIX_GCC/nix-support/dynamic-linker)" --set-rpath ${libPath}:$out/lib:${stdenv.gcc.gcc}/lib64:${stdenv.gcc.gcc}/lib $out/chrome/chrome 
-        
+    ${patchelf}/bin/patchelf --interpreter "$(cat $NIX_GCC/nix-support/dynamic-linker)" --set-rpath ${libPath}:$out/lib:${stdenv.gcc.gcc}/lib64:${stdenv.gcc.gcc}/lib $out/chrome/chrome
 
     ln -s ${nss}/lib/libsmime3.so $out/lib/libsmime3.so.1d
     ln -s ${nss}/lib/libnssutil3.so $out/lib/libnssutil3.so.1d
diff --git a/pkgs/applications/networking/ekiga/default.nix b/pkgs/applications/networking/ekiga/default.nix
index 46af2275c37b..d411c3b0f57c 100644
--- a/pkgs/applications/networking/ekiga/default.nix
+++ b/pkgs/applications/networking/ekiga/default.nix
@@ -3,7 +3,7 @@ x@{builderDefsPackage
   , perl, perlXMLParser, evolution_data_server, gnome_doc_utils, avahi
   , libsigcxx, gtk, dbus_glib, libnotify, libXext, xextproto, automake
   , autoconf, pkgconfig, libxml2, videoproto, unixODBC, db4, nspr, nss, zlib
-  , libXrandr, randrproto, which, libxslt
+  , libXrandr, randrproto, which, libxslt, libtasn1
   , ...}:
 builderDefsPackage
 (a :  
diff --git a/pkgs/applications/networking/instant-messengers/gajim/default.nix b/pkgs/applications/networking/instant-messengers/gajim/default.nix
index 2d0b8fa01058..bca70d14c008 100644
--- a/pkgs/applications/networking/instant-messengers/gajim/default.nix
+++ b/pkgs/applications/networking/instant-messengers/gajim/default.nix
@@ -2,7 +2,7 @@ a :
 let 
   fetchurl = a.fetchurl;
 
-  version = a.lib.attrByPath ["version"] "0.14" a; 
+  version = a.lib.attrByPath ["version"] "0.14.1" a; 
   buildInputs = with a; [
     python pyGtkGlade gtk perl intltool dbus gettext
     pkgconfig makeWrapper libglade pyopenssl libXScrnSaver
@@ -14,7 +14,7 @@ in
 rec {
   src = fetchurl {
     url = "http://www.gajim.org/downloads/0.14/gajim-${version}.tar.gz";
-    sha256 = "3dc31b76f5e019515947b81685ec0e62ca20318b13cb80df4f4d7a045242d5bd";
+    sha256 = "ef757572acf3f3d59408fd95b7ec99bc0e39c5b8c66bc61c78ba65e71c3d8e18";
   };
 
   inherit buildInputs;
diff --git a/pkgs/applications/science/electronics/verilog/default.nix b/pkgs/applications/science/electronics/verilog/default.nix
index 8f48879f76a3..a4c803e2952c 100644
--- a/pkgs/applications/science/electronics/verilog/default.nix
+++ b/pkgs/applications/science/electronics/verilog/default.nix
@@ -4,7 +4,7 @@ stdenv.mkDerivation rec {
   name = "verilog-0.9.3";
 
   src = fetchurl {
-    url = "mirror://sourceforce/${name}.tar.gz";
+    url = "mirror://sourceforge/iverilog/${name}.tar.gz";
     sha256 = "dd68c8ab874a93805d1e93fa76ee1e91fc0c7b20822ded3e57b6536cd8c0d1ba";
   };
 
diff --git a/pkgs/applications/science/logic/cvc3/default.nix b/pkgs/applications/science/logic/cvc3/default.nix
new file mode 100644
index 000000000000..9bb8f8cde4ca
--- /dev/null
+++ b/pkgs/applications/science/logic/cvc3/default.nix
@@ -0,0 +1,54 @@
+x@{builderDefsPackage
+  , flex, bison, gmp, perl
+  , ...}:
+builderDefsPackage
+(a :  
+let 
+  helperArgNames = ["stdenv" "fetchurl" "builderDefsPackage"] ++ 
+    ["gmp"];
+
+  buildInputs = (map (n: builtins.getAttr n x)
+    (builtins.attrNames (builtins.removeAttrs x helperArgNames)))
+    ++ [(a.lib.overrideDerivation x.gmp (y: {dontDisableStatic=true;}))];
+  sourceInfo = rec {
+    baseName="cvc3";
+    version="2.2";
+    name="${baseName}-${version}";
+    url="http://www.cs.nyu.edu/acsys/cvc3/releases/${version}/${name}.tar.gz";
+    hash="1dw12d5vrixfr6l9j6j7026vrr22zb433xyl6n5yxx4hgfywi0ji";
+  };
+in
+rec {
+  src = a.fetchurl {
+    url = sourceInfo.url;
+    sha256 = sourceInfo.hash;
+  };
+
+  inherit (sourceInfo) name version;
+  inherit buildInputs;
+
+  /* doConfigure should be removed if not needed */
+  phaseNames = ["fixPaths" "doConfigure" "doMakeInstall"];
+  fixPaths = a.fullDepEntry (''
+    sed -e "s@ /bin/bash@bash@g" -i Makefile.std
+    find . -exec sed -e "s@/usr/bin/perl@${perl}/bin/perl@g" -i '{}' ';'
+  '') ["minInit" "doUnpack"];
+      
+  meta = {
+    description = "A prover for satisfiability modulo theory (SMT)";
+    maintainers = with a.lib.maintainers;
+    [
+      raskin
+    ];
+    platforms = with a.lib.platforms;
+      linux;
+    license = "free-noncopyleft";
+    homepage = "http://www.cs.nyu.edu/acsys/cvc3/index.html";
+  };
+  passthru = {
+    updateInfo = {
+      downloadPage = "http://www.cs.nyu.edu/acsys/cvc3/download.html";
+    };
+  };
+}) x
+
diff --git a/pkgs/applications/science/logic/iprover/default.nix b/pkgs/applications/science/logic/iprover/default.nix
new file mode 100644
index 000000000000..7bfd8dff12e3
--- /dev/null
+++ b/pkgs/applications/science/logic/iprover/default.nix
@@ -0,0 +1,58 @@
+x@{builderDefsPackage
+  , ocaml, eprover
+  , ...}:
+builderDefsPackage
+(a :  
+let 
+  helperArgNames = ["stdenv" "fetchurl" "builderDefsPackage"] ++ 
+    [];
+
+  buildInputs = map (n: builtins.getAttr n x)
+    (builtins.attrNames (builtins.removeAttrs x helperArgNames));
+  sourceInfo = rec {
+    baseName="iprover";
+    version="0.8.1";
+    name="${baseName}_v${version}";
+    url="${baseName}.googlecode.com/files/${name}.tar.gz";
+    hash="15qn523w4l296np5rnkwi50a5x2xqz0kaza7bsh9bkazph7jma7w";
+  };
+in
+rec {
+  src = a.fetchurl {
+    url = sourceInfo.url;
+    sha256 = sourceInfo.hash;
+  };
+
+  inherit (sourceInfo) name version;
+  inherit buildInputs;
+
+  /* doConfigure should be removed if not needed */
+  phaseNames = ["doConfigure" "doMake" "doDeploy"];
+  configureCommand = "sh configure";
+  doDeploy = a.fullDepEntry (''
+    ensureDir "$out/bin"
+    cp iproveropt "$out/bin"
+
+    ensureDir "$out/share/${name}"
+    cp *.p "$out/share/${name}"
+    echo -e "#! /bin/sh\\n$out/bin/iproveropt --clausifier \"${eprover}/bin/eprover\" --clausifier_options \" --tstp-format --silent --cnf \" \"\$@\"" > "$out"/bin/iprover
+    chmod a+x  "$out"/bin/iprover
+  '') ["defEnsureDir" "minInit" "doMake"];
+      
+  meta = {
+    description = "An automated first-order logic theorem prover";
+    maintainers = with a.lib.maintainers;
+    [
+      raskin
+    ];
+    platforms = with a.lib.platforms;
+      linux;
+    license = "GPLv3";
+  };
+  passthru = {
+    updateInfo = {
+      downloadPage = "http://code.google.com/p/iprover/downloads/list";
+    };
+  };
+}) x
+
diff --git a/pkgs/applications/science/logic/isabelle/default.nix b/pkgs/applications/science/logic/isabelle/default.nix
index 2471aa8b594c..b9e756e0423b 100644
--- a/pkgs/applications/science/logic/isabelle/default.nix
+++ b/pkgs/applications/science/logic/isabelle/default.nix
@@ -3,7 +3,7 @@
 
 let
   pname = "Isabelle";
-  version = "2009-1";
+  version = "2009-2";
   name = "${pname}${version}";
   theories = ["HOL" "FOL" "ZF"];
 in
@@ -13,7 +13,7 @@ stdenv.mkDerivation {
 
   src = fetchurl {
     url = "http://www.cl.cam.ac.uk/research/hvg/${pname}/dist/${name}.tar.gz";
-    sha256 = "43ad7794e8b4214b3ace49fc136a69ed6cc65ead02831ae6071f846ecbe56f68";
+    sha256 = "f92a275b78bd8844de47a5902e339b58f3b768c07a7fb19d8e606b68499d5ac4";
   };
 
   buildInputs = [ perl polyml nettools ];
diff --git a/pkgs/applications/science/logic/isabelle/settings.patch b/pkgs/applications/science/logic/isabelle/settings.patch
index 15a70944087b..dc9c611d4886 100644
--- a/pkgs/applications/science/logic/isabelle/settings.patch
+++ b/pkgs/applications/science/logic/isabelle/settings.patch
@@ -6,7 +6,7 @@ diff -Naur Isabelle2009-1/etc/settings Isabelle2009-1-patched/etc/settings
  
  # Poly/ML 5.x (automated settings)
 -POLY_HOME="$(type -p poly)"; [ -n "$POLY_HOME" ] && POLY_HOME="$(dirname "$POLY_HOME")"
- ML_PLATFORM=$("$ISABELLE_HOME/lib/scripts/polyml-platform")
+ ML_PLATFORM="$ISABELLE_PLATFORM"
 -ML_HOME=$(choosefrom \
 -  "$ISABELLE_HOME/contrib/polyml/$ML_PLATFORM" \
 -  "$ISABELLE_HOME/../polyml/$ML_PLATFORM" \
diff --git a/pkgs/applications/science/logic/leo2/default.nix b/pkgs/applications/science/logic/leo2/default.nix
new file mode 100644
index 000000000000..eb3a13593480
--- /dev/null
+++ b/pkgs/applications/science/logic/leo2/default.nix
@@ -0,0 +1,62 @@
+x@{builderDefsPackage
+  , ocaml, eprover
+  , ...}:
+builderDefsPackage
+(a :  
+let 
+  helperArgNames = ["stdenv" "fetchurl" "builderDefsPackage"] ++ 
+    ["eprover"];
+
+  buildInputs = map (n: builtins.getAttr n x)
+    (builtins.attrNames (builtins.removeAttrs x helperArgNames));
+  sourceInfo = rec {
+    baseName="leo2";
+    version="1.2.6";
+    name="${baseName}_v${version}";
+    url="http://www.ags.uni-sb.de/~leo/${name}.tgz";
+    hash="0gjgcm6nb9kzdl0y72sgvf2w2q92s1ix70lh6wjz9lj2qdf7gi1z";
+  };
+in
+rec {
+  src = a.fetchurl {
+    url = sourceInfo.url;
+    sha256 = sourceInfo.hash;
+  };
+
+  inherit (sourceInfo) name version;
+  inherit buildInputs;
+
+  phaseNames = ["makeInstallationDir" "doUnpack" "doMake" "doFinalize"];
+
+  makeInstallationDir = a.fullDepEntry (''
+    ensureDir "$out/share/leo2/build-dir"
+    cd "$out/share/leo2/build-dir"
+  '') ["minInit" "defEnsureDir"];
+
+  goSrcDir = "cd src/";
+
+  doFinalize = a.fullDepEntry (''
+    ensureDir "$out/bin"
+    echo -e "#! /bin/sh\\n$PWD/../bin/leo --atprc $out/etc/leoatprc \"\$@\"\\n" > "$out/bin/leo"
+    chmod a+x "$out/bin/leo"
+    ensureDir "$out/etc"
+    echo -e "e = ${eprover}/bin/eprover\\nepclextract = ${eprover}/bin/epclextract" > "$out/etc/leoatprc"
+  '') ["minInit" "doMake" "defEnsureDir"];
+
+  meta = {
+    description = "A high-performance typed higher order prover";
+    maintainers = with a.lib.maintainers;
+    [
+      raskin
+    ];
+    platforms = with a.lib.platforms;
+      linux;
+    license = "BSD";
+  };
+  passthru = {
+    updateInfo = {
+      downloadPage = "http://www.ags.uni-sb.de/~leo/download.html";
+    };
+  };
+}) x
+
diff --git a/pkgs/applications/science/logic/minisat/default.nix b/pkgs/applications/science/logic/minisat/default.nix
new file mode 100644
index 000000000000..34a6bd7ceff3
--- /dev/null
+++ b/pkgs/applications/science/logic/minisat/default.nix
@@ -0,0 +1,57 @@
+x@{builderDefsPackage
+  , zlib
+  , ...}:
+builderDefsPackage
+(a :  
+let 
+  helperArgNames = ["stdenv" "fetchurl" "builderDefsPackage"] ++ 
+    [];
+
+  buildInputs = map (n: builtins.getAttr n x)
+    (builtins.attrNames (builtins.removeAttrs x helperArgNames));
+  sourceInfo = rec {
+    baseName="minisat";
+    version="2.2.0";
+    name="${baseName}-${version}";
+    url="http://minisat.se/downloads/${name}.tar.gz";
+    hash="023qdnsb6i18yrrawlhckm47q8x0sl7chpvvw3gssfyw3j2pv5cj";
+  };
+in
+rec {
+  src = a.fetchurl {
+    url = sourceInfo.url;
+    sha256 = sourceInfo.hash;
+  };
+
+  inherit (sourceInfo) name version;
+  inherit buildInputs;
+
+  phaseNames = ["setVars" "doMake" "doDeploy"];
+  goSrcDir = "cd simp";
+  doDeploy = a.fullDepEntry (''
+    ensureDir "$out"/bin
+    cp minisat_static "$out/bin"/minisat
+  '') ["minInit" "defEnsureDir"];
+  makeFlags = ["rs"];
+  setVars = a.fullDepEntry (''
+    export MROOT=$PWD/../
+  '') ["doUnpack"];
+      
+  meta = {
+    description = "A compact and readable SAT-solver";
+    maintainers = with a.lib.maintainers;
+    [
+      raskin
+    ];
+    platforms = with a.lib.platforms;
+      linux;
+    license = "MIT";
+    homepage = "http://minisat.se/";
+  };
+  passthru = {
+    updateInfo = {
+      downloadPage = "http://minisat.se/MiniSat.html";
+    };
+  };
+}) x
+
diff --git a/pkgs/applications/science/logic/opensmt/default.nix b/pkgs/applications/science/logic/opensmt/default.nix
new file mode 100644
index 000000000000..165c8a2f1484
--- /dev/null
+++ b/pkgs/applications/science/logic/opensmt/default.nix
@@ -0,0 +1,51 @@
+x@{builderDefsPackage
+  , automake, libtool, autoconf, intltool, perl
+  , gmpxx, flex, bison
+  , ...}:
+builderDefsPackage
+(a :  
+let 
+  helperArgNames = ["stdenv" "fetchurl" "builderDefsPackage"] ++ 
+    [];
+
+  buildInputs = map (n: builtins.getAttr n x)
+    (builtins.attrNames (builtins.removeAttrs x helperArgNames));
+  sourceInfo = rec {
+    baseName="opensmt";
+    version="20101017";
+    name="${baseName}-${version}";
+    filename="${baseName}_src_${version}";
+    url="${baseName}.googlecode.com/files/${filename}.tgz";
+    hash="0xrky7ixjaby5x026v7hn72xh7d401w9jhccxjn0khhn1x87p2w1";
+  };
+in
+rec {
+  src = a.fetchurl {
+    url = sourceInfo.url;
+    sha256 = sourceInfo.hash;
+  };
+
+  inherit (sourceInfo) name version;
+  inherit buildInputs;
+
+  /* doConfigure should be removed if not needed */
+  phaseNames = ["doAutotools" "doConfigure" "doMakeInstall"];
+      
+  meta = {
+    description = "A satisfiability modulo theory (SMT) solver";
+    maintainers = with a.lib.maintainers;
+    [
+      raskin
+    ];
+    platforms = with a.lib.platforms;
+      linux;
+    license = "GPLv3";
+    homepage = "http://code.google.com/p/opensmt/";
+  };
+  passthru = {
+    updateInfo = {
+      downloadPage = "http://code.google.com/p/opensmt/downloads/list";
+    };
+  };
+}) x
+
diff --git a/pkgs/applications/science/logic/satallax/default.nix b/pkgs/applications/science/logic/satallax/default.nix
new file mode 100644
index 000000000000..4bf6e53737e9
--- /dev/null
+++ b/pkgs/applications/science/logic/satallax/default.nix
@@ -0,0 +1,72 @@
+x@{builderDefsPackage
+  , sbcl, zlib
+  , ...}:
+builderDefsPackage
+(a :  
+let 
+  helperArgNames = ["stdenv" "fetchurl" "builderDefsPackage"] ++ 
+    [];
+
+  buildInputs = map (n: builtins.getAttr n x)
+    (builtins.attrNames (builtins.removeAttrs x helperArgNames));
+  sourceInfo = rec {
+    baseName="satallax";
+    version="1.4";
+    name="${baseName}-${version}";
+    url="http://www.ps.uni-saarland.de/~cebrown/satallax/downloads/${name}.tar.gz";
+    hash="0l8dq4nyfw2bdsyqmgb4v6fjw3739p8nqv4bh2gh2924ibzrq5fc";
+  };
+in
+rec {
+  src = a.fetchurl {
+    url = sourceInfo.url;
+    sha256 = sourceInfo.hash;
+  };
+
+  inherit (sourceInfo) name version;
+  inherit buildInputs;
+
+  phaseNames = ["doDeployMinisat" "doDeploy"];
+
+  doDeployMinisat = a.fullDepEntry (''
+    (
+      cd minisat/simp
+      make
+    )
+
+    ensureDir "$out/bin"
+    cp minisat/simp/minisat "$out/bin"
+
+    echo "(setq *minisat-binary* \"$out/bin/minisat\")" > config.lisp
+
+  '') ["defEnsureDir" "minInit" "addInputs" "doUnpack"];
+  doDeploy = a.fullDepEntry (''
+    ensureDir "$out/share/satallax/build-dir"
+    cp -r * "$out/share/satallax/build-dir"
+    cd  "$out/share/satallax/build-dir"
+
+    sbcl --load make.lisp
+    ! ( ./test | grep ERROR )
+    
+    ensureDir "$out/bin"
+    cp bin/satallax "$out/bin"
+  '') ["defEnsureDir" "minInit" "addInputs" "doUnpack"];
+      
+  meta = {
+    description = "A higher-order logic prover";
+    maintainers = with a.lib.maintainers;
+    [
+      raskin
+    ];
+    platforms = with a.lib.platforms;
+      unix;
+    license = "free-noncopyleft";
+    homepage = "http://www.ps.uni-saarland.de/~cebrown/satallax/";
+  };
+  passthru = {
+    updateInfo = {
+      downloadPage = "http://www.ps.uni-saarland.de/~cebrown/satallax/";
+    };
+  };
+}) x
+
diff --git a/pkgs/applications/science/logic/spass/default.nix b/pkgs/applications/science/logic/spass/default.nix
new file mode 100644
index 000000000000..2c6144baf0e8
--- /dev/null
+++ b/pkgs/applications/science/logic/spass/default.nix
@@ -0,0 +1,49 @@
+x@{builderDefsPackage
+  , ...}:
+builderDefsPackage
+(a :  
+let 
+  helperArgNames = ["stdenv" "fetchurl" "builderDefsPackage"] ++ 
+    [];
+
+  buildInputs = map (n: builtins.getAttr n x)
+    (builtins.attrNames (builtins.removeAttrs x helperArgNames));
+  sourceInfo = rec {
+    baseName="spass";
+    baseVersion="3";
+    minorVersion="7";
+    version="${baseVersion}.${minorVersion}";
+    name="${baseName}-${version}";
+    url="http://www.spass-prover.org/download/sources/${baseName}${baseVersion}${minorVersion}.tgz";
+    hash="1k5a98kr3vzga54zs7slwwaaf6v6agk1yfcayd8bl55q15g7xihk";
+  };
+in
+rec {
+  src = a.fetchurl {
+    url = sourceInfo.url;
+    sha256 = sourceInfo.hash;
+  };
+
+  inherit (sourceInfo) name version;
+  inherit buildInputs;
+
+  /* doConfigure should be removed if not needed */
+  phaseNames = ["doConfigure" "doMakeInstall"];
+      
+  meta = {
+    description = "An automated theorem preover for FOL";
+    maintainers = with a.lib.maintainers;
+    [
+      raskin
+    ];
+    platforms = with a.lib.platforms;
+      linux;
+    license = "BSD";
+  };
+  passthru = {
+    updateInfo = {
+      downloadPage = "http://www.spass-prover.org/download/index.html";
+    };
+  };
+}) x
+
diff --git a/pkgs/applications/science/math/pari/default.nix b/pkgs/applications/science/math/pari/default.nix
new file mode 100644
index 000000000000..62763ac2198a
--- /dev/null
+++ b/pkgs/applications/science/math/pari/default.nix
@@ -0,0 +1,50 @@
+x@{builderDefsPackage
+  , perl, zlib, gmp, readline
+  , ...}:
+builderDefsPackage
+(a :  
+let 
+  helperArgNames = ["stdenv" "fetchurl" "builderDefsPackage"] ++ 
+    [];
+
+  buildInputs = map (n: builtins.getAttr n x)
+    (builtins.attrNames (builtins.removeAttrs x helperArgNames));
+  sourceInfo = rec {
+    baseName="pari";
+    version="2.3.5";
+    name="${baseName}-${version}";
+    url="http://pari.math.u-bordeaux.fr/pub/pari/unix/${name}.tar.gz";
+    hash="124xr2jdz2c15v45i1zvgylng44lhf23729a1mk7ci1vywdaxpa7";
+  };
+in
+rec {
+  src = a.fetchurl {
+    url = sourceInfo.url;
+    sha256 = sourceInfo.hash;
+  };
+
+  inherit (sourceInfo) name version;
+  inherit buildInputs;
+
+  /* doConfigure should be removed if not needed */
+  phaseNames = ["doConfigure" "doMakeInstall"];
+  configureCommand="./Configure";
+      
+  meta = {
+    description = "Computer algebra system for high-performance number theory computations";
+    maintainers = with a.lib.maintainers;
+    [
+      raskin
+    ];
+    platforms = with a.lib.platforms;
+      linux;
+    license = "GPLv2+";
+    homepage = "http://pari.math.u-bordeaux.fr/";
+  };
+  passthru = {
+    updateInfo = {
+      downloadPage = "http://pari.math.u-bordeaux.fr/download.html";
+    };
+  };
+}) x
+
diff --git a/pkgs/applications/science/math/singular/default.nix b/pkgs/applications/science/math/singular/default.nix
new file mode 100644
index 000000000000..dfc97eca8ebe
--- /dev/null
+++ b/pkgs/applications/science/math/singular/default.nix
@@ -0,0 +1,61 @@
+x@{builderDefsPackage
+  , gmp, bison, perl, autoconf, ncurses, readline
+  , coreutils
+  , ...}:
+builderDefsPackage
+(a :  
+let 
+  helperArgNames = ["stdenv" "fetchurl" "builderDefsPackage"] ++ 
+    [];
+
+  buildInputs = map (n: builtins.getAttr n x)
+    (builtins.attrNames (builtins.removeAttrs x helperArgNames));
+  sourceInfo = rec {
+    baseName="Singular";
+    version="3-1-2";
+    revision="-1";
+    name="${baseName}-${version}${revision}";
+    url="http://www.mathematik.uni-kl.de/ftp/pub/Math/Singular/SOURCES/${version}/${name}.tar.gz";
+    hash="04f9i1xar0r7qrrbfki1h9rrmx5y2xg4w7rrvlbx05v2dy6s8djv";
+  };
+in
+rec {
+  src = a.fetchurl {
+    url = sourceInfo.url;
+    sha256 = sourceInfo.hash;
+  };
+
+  inherit (sourceInfo) name version;
+  inherit buildInputs;
+
+  /* doConfigure should be removed if not needed */
+  phaseNames = ["doFixPaths" "doConfigure" "doMakeInstall" "fixInstall"];
+  doFixPaths = a.fullDepEntry (''
+    find . -exec sed -e 's@/bin/rm@${a.coreutils}&@g' -i '{}' ';'
+    find . -exec sed -e 's@/bin/uname@${a.coreutils}&@g' -i '{}' ';'
+  '') ["minInit" "doUnpack"];
+  fixInstall = a.fullDepEntry (''
+    rm -rf "$out/LIB"
+    cp -r Singular/LIB "$out"
+    ensureDir "$out/bin"
+    ln -s "$out"/*/Singular "$out/bin"
+  '') ["minInit" "defEnsureDir"];
+      
+  meta = {
+    description = "A CAS for polynomial computations";
+    maintainers = with a.lib.maintainers;
+    [
+      raskin
+    ];
+    platforms = with a.lib.platforms;
+      linux;
+    license = "GPLv3"; # Or GPLv2 at your option - but not GPLv4
+    homepage = "http://www.singular.uni-kl.de/index.php";
+  };
+  passthru = {
+    updateInfo = {
+      downloadPage = "http://www.mathematik.uni-kl.de/ftp/pub/Math/Singular/SOURCES/";
+    };
+  };
+}) x
+
diff --git a/pkgs/applications/version-management/subversion/default.nix b/pkgs/applications/version-management/subversion/default.nix
index 0c94d96a999d..95d21e2f7a6c 100644
--- a/pkgs/applications/version-management/subversion/default.nix
+++ b/pkgs/applications/version-management/subversion/default.nix
@@ -19,13 +19,13 @@ assert compressionSupport -> neon.compressionSupport;
 
 stdenv.mkDerivation rec {
 
-  version = "1.6.12";
+  version = "1.6.15";
 
   name = "subversion-${version}";
 
   src = fetchurl {
     url = "http://subversion.tigris.org/downloads/${name}.tar.bz2";
-    sha1 = "b4ae7c75abbbdade8b2c9122ca7e2e26c6468a82";
+    sha1 = "b6fadf944a94b86f989f07bc2d781be41df017bf";
   };
 
   buildInputs = [ zlib apr aprutil sqlite ]
@@ -34,12 +34,11 @@ stdenv.mkDerivation rec {
     ++ stdenv.lib.optional perlBindings perl;
 
   configureFlags = ''
-    --disable-keychain
     ${if bdbSupport then "--with-berkeley-db" else "--without-berkeley-db"}
     ${if httpServer then "--with-apxs=${httpd}/bin/apxs" else "--without-apxs"}
     ${if pythonBindings || perlBindings then "--with-swig=${swig}" else "--without-swig"}
     ${if javahlBindings then "--enable-javahl --with-jdk=${jdk}" else ""}
-    ${if stdenv.isDarwin then "--enable-keychain" else ""}
+    ${if stdenv.isDarwin then "--enable-keychain" else "--disable-keychain"}
     --with-zlib=${zlib}
     --with-sqlite=${sqlite}
   '';
diff --git a/pkgs/applications/video/kmplayer/default.nix b/pkgs/applications/video/kmplayer/default.nix
index 51ae56cc8e4e..a665670d9c98 100644
--- a/pkgs/applications/video/kmplayer/default.nix
+++ b/pkgs/applications/video/kmplayer/default.nix
@@ -1,10 +1,10 @@
 {stdenv, fetchurl, lib, cmake, qt4, perl, gettext, pango, gtk, dbus_glib, kdelibs, automoc4, phonon}:
 
 stdenv.mkDerivation {
-  name = "kmplayer-0.11.2a";
+  name = "kmplayer-0.11.2b";
   src = fetchurl {
-    url = http://kmplayer.kde.org/pkgs/kmplayer-0.11.2a.tar.bz2;
-    sha256 = "1ddrghwsz11nhdxkca7jz0q2z1ajdb47n325h32jp5q7rm2qz80k";
+    url = http://kmplayer.kde.org/pkgs/kmplayer-0.11.2b.tar.bz2;
+    sha256 = "00a1pw31p849cbgskyfi8jni9ar6yi2ivr625vza2za6apdxvkr7";
   };
   builder = ./builder.sh;
   buildInputs = [ cmake qt4 perl gettext stdenv.gcc.libc pango gtk dbus_glib kdelibs automoc4 phonon ];
diff --git a/pkgs/applications/virtualization/virtualbox/guest-additions/default.nix b/pkgs/applications/virtualization/virtualbox/guest-additions/default.nix
index bb9b8eea08c4..eb8a91551426 100644
--- a/pkgs/applications/virtualization/virtualbox/guest-additions/default.nix
+++ b/pkgs/applications/virtualization/virtualbox/guest-additions/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, lib, patchelf, cdrkit, kernel
+{ stdenv, fetchurl, lib, patchelf, cdrkit, kernel, which, makeWrapper
 , libX11, libXt, libXext, libXmu, libXcomposite, libXfixes, libXrandr, libXcursor}:
 
 stdenv.mkDerivation {
@@ -8,7 +8,14 @@ stdenv.mkDerivation {
     sha256 = "1pyfgrcdmw6zf3yxgzcd8c5qzqqn62bz4085ka453gfmi9d65lys";
   };
   KERN_DIR = "${kernel}/lib/modules/*/build";
-  buildInputs = [ patchelf cdrkit ];
+  buildInputs = [ patchelf cdrkit makeWrapper ];
+
+  installPhase = ''
+    ensureDir $out
+    cp -r install/* $out
+
+  '';
+  
   buildCommand = ''
     ${if stdenv.system == "i686-linux" then ''
         isoinfo -J -i $src -x /VBoxLinuxAdditions-x86.run > ./VBoxLinuxAdditions-x86.run
@@ -73,6 +80,9 @@ stdenv.mkDerivation {
     install -m 755 bin/VBoxControl $out/bin
     install -m 755 bin/VBoxClient-all $out/bin
 
+    wrapProgram $out/bin/VBoxClient-all \
+            --prefix PATH : "${which}/bin"
+
     # Install OpenGL libraries
     ensureDir $out/lib
     cp -v lib/VBoxOGL*.so $out/lib
diff --git a/pkgs/applications/window-managers/openbox/default.nix b/pkgs/applications/window-managers/openbox/default.nix
new file mode 100644
index 000000000000..016325140e05
--- /dev/null
+++ b/pkgs/applications/window-managers/openbox/default.nix
@@ -0,0 +1,18 @@
+{ stdenv, fetchurl, pkgconfig, glib, pango, libxml2, libXau }:
+
+stdenv.mkDerivation rec {
+  name = "openbox-3-4-11-2";
+
+  buildInputs = [ pkgconfig glib pango libxml2 libXau ];
+
+  src = fetchurl {
+    url = http://openbox.org/dist/openbox/openbox-3.4.11.2.tar.gz;
+    sha256 = "2e7579389c30e6bb08cc721a2c1af512e049fec2670e71715aa1c4e129ec349d";
+  };
+
+  meta = {
+    description = "X window manager for non-desktop embedded systems";
+    homepage = http://openbox.org/;
+    license = "GPLv2+";
+  };
+}