about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/drumgizmo/default.nix28
-rw-r--r--pkgs/applications/audio/faust-compiler/default.nix70
-rw-r--r--pkgs/applications/audio/faust/default.nix79
-rw-r--r--pkgs/applications/editors/neovim/default.nix65
-rw-r--r--pkgs/applications/graphics/shotwell/default.nix10
-rw-r--r--pkgs/applications/graphics/synfigstudio/default.nix4
-rw-r--r--pkgs/applications/graphics/yed/default.nix29
-rw-r--r--pkgs/applications/misc/calibre/default.nix4
-rw-r--r--pkgs/applications/misc/xrandr-invert-colors/default.nix26
-rw-r--r--pkgs/applications/networking/browsers/chromium/common.nix1
-rw-r--r--pkgs/applications/networking/browsers/rekonq/default.nix6
-rw-r--r--pkgs/applications/networking/ids/daq/default.nix4
-rw-r--r--pkgs/applications/networking/ids/snort/default.nix4
-rw-r--r--pkgs/applications/networking/instant-messengers/pidgin-plugins/otr/default.nix4
-rw-r--r--pkgs/applications/networking/instant-messengers/teamspeak/client.nix6
-rw-r--r--pkgs/applications/version-management/git-and-tools/git/default.nix9
-rw-r--r--pkgs/applications/version-management/git-and-tools/git/ssl-cert-file.patch13
-rw-r--r--pkgs/applications/version-management/src/default.nix4
-rw-r--r--pkgs/applications/version-management/src/path.patch16
-rw-r--r--pkgs/applications/video/mpv/default.nix15
20 files changed, 347 insertions, 50 deletions
diff --git a/pkgs/applications/audio/drumgizmo/default.nix b/pkgs/applications/audio/drumgizmo/default.nix
new file mode 100644
index 000000000000..2daafda554e7
--- /dev/null
+++ b/pkgs/applications/audio/drumgizmo/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchurl, alsaLib, expat, glib, jack2, libX11, libpng
+, libpthreadstubs, libsmf, libsndfile, lv2, pkgconfig
+}:
+
+stdenv.mkDerivation rec {
+  version = "0.9.6";
+  name = "drumgizmo-${version}";
+
+  src = fetchurl {
+    url = "http://www.drumgizmo.org/releases/${name}/${name}.tar.gz";
+    sha256 = "1qs8aa1v8cw5zgfzcnr2dc4w0y5yzsgrywlnx2hfvx2si3as0mw4";
+  };
+
+  configureFlags = [ "--enable-lv2" ];
+
+  buildInputs = [
+    alsaLib expat glib jack2 libX11 libpng libpthreadstubs libsmf
+    libsndfile lv2 pkgconfig
+  ];
+
+  meta = with stdenv.lib; {
+    description = "An LV2 sample based drum plugin";
+    homepage = http://www.drumgizmo.org;
+    license = licenses.gpl3;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.goibhniu ];
+  };
+}
diff --git a/pkgs/applications/audio/faust-compiler/default.nix b/pkgs/applications/audio/faust-compiler/default.nix
index f924fe2953d7..5e980691df6d 100644
--- a/pkgs/applications/audio/faust-compiler/default.nix
+++ b/pkgs/applications/audio/faust-compiler/default.nix
@@ -1,4 +1,4 @@
-{ fetchurl, stdenv, unzip }:
+{ fetchurl, stdenv, unzip, pkgconfig, makeWrapper, libsndfile, libmicrohttpd, vim }:
 
 stdenv.mkDerivation rec {
 
@@ -9,20 +9,70 @@ stdenv.mkDerivation rec {
     sha256 = "068vl9536zn0j4pknwfcchzi90rx5pk64wbcbd67z32w0csx8xm1";
   };
 
-  buildInputs = [ unzip ];
+  buildInputs = [ unzip pkgconfig makeWrapper libsndfile libmicrohttpd vim];
+
+
+  makeFlags="PREFIX = $(out)";
+  FPATH="$out"; # <- where to search
 
   patchPhase = ''
-    sed -i '77,101d' Makefile
-    sed -i 's#?= $(shell uname -s)#:= Linux#g'  architecture/osclib/oscpack/Makefile
-    sed -e "s@\$FAUST_INSTALL /usr/local /usr /opt /opt/local@$out@g" -i tools/faust2appls/faustpath
-  '';
+    sed -i 's@?= $(shell uname -s)@:= Linux@g'  architecture/osclib/oscpack/Makefile
+    sed -i 's@faust/misc.h@../../architecture/faust/misc.h@g' tools/sound2faust/sound2faust.cpp
+    sed -i 's@faust/gui/@../../architecture/faust/gui/@g' architecture/faust/misc.h
+    '';
+
+  buildPhase = ''
+    make -C compiler -f Makefile.unix
+    make -C architecture/osclib
+	g++ -O3 tools/sound2faust/sound2faust.cpp `pkg-config --cflags --static --libs sndfile` -o tools/sound2faust/sound2faust
+    make httpd
 
-  postInstallPhase = ''
-    rm -rf $out/include/
   '';
 
-  makeFlags = "PREFIX=$(out)";
-  FPATH = "$out"; # <- where to search
+  installPhase = ''
+
+    echo install faust itself
+    mkdir -p $out/bin/
+    mkdir -p $out/include/
+	mkdir -p $out/include/faust/
+	mkdir -p $out/include/faust/osc/
+    install compiler/faust $out/bin/
+
+    echo install architecture and faust library files
+    mkdir -p $out/lib/faust
+    cp architecture/*.lib $out/lib/faust/
+    cp architecture/*.cpp $out/lib/faust/
+
+    echo install math documentation files
+	cp architecture/mathdoctexts-*.txt $out/lib/faust/
+	cp architecture/latexheader.tex $out/lib/faust/
+
+    echo install additional binary libraries: osc, http
+	([ -e architecture/httpdlib/libHTTPDFaust.a ] && cp architecture/httpdlib/libHTTPDFaust.a $out/lib/faust/) || echo libHTTPDFaust not available	
+	cp architecture/osclib/*.a $out/lib/faust/
+	cp -r architecture/httpdlib/html/js $out/lib/faust/js
+	([ -e architecture/httpdlib/src/hexa/stylesheet ] && cp architecture/httpdlib/src/hexa/stylesheet $out/lib/faust/js/stylesheet.js) || echo stylesheet not available
+	([ -e architecture/httpdlib/src/hexa/jsscripts ] && cp architecture/httpdlib/src/hexa/jsscripts $out/lib/faust/js/jsscripts.js) || echo jsscripts not available
+
+    echo install includes files for architectures
+	cp -r architecture/faust $out/include/
+
+    echo install additional includes files for binary libraries:  osc, http
+	cp architecture/osclib/faust/faust/OSCControler.h $out/include/faust/gui/
+	cp architecture/osclib/faust/faust/osc/*.h $out/include/faust/osc/
+	cp architecture/httpdlib/src/include/*.h $out/include/faust/gui/
+
+
+    echo patch header and cpp files
+    find $out/include/ -name "*.h" -type f | xargs sed "s@#include \"faust/@#include \"$out/include/faust/@g" -i
+    find $out/lib/faust/ -name "*.cpp" -type f | xargs sed "s@#include \"faust/@#include \"$out/include/faust/@g" -i
+    sed -i "s@../../architecture/faust/gui/@$out/include/faust/gui/@g"  $out/include/faust/misc.h
+
+    wrapProgram $out/bin/faust \
+    --set FAUSTLIB $out/lib/faust \
+    --set FAUST_LIB_PATH  $out/lib/faust \
+    --set FAUSTINC $out/include/
+  '';
 
   meta = with stdenv.lib; {
     description = "A functional programming language for realtime audio signal processing";
diff --git a/pkgs/applications/audio/faust/default.nix b/pkgs/applications/audio/faust/default.nix
new file mode 100644
index 000000000000..9d25573ccc81
--- /dev/null
+++ b/pkgs/applications/audio/faust/default.nix
@@ -0,0 +1,79 @@
+{ fetchurl, stdenv, bash, alsaLib, atk, cairo, faust-compiler, fontconfig, freetype
+, gcc, gdk_pixbuf, glib, gtk, makeWrapper, pango, pkgconfig, unzip
+, gtkSupport ? true
+}:
+
+stdenv.mkDerivation rec {
+
+  version = "0.9.67";
+  name = "faust-${version}";
+  src = fetchurl {
+    url = "http://downloads.sourceforge.net/project/faudiostream/faust-${version}.zip";
+    sha256 = "068vl9536zn0j4pknwfcchzi90rx5pk64wbcbd67z32w0csx8xm1";
+  };
+
+  buildInputs = [ bash unzip faust-compiler gcc makeWrapper pkgconfig ]
+    ++ stdenv.lib.optionals gtkSupport [
+      alsaLib atk cairo fontconfig freetype gdk_pixbuf glib gtk pango
+    ]
+  ;
+
+  makeFlags="PREFIX=$(out)";
+  FPATH="$out"; # <- where to search
+
+  phases = [ "unpackPhase installPhase postInstall" ];
+
+  installPhase  = ''
+    mkdir $out/bin
+    install tools/faust2appls/faust2alsaconsole $out/bin
+    install tools/faust2appls/faustpath  $out/bin
+    install tools/faust2appls/faustoptflags  $out/bin
+    install tools/faust2appls/faust2alsa $out/bin
+
+    wrapProgram $out/bin/faust2alsaconsole \
+    --prefix PKG_CONFIG_PATH : ${alsaLib}/lib/pkgconfig \
+    --set FAUSTLIB ${faust-compiler}/lib/faust \
+    --set FAUSTINC ${faust-compiler}/include/
+
+    GTK_PKGCONFIG_PATHS=${gtk}/lib/pkgconfig:${pango}/lib/pkgconfig:${glib}/lib/pkgconfig:${cairo}/lib/pkgconfig:${gdk_pixbuf}/lib/pkgconfig:${atk}/lib/pkgconfig:${freetype}/lib/pkgconfig:${fontconfig}/lib/pkgconfig
+
+    wrapProgram  $out/bin/faust2alsa \
+    --prefix PKG_CONFIG_PATH :  ${alsaLib}/lib/pkgconfig:$GTK_PKGCONFIG_PATHS \
+    --set FAUSTLIB ${faust-compiler}/lib/faust \
+    --set FAUSTINC ${faust-compiler}/include/ \
+    '' + stdenv.lib.optionalString (!gtkSupport) "rm $out/bin/faust2alsa"
+  ;
+
+  postInstall = ''
+    find $out/bin/ -name "faust2*" -type f | xargs sed "s@/bin/bash@${bash}/bin/bash@g" -i
+    sed -i "s@/bin/bash@${bash}/bin/bash@g" $out/bin/faustpath
+    sed -e "s@\$FAUST_INSTALL /usr/local /usr /opt /opt/local@${faust-compiler}@g" -i $out/bin/faustpath
+    sed -i "s@/bin/bash@${bash}/bin/bash@g" $out/bin/faustoptflags
+    find $out/bin/ -name "faust2*" -type f | xargs sed "s@pkg-config@${pkgconfig}/bin/pkg-config@g" -i
+    find $out/bin/ -name "faust2*" -type f | xargs sed "s@CXX=g++@CXX=${gcc}/bin/g++@g" -i
+    find $out/bin/ -name "faust2*" -type f | xargs sed "s@faust -i -a @${faust-compiler}/bin/faust -i -a ${faust-compiler}/lib/faust/@g" -i
+  '';
+
+  meta = with stdenv.lib; {
+    description = "A functional programming language for realtime audio signal processing";
+    longDescription = ''
+      FAUST (Functional Audio Stream) is a functional programming
+      language specifically designed for real-time signal processing
+      and synthesis. FAUST targets high-performance signal processing
+      applications and audio plug-ins for a variety of platforms and
+      standards.
+      The Faust compiler translates DSP specifications into very
+      efficient C++ code. Thanks to the notion of architecture,
+      FAUST programs can be easily deployed on a large variety of
+      audio platforms and plugin formats (jack, alsa, ladspa, maxmsp,
+      puredata, csound, supercollider, pure, vst, coreaudio) without
+      any change to the FAUST code.
+    '';
+    homepage = http://faust.grame.fr/;
+    downloadPage = http://sourceforge.net/projects/faudiostream/files/;
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.magnetophon ];
+  };
+}
+
diff --git a/pkgs/applications/editors/neovim/default.nix b/pkgs/applications/editors/neovim/default.nix
new file mode 100644
index 000000000000..1c1c050b0000
--- /dev/null
+++ b/pkgs/applications/editors/neovim/default.nix
@@ -0,0 +1,65 @@
+{ stdenv, fetchgit, fetchurl, unzip, callPackage, ncurses, gettext, pkgconfig,
+cmake, pkgs, lpeg, lua, luajit, luaMessagePack, luabitop }:
+
+stdenv.mkDerivation rec {
+  name = "neovim-nightly";
+
+  version = "nightly";
+
+  src = fetchgit {
+    url = "https://github.com/neovim/neovim";
+    rev = "68fcd8b696dae33897303c9f8265629a31afbf17";
+    sha256 = "0hxkcy641jpn4qka44gfvhmb6q3dkjx6lvn9748lcl2gx2d36w4i";
+  };
+
+  libmsgpack = stdenv.mkDerivation rec {
+    version = "0.5.9";
+    name = "libmsgpack-${version}";
+
+    src = fetchgit {
+      rev = "ecf4b09acd29746829b6a02939db91dfdec635b4";
+      url = "https://github.com/msgpack/msgpack-c";
+      sha256 = "076ygqgxrc3vk2l20l8x2cgcv05py3am6mjjkknr418pf8yav2ww";
+    };
+
+    buildInputs = [ cmake ];
+
+    meta = with stdenv.lib; {
+      description = "MessagePack implementation for C and C++";
+      homepage = http://msgpack.org;
+      maintainers = [ maintainers.manveru ];
+      license = licenses.asl20;
+      platforms = platforms.all;
+    };
+  };
+
+  enableParallelBuilding = true;
+
+  buildInputs = [
+    ncurses
+    pkgconfig
+    cmake
+    pkgs.libuvVersions.v0_11_29
+    luajit
+    lua
+    lpeg
+    luaMessagePack
+    luabitop
+    libmsgpack
+  ];
+  nativeBuildInputs = [ gettext ];
+
+  LUA_CPATH="${lpeg}/lib/lua/${lua.luaversion}/?.so;${luabitop}/lib/lua/5.2/?.so";
+  LUA_PATH="${luaMessagePack}/share/lua/5.1/?.lua";
+  cmakeFlags = [
+    "-DUSE_BUNDLED_MSGPACK=ON"
+  ];
+
+  meta = with stdenv.lib; {
+    description = "Aggressive refactor of Vim";
+    homepage    = http://www.neovim.org;
+    maintainers = with maintainers; [ manveru ];
+    platforms   = platforms.unix;
+  };
+}
+
diff --git a/pkgs/applications/graphics/shotwell/default.nix b/pkgs/applications/graphics/shotwell/default.nix
index 1953f951d169..48044fba1666 100644
--- a/pkgs/applications/graphics/shotwell/default.nix
+++ b/pkgs/applications/graphics/shotwell/default.nix
@@ -1,4 +1,4 @@
-{ fetchurl, stdenv, m4, glibc, gtk3, libexif, libgphoto2, libsoup, libxml2, vala, sqlite, webkit
+{ fetchurl, stdenv, m4, glibc, gtk3, libexif, libgphoto2, libsoup, libxml2, vala, sqlite, webkitgtk24x
 , pkgconfig, gnome3, gst_all_1, which, udev, libraw, glib, json_glib, gettext, desktop_file_utils
 , lcms2, gdk_pixbuf, librsvg, makeWrapper, gnome_doc_utils }:
 
@@ -18,12 +18,12 @@ let
     buildInputs = [ pkgconfig glib libsoup ];
   };
 in stdenv.mkDerivation rec {
-  version = "0.18.0";
+  version = "0.20.2";
   name = "shotwell-${version}";
 
   src = fetchurl {
-    url = "mirror://gnome/sources/shotwell/0.18/${name}.tar.xz";
-    sha256 = "0cq0zs13f3f4xyz46yvj4qfpm5nh4ypds7r53pkqm4a3n8ybf5v7";
+    url = "mirror://gnome/sources/shotwell/0.20/${name}.tar.xz";
+    sha256 = "0h5pdczsrkplvlvq54zk3am4kjmfpd6pn2sz0ky8lfq1fngwiqip";
   };
 
   NIX_CFLAGS_COMPILE = "-I${glib}/include/glib-2.0 -I${glib}/lib/glib-2.0/include";
@@ -47,7 +47,7 @@ in stdenv.mkDerivation rec {
   '';
 
 
-  buildInputs = [ m4 glibc gtk3 libexif libgphoto2 libsoup libxml2 vala sqlite webkit pkgconfig
+  buildInputs = [ m4 glibc gtk3 libexif libgphoto2 libsoup libxml2 vala sqlite webkitgtk24x pkgconfig
                   gst_all_1.gstreamer gst_all_1.gst-plugins-base gnome3.libgee which udev gnome3.gexiv2
                   libraw rest json_glib gettext desktop_file_utils glib lcms2 gdk_pixbuf librsvg
                   makeWrapper gnome_doc_utils ];
diff --git a/pkgs/applications/graphics/synfigstudio/default.nix b/pkgs/applications/graphics/synfigstudio/default.nix
index 6af51e817785..2b3f4c80bcd0 100644
--- a/pkgs/applications/graphics/synfigstudio/default.nix
+++ b/pkgs/applications/graphics/synfigstudio/default.nix
@@ -45,7 +45,7 @@ stdenv.mkDerivation rec {
   };
 
   buildInputs = [
-    ETL boost cairo fontsConf gettext glibmm gtk gtkmm imagemagick intltool
+    ETL boost cairo gettext glibmm gtk gtkmm imagemagick intltool
     intltool libsigcxx libtool libxmlxx pkgconfig synfig
   ];
 
@@ -58,6 +58,8 @@ stdenv.mkDerivation rec {
     export FONTCONFIG_FILE=${fontsConf}
   '';
 
+  enableParallelBuilding = true;
+
   meta = with stdenv.lib; {
     description = "A 2D animation program";
     homepage = http://www.synfig.org;
diff --git a/pkgs/applications/graphics/yed/default.nix b/pkgs/applications/graphics/yed/default.nix
new file mode 100644
index 000000000000..2929513952e1
--- /dev/null
+++ b/pkgs/applications/graphics/yed/default.nix
@@ -0,0 +1,29 @@
+{ stdenv, fetchurl, makeWrapper, unzip, jre }:
+
+stdenv.mkDerivation rec {
+  name = "yEd-3.13";
+
+  src = fetchurl {
+    url = "http://www.yworks.com/products/yed/demo/${name}.zip";
+    sha256 = "1d5qs6q31k49y9gh054aafck548pv9f97b3il4iksnna1r59w5jy";
+  };
+
+  nativeBuildInputs = [ unzip makeWrapper ];
+
+  installPhase = ''
+    mkdir -p $out/yed
+    cp -r * $out/yed
+    mkdir -p $out/bin
+
+    makeWrapper ${jre}/bin/java $out/bin/yed \
+      --add-flags "-jar $out/yed/yed.jar --"
+  '';
+
+  meta = with stdenv.lib; {
+    license = licenses.unfreeRedistributable;
+    homepage = http://www.yworks.com/en/products/yfiles/yed/;
+    description = "A powerful desktop application that can be used to quickly and effectively generate high-quality diagrams";
+    platforms = jre.meta.platforms;
+    maintainer = with maintainers; [ abbradar ];
+  };
+}
diff --git a/pkgs/applications/misc/calibre/default.nix b/pkgs/applications/misc/calibre/default.nix
index f6159c79b1fc..4656e5add13f 100644
--- a/pkgs/applications/misc/calibre/default.nix
+++ b/pkgs/applications/misc/calibre/default.nix
@@ -5,11 +5,11 @@
 }:
 
 stdenv.mkDerivation rec {
-  name = "calibre-2.11.0";
+  name = "calibre-2.12.0";
 
   src = fetchurl {
     url = "mirror://sourceforge/calibre/${name}.tar.xz";
-    sha256 = "19pn55yvc7yiz21gri5838zf7n88l6m2abbwzswn4x8v9915lls1";
+    sha256 = "1qp3aq6f6ngfy8m0bj6rzdf6p2vmk4bxycxfby2n8byfhr8gaclf";
   };
 
   inherit python;
diff --git a/pkgs/applications/misc/xrandr-invert-colors/default.nix b/pkgs/applications/misc/xrandr-invert-colors/default.nix
new file mode 100644
index 000000000000..e9bb722dcab0
--- /dev/null
+++ b/pkgs/applications/misc/xrandr-invert-colors/default.nix
@@ -0,0 +1,26 @@
+{ fetchurl, stdenv, libXrandr}:
+
+stdenv.mkDerivation rec {
+  version = "v0.01";
+  name = "xrandr-invert-colors-${version}";
+  src = fetchurl {
+    url = "https://github.com/zoltanp/xrandr-invert-colors/archive/${version}.tar.gz";
+    sha256 = "1z4hxn56rlflvqanb8ncqa1xqawnda85b1b37w6r2iqs8rw52d75";
+  };
+
+  buildInputs = [ libXrandr ];
+
+  installPhase = ''
+    mkdir -p $out/bin
+    mv xrandr-invert-colors.bin xrandr-invert-colors
+    install xrandr-invert-colors $out/bin
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Inverts the colors of your screen";
+    license = stdenv.lib.licenses.gpl3Plus;
+    homepage = https://github.com/zoltanp/xrandr-invert-colors;
+    maintainers = [stdenv.lib.maintainers.magnetophon ];
+    platforms = platforms.linux;
+  }; 
+}
diff --git a/pkgs/applications/networking/browsers/chromium/common.nix b/pkgs/applications/networking/browsers/chromium/common.nix
index cfdddf288566..dea816e5be9b 100644
--- a/pkgs/applications/networking/browsers/chromium/common.nix
+++ b/pkgs/applications/networking/browsers/chromium/common.nix
@@ -190,6 +190,7 @@ let
       libExecPath="${libExecPath}"
       python build/linux/unbundle/replace_gyp_files.py ${gypFlags}
       python build/gyp_chromium -f ninja --depth "$(pwd)" ${gypFlags}
+      find . -iname '*.py[co]' -delete
     '';
 
     buildPhase = let
diff --git a/pkgs/applications/networking/browsers/rekonq/default.nix b/pkgs/applications/networking/browsers/rekonq/default.nix
index 3deabd42e013..ce36e26d6fcc 100644
--- a/pkgs/applications/networking/browsers/rekonq/default.nix
+++ b/pkgs/applications/networking/browsers/rekonq/default.nix
@@ -3,11 +3,11 @@
 assert builtins.compareVersions "4.8.3" kde4.release != 1; # https://bugs.kde.org/show_bug.cgi?id=306077
 
 stdenv.mkDerivation rec {
-  name = "rekonq-1.80"; # >=1.80 need kde >=4.9.0
+  name = "rekonq-2.4.2"; # >=1.80 need kde >=4.9.0
 
   src = fetchurl {
-    url = "mirror://sourceforge/rekonq/${name}.tar.bz2";
-    sha256 = "1lzmg8psy1j1v8vrmsyw609jv9scgnigdivx97fb4spb7x6sxn4g";
+    url = "mirror://sourceforge/rekonq/${name}.tar.xz";
+    sha256 = "09jihyf4xl7bwfwahwwbx6f11h3zqljccchnpl4mijljylr5p079";
   };
 
   buildInputs = [ kde4.kdelibs qca2 qoauth ];
diff --git a/pkgs/applications/networking/ids/daq/default.nix b/pkgs/applications/networking/ids/daq/default.nix
index 3e7a80f137d5..287a4239c2c0 100644
--- a/pkgs/applications/networking/ids/daq/default.nix
+++ b/pkgs/applications/networking/ids/daq/default.nix
@@ -1,12 +1,12 @@
 {stdenv, fetchurl, flex, bison, libpcap}:
 
 stdenv.mkDerivation rec {
-  name = "daq-2.0.2";
+  name = "daq-2.0.4";
   
   src = fetchurl {
     name = "${name}.tar.gz";
     url = "http://www.snort.org/downloads/snort/${name}.tar.gz";
-    sha256 = "1a39qbm9nc05yr8llawl7mz0ny1fci4acj9c2k1h4klrqikiwpfn";
+    sha256 = "0g15kny0s6mpqfc723jxv7mgjfh45izhwcidhjzh52fd04ysm552";
   };
   
   buildInputs = [ flex bison libpcap ];
diff --git a/pkgs/applications/networking/ids/snort/default.nix b/pkgs/applications/networking/ids/snort/default.nix
index 5b740cec9355..3f99094ffd45 100644
--- a/pkgs/applications/networking/ids/snort/default.nix
+++ b/pkgs/applications/networking/ids/snort/default.nix
@@ -1,12 +1,12 @@
 {stdenv, fetchurl, libpcap, pcre, libdnet, daq, zlib, flex, bison}:
 
 stdenv.mkDerivation rec {
-  name = "snort-2.9.6.2";
+  name = "snort-2.9.7.0";
   
   src = fetchurl {
     name = "${name}.tar.gz";
     url = "http://www.snort.org/downloads/snort/${name}.tar.gz";
-    sha256 = "0xsxbd5h701ncnhn9sf7zkmzravlqhn1182whinphfjjw72py7cf";
+    sha256 = "16z4mi7bri7ygvc0j4hhl2pgcw6xwxah1h3wk5vpy2yj8pmayf4p";
   };
   
   buildInputs = [ libpcap pcre libdnet daq zlib flex bison ];
diff --git a/pkgs/applications/networking/instant-messengers/pidgin-plugins/otr/default.nix b/pkgs/applications/networking/instant-messengers/pidgin-plugins/otr/default.nix
index 7cbc38ea0dc0..2fa7d5f37f24 100644
--- a/pkgs/applications/networking/instant-messengers/pidgin-plugins/otr/default.nix
+++ b/pkgs/applications/networking/instant-messengers/pidgin-plugins/otr/default.nix
@@ -1,10 +1,10 @@
 { stdenv, fetchurl, libotr, pidgin, intltool } :
 
 stdenv.mkDerivation rec {
-  name = "pidgin-otr-4.0.0";
+  name = "pidgin-otr-4.0.1";
   src = fetchurl {
     url = "http://www.cypherpunks.ca/otr/${name}.tar.gz";
-    sha256 = "14a6vxvlkm8wazng9aj7p82dr12857fx5is1frcyd7my5l4kysym";
+    sha256 = "02pkkf86fh5jvzsdn9y78impsgzj1n0p81kc2girvk3vq941yy0v";
   };
 
   postInstall = "ln -s \$out/lib/pidgin \$out/share/pidgin-otr";
diff --git a/pkgs/applications/networking/instant-messengers/teamspeak/client.nix b/pkgs/applications/networking/instant-messengers/teamspeak/client.nix
index 3870533aa89b..8a3e7203f265 100644
--- a/pkgs/applications/networking/instant-messengers/teamspeak/client.nix
+++ b/pkgs/applications/networking/instant-messengers/teamspeak/client.nix
@@ -1,6 +1,6 @@
 { stdenv, fetchurl, makeWrapper, zlib, glib, libpng, freetype, xorg
 , fontconfig, xlibs, qt5, xkeyboard_config, alsaLib, pulseaudio ? null
-, libredirect, quazip
+, libredirect, quazip, less, which
 }:
 
 let
@@ -33,11 +33,11 @@ stdenv.mkDerivation rec {
                 else "1b3nbvfpd8lx3dig8z5yk6zjkbmsy6y938dhj1f562wc8adixciz";
   };
 
-  buildInputs = [ makeWrapper ];
+  buildInputs = [ makeWrapper less which ];
 
   unpackPhase =
     ''
-      yes | sh $src
+      echo -e 'q\ny' | sh -xe $src
       cd TeamSpeak*
     '';
 
diff --git a/pkgs/applications/version-management/git-and-tools/git/default.nix b/pkgs/applications/version-management/git-and-tools/git/default.nix
index 7ba69a9fc182..69e88f32c41d 100644
--- a/pkgs/applications/version-management/git-and-tools/git/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/git/default.nix
@@ -24,7 +24,12 @@ stdenv.mkDerivation {
     sha256 = "0mvgvr2hz25p49dhhizcw9591f2h17y2699mpmndis3kzap0c6zy";
   };
 
-  patches = [ ./docbook2texi.patch ./symlinks-in-bin.patch ./cert-path.patch ];
+  patches = [
+    ./docbook2texi.patch
+    ./symlinks-in-bin.patch
+    ./cert-path.patch
+    ./ssl-cert-file.patch
+  ];
 
   buildInputs = [curl openssl zlib expat gettext cpio makeWrapper]
     ++ stdenv.lib.optionals withManual [ asciidoc texinfo xmlto docbook2x
@@ -142,6 +147,6 @@ stdenv.mkDerivation {
     '';
 
     platforms = stdenv.lib.platforms.all;
-    maintainers = with stdenv.lib.maintainers; [ simons the-kenny ];
+    maintainers = with stdenv.lib.maintainers; [ simons the-kenny wmertens ];
   };
 }
diff --git a/pkgs/applications/version-management/git-and-tools/git/ssl-cert-file.patch b/pkgs/applications/version-management/git-and-tools/git/ssl-cert-file.patch
new file mode 100644
index 000000000000..dd216b7bf6f8
--- /dev/null
+++ b/pkgs/applications/version-management/git-and-tools/git/ssl-cert-file.patch
@@ -0,0 +1,13 @@
+This patch adds support for the OpenSSL SSL_CERT_FILE environment variable.
+GIT_SSL_CAINFO still takes precedence.
+
+--- git-orig/http.c.orig	2014-11-25 23:27:56.000000000 +0100
++++ git-orig/http.c	2014-11-25 23:28:48.000000000 +0100
+@@ -433,6 +433,7 @@
+ #if LIBCURL_VERSION_NUM >= 0x070908
+ 	set_from_env(&ssl_capath, "GIT_SSL_CAPATH");
+ #endif
++	set_from_env(&ssl_cainfo, "SSL_CERT_FILE");
+ 	set_from_env(&ssl_cainfo, "GIT_SSL_CAINFO");
+ 
+ 	set_from_env(&user_agent, "GIT_HTTP_USER_AGENT");
diff --git a/pkgs/applications/version-management/src/default.nix b/pkgs/applications/version-management/src/default.nix
index d3b0ee9131be..ced82dd45c00 100644
--- a/pkgs/applications/version-management/src/default.nix
+++ b/pkgs/applications/version-management/src/default.nix
@@ -1,11 +1,11 @@
 { stdenv, fetchurl, python, rcs, git }:
 
 stdenv.mkDerivation rec {
-  name = "src-0.12";
+  name = "src-0.13";
 
   src = fetchurl {
     url = "http://www.catb.org/~esr/src/${name}.tar.gz";
-    sha256 = "1w8k9z2dxim99nniid9kjsc5lzri7m4sd0n819y73aqcdi54lr1s";
+    sha256 = "03x0slgi6bnzgfn7f9qbl6jma0pj7357kwdh832l3v8zafk41p51";
   };
 
   buildInputs = [ python ];
diff --git a/pkgs/applications/version-management/src/path.patch b/pkgs/applications/version-management/src/path.patch
index 05e643e9e0ff..ef500c8e04e7 100644
--- a/pkgs/applications/version-management/src/path.patch
+++ b/pkgs/applications/version-management/src/path.patch
@@ -1,24 +1,24 @@
-diff -Naur src-0.12-orig/src src-0.12/src
---- src-0.12-orig/src	2014-11-21 08:19:59.000000000 -0500
-+++ src-0.12/src	2014-11-21 15:54:54.598113846 -0500
+diff -Naur src-0.13-orig/src src-0.13/src
+--- src-0.13-orig/src	2014-11-24 03:56:16.000000000 -0500
++++ src-0.13/src	2014-11-26 16:32:32.925151003 -0500
 @@ -1,4 +1,4 @@
 -#!/usr/bin/env python2
 +#!@python@/bin/python
  #
  # src - simple revision control.
  #
-@@ -58,6 +58,8 @@
+@@ -51,6 +51,8 @@
  
  import sys, os, subprocess, time, calendar, stat, glob, shutil, hashlib
  
 +os.environ['PATH'] = "@rcs@/bin:@git@/bin:" + os.environ['PATH']
 +
- version="0.12"
+ version="0.13"
  
  def rfc3339(t):
-diff -Naur src-0.12-orig/srctest src-0.12/srctest
---- src-0.12-orig/srctest	2014-11-21 08:12:00.000000000 -0500
-+++ src-0.12/srctest	2014-11-21 15:58:31.370500990 -0500
+diff -Naur src-0.13-orig/srctest src-0.13/srctest
+--- src-0.13-orig/srctest	2014-11-21 08:12:00.000000000 -0500
++++ src-0.13/srctest	2014-11-26 16:33:13.627715388 -0500
 @@ -12,7 +12,7 @@
  
  # Set the PATH to include the current directory, so the repository
diff --git a/pkgs/applications/video/mpv/default.nix b/pkgs/applications/video/mpv/default.nix
index 28b3727fa4f3..5acdcac97372 100644
--- a/pkgs/applications/video/mpv/default.nix
+++ b/pkgs/applications/video/mpv/default.nix
@@ -20,7 +20,7 @@
 # For screenshots
 , libpngSupport ? true, libpng ? null
 # for Youtube support
-, quviSupport ? false, libquvi ? null
+, youtubeSupport ? false, youtubeDL ? null
 , cacaSupport ? false, libcaca ? null
 , vaapiSupport ? false, libva ? null
 }:
@@ -41,7 +41,7 @@ assert jackaudioSupport -> jack2 != null;
 assert pulseSupport -> pulseaudio != null;
 assert bs2bSupport -> libbs2b != null;
 assert libpngSupport -> libpng != null;
-assert quviSupport -> libquvi != null;
+assert youtubeSupport -> youtubeDL != null;
 assert cacaSupport -> libcaca != null;
 
 # Purity problem: Waf needed to be is downloaded by bootstrap.py
@@ -50,19 +50,19 @@ assert cacaSupport -> libcaca != null;
 
 let
   waf = fetchurl {
-    url = http://ftp.waf.io/pub/release/waf-1.7.16;
-    sha256 = "b64dc26c882572415fd450b745006107965f3fe17b357e3eb43d6676c9635a61";
+    url = http://ftp.waf.io/pub/release/waf-1.8.1;
+    sha256 = "ec658116ba0b96629d91fde0b32321849e866e0819f1e835c4c2c7f7ffe1a21d";
   };
 
 in
 
 stdenv.mkDerivation rec {
   name = "mpv-${version}";
-  version = "0.6.2";
+  version = "0.7.0";
 
   src = fetchurl {
     url = "https://github.com/mpv-player/mpv/archive/v${version}.tar.gz";
-    sha256 = "1s42i3vf8i86lx62kw00vvimjizvp8zpxdq53mqhdz1p5im2ylr0";
+    sha256 = "0rz8dp44yag442gamaa2vdmf69h25gqh2bgybx89prkfh8n4hy8x";
   };
 
   buildInputs = with stdenv.lib;
@@ -82,7 +82,7 @@ stdenv.mkDerivation rec {
     ++ optional speexSupport speex
     ++ optional bs2bSupport libbs2b
     ++ optional libpngSupport libpng
-    ++ optional quviSupport libquvi
+    ++ optional youtubeSupport youtubeDL
     ++ optional sdl2Support SDL2
     ++ optional cacaSupport libcaca
     ++ optional vaapiSupport libva
@@ -126,6 +126,5 @@ stdenv.mkDerivation rec {
 }
 
 # TODO: Wayland support
-# TODO: investigate libquvi problems (related to Youtube support)
 # TODO: investigate caca support
 # TODO: investigate lua5_sockets bug