about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/graphics/ImageMagick/default.nix4
-rw-r--r--pkgs/applications/graphics/inkscape/configure-python-libs.patch4
-rw-r--r--pkgs/applications/graphics/inkscape/default.nix5
-rw-r--r--pkgs/applications/graphics/inkscape/libpng-setjmp.patch62
-rw-r--r--pkgs/applications/networking/instant-messengers/pidgin/default.nix10
-rw-r--r--pkgs/applications/networking/sync/rsync/default.nix6
-rw-r--r--pkgs/applications/networking/yafc/default.nix20
-rw-r--r--pkgs/applications/office/abiword/default.nix6
-rw-r--r--pkgs/applications/version-management/git-and-tools/default.nix71
-rw-r--r--pkgs/applications/version-management/git-and-tools/git/default.nix (renamed from pkgs/applications/version-management/git/default.nix)0
-rw-r--r--pkgs/applications/version-management/git-and-tools/git/docbook2texi-2.patch28
-rw-r--r--pkgs/applications/version-management/git-and-tools/git/docbook2texi.patch (renamed from pkgs/applications/version-management/git/docbook2texi.patch)0
-rw-r--r--pkgs/applications/version-management/git-and-tools/git/git-git.nix (renamed from pkgs/applications/version-management/git/git-git.nix)7
-rw-r--r--pkgs/applications/version-management/git-and-tools/git/glob-path.patch (renamed from pkgs/applications/version-management/git/glob-path.patch)0
-rw-r--r--pkgs/applications/version-management/git-and-tools/hg2git/default.nix26
-rw-r--r--pkgs/applications/version-management/git-and-tools/qgit/default.nix (renamed from pkgs/applications/version-management/qgit/default.nix)0
-rw-r--r--pkgs/applications/version-management/git-and-tools/qgit/qgit-git.nix17
-rw-r--r--pkgs/applications/version-management/git-and-tools/stgit/default.nix (renamed from pkgs/applications/version-management/stgit/default.nix)0
-rw-r--r--pkgs/applications/version-management/subversion-1.5.x/default.nix6
-rw-r--r--pkgs/applications/virtualization/virtualbox/2.1.2.nix47
20 files changed, 298 insertions, 21 deletions
diff --git a/pkgs/applications/graphics/ImageMagick/default.nix b/pkgs/applications/graphics/ImageMagick/default.nix
index 1050332cc287..e5a57dd6db9e 100644
--- a/pkgs/applications/graphics/ImageMagick/default.nix
+++ b/pkgs/applications/graphics/ImageMagick/default.nix
@@ -1,13 +1,13 @@
 args: with args;
 
-let version = "6.4.1-1"; in
+let version = "6.4.8-9"; in
 
 stdenv.mkDerivation (rec {
   name = "ImageMagick-${version}";
 
   src = fetchurl {
     url = "mirror://imagemagick/${name}.tar.bz2";
-    sha256 = "0a8defbfa867bb5e969f898d9a3b65a8c4f6952cb71411b40f005dd0a183644e";
+    sha256 = "1ngfs99wryrc7v5pqrjbcrvhsilc29iaj6zplzxm450f49xmpidq";
   };
 
   configureFlags = ''
diff --git a/pkgs/applications/graphics/inkscape/configure-python-libs.patch b/pkgs/applications/graphics/inkscape/configure-python-libs.patch
index 840f15a40324..c79006d33201 100644
--- a/pkgs/applications/graphics/inkscape/configure-python-libs.patch
+++ b/pkgs/applications/graphics/inkscape/configure-python-libs.patch
@@ -1,3 +1,7 @@
+Work around Python misdetection and set `PYTHON_LIBS' to
+"-L/nix/store/... -lpython2.4" instead of "/nix/store/.../libpython2.4.so".
+Changed to 2.5.
+
 --- inkscape-0.45.1/configure	2007-03-20 14:56:43.000000000 +0100
 +++ inkscape-0.45.1/configure	2008-02-22 16:19:10.000000000 +0100
 @@ -10202,7 +10202,7 @@ if test "x$with_python" = "xyes"; then
diff --git a/pkgs/applications/graphics/inkscape/default.nix b/pkgs/applications/graphics/inkscape/default.nix
index 1f8bff4db9ba..33defc0bea42 100644
--- a/pkgs/applications/graphics/inkscape/default.nix
+++ b/pkgs/applications/graphics/inkscape/default.nix
@@ -8,10 +8,7 @@ stdenv.mkDerivation rec {
     sha256 = "0flrjqa68vnnn8lrhj86xpa6h2cyzrvjy6873v9id092f86ix1li";
   };
 
-  # Work around Python misdetection and set `PYTHON_LIBS' to
-  # "-L/nix/store/... -lpython2.4" instead of "/nix/store/.../libpython2.4.so".
-  # Changed to 2.5
-  patches = [ ./configure-python-libs.patch ];
+  patches = [ ./configure-python-libs.patch ./libpng-setjmp.patch ]; 
 
   propagatedBuildInputs = [
     # Python is used at run-time to execute scripts, e.g., those from
diff --git a/pkgs/applications/graphics/inkscape/libpng-setjmp.patch b/pkgs/applications/graphics/inkscape/libpng-setjmp.patch
new file mode 100644
index 000000000000..623e891b24ba
--- /dev/null
+++ b/pkgs/applications/graphics/inkscape/libpng-setjmp.patch
@@ -0,0 +1,62 @@
+Include <png.h> as early as possible to make sure <setjmp.h> is not
+included before it.
+
+See http://thread.gmane.org/gmane.linux.distributions.nixos/1501 .
+
+--- inkscape-0.46/src/sp-image.cpp	2008-03-11 05:19:56.000000000 +0100
++++ inkscape-0.46/src/sp-image.cpp	2009-01-26 15:34:33.000000000 +0100
+@@ -17,6 +17,8 @@
+ # include "config.h"
+ #endif
+ 
++#include <png.h>
++
+ #include <cstring>
+ #include <string>
+ #include <libnr/nr-matrix-fns.h>
+@@ -41,7 +43,6 @@
+ #include "libnr/nr-matrix-fns.h"
+ 
+ #include "io/sys.h"
+-#include <png.h>
+ #if ENABLE_LCMS
+ #include "color-profile-fns.h"
+ #include "color-profile.h"
+
+--- inkscape-0.46/src/dialogs/export.cpp	2008-03-11 05:19:54.000000000 +0100
++++ inkscape-0.46/src/dialogs/export.cpp	2009-01-26 17:01:13.000000000 +0100
+@@ -20,6 +20,7 @@
+ # include "config.h"
+ #endif
+ 
++#include <png.h>
+ #include <gtk/gtk.h>
+ #include <gtkmm/box.h>
+ #include <gtkmm/buttonbox.h>
+@@ -60,7 +61,6 @@
+ #include "io/sys.h"
+ 
+ #include "helper/png-write.h"
+-#include <png.h>
+ 
+ 
+ #define SP_EXPORT_MIN_SIZE 1.0
+
+--- inkscape-0.46/src/main.cpp	2008-03-11 05:20:50.000000000 +0100
++++ inkscape-0.46/src/main.cpp	2009-01-26 17:57:12.000000000 +0100
+@@ -26,6 +26,7 @@
+ #ifdef HAVE_CONFIG_H
+ # include "config.h"
+ #endif
++#include <png.h>
+ #include "path-prefix.h"
+ 
+ #include <gtk/gtkmessagedialog.h>
+@@ -111,7 +112,6 @@ using Inkscape::Extension::Internal::Pri
+ 
+ #include "main-cmdlineact.h"
+ 
+-#include <png.h>
+ #include <errno.h>
+ 
+ enum {
diff --git a/pkgs/applications/networking/instant-messengers/pidgin/default.nix b/pkgs/applications/networking/instant-messengers/pidgin/default.nix
index 434c1983e03a..93c3a46b6d1a 100644
--- a/pkgs/applications/networking/instant-messengers/pidgin/default.nix
+++ b/pkgs/applications/networking/instant-messengers/pidgin/default.nix
@@ -13,17 +13,17 @@
 { stdenv, fetchurl, pkgconfig, gtk, gtkspell, aspell,
   GStreamer, startupnotification, gettext,
   perl, perlXMLParser, libxml2, nss,
-  libXScrnSaver, ncurses, avahi, dbus, dbus_glib
+  libXScrnSaver, ncurses, avahi, dbus, dbus_glib, intltool
   , lib
   , openssl ? null
   , gnutls ? null
 } :
 
 stdenv.mkDerivation {
-  name = "pidgin-2.5.2";
+  name = "pidgin-2.5.4";
   src = fetchurl {
-    url = mirror://sourceforge/pidgin/pidgin-2.5.2.tar.bz2;
-    sha256 = "1p39nvwy3c7wc97a6i88f6rrg5d3a6vv0wdard4vkfmva81l24r0";
+    url = mirror://sourceforge/pidgin/pidgin-2.5.4.tar.bz2;
+    sha256 = "0qqvv9x5p2yxmw57sj3hvc10vxpd9mqv61w1pk97qcwbggwvxgn6";
   };
 
   inherit nss ncurses;
@@ -36,7 +36,7 @@ stdenv.mkDerivation {
   ++
   [nss
     libXScrnSaver ncurses
-    avahi dbus dbus_glib
+    avahi dbus dbus_glib intltool
   ]
   ;
 
diff --git a/pkgs/applications/networking/sync/rsync/default.nix b/pkgs/applications/networking/sync/rsync/default.nix
index 748fef9439c2..cba78189789f 100644
--- a/pkgs/applications/networking/sync/rsync/default.nix
+++ b/pkgs/applications/networking/sync/rsync/default.nix
@@ -1,9 +1,9 @@
 {stdenv, fetchurl}:
 
 stdenv.mkDerivation {
-  name = "rsync-3.0.4";
+  name = "rsync-3.0.5";
   src = fetchurl {
-    url = http://rsync.samba.org/ftp/rsync/src/rsync-3.0.4.tar.gz;
-    sha256 = "0lfyrs8vj47p1p19b0f5grxhxcn00hpb1yvvprbwzr6j077ljfkl";
+    url = http://rsync.samba.org/ftp/rsync/src/rsync-3.0.5.tar.gz;
+    sha256 = "1js36yv5s9dic524s7jczqk5myzp67bp24rqhbnikg6lh6pj1b20";
   };
 }
diff --git a/pkgs/applications/networking/yafc/default.nix b/pkgs/applications/networking/yafc/default.nix
new file mode 100644
index 000000000000..ae3ce06ca50f
--- /dev/null
+++ b/pkgs/applications/networking/yafc/default.nix
@@ -0,0 +1,20 @@
+{stdenv, fetchurl, readline, openssh}:
+
+stdenv.mkDerivation {
+  name = "yafc-1.1.1";
+  src = fetchurl {
+    url = mirror://sourceforge/yafc/yafc-1.1.1.tar.bz2;
+    sha256 = "ab72b2ed89fb75dbe8ebd119458cf513392225f367cccfad881e9780aefcd7e6";
+  };
+
+  buildInputs = [readline openssh];
+
+  patchPhase = "
+    sed -e 's@/usr/bin/ssh@${openssh}/bin/ssh@' -i src/main.c
+  ";
+
+  meta = {
+    description = "ftp/sftp client with readline, autocompletion and bookmarks";
+    homepage = http://yafc.sourceforge.net;
+  };
+}
diff --git a/pkgs/applications/office/abiword/default.nix b/pkgs/applications/office/abiword/default.nix
index d7a88d739623..7f22187793e0 100644
--- a/pkgs/applications/office/abiword/default.nix
+++ b/pkgs/applications/office/abiword/default.nix
@@ -4,10 +4,10 @@ enchant, wv
 }:
 
 stdenv.mkDerivation {
-  name = "abiword-2.6.4";
+  name = "abiword-2.6.6";
   src = fetchurl {
-    url = http://www.abisource.com/downloads/abiword/2.6.4/source/abiword-2.6.4.tar.gz;
-    sha256 = "1zp9p2dfrskn7r827ivvii2477ysxkvrsshk79hgw3xhd5mplbad";
+    url = http://www.abisource.org/downloads/abiword/2.6.6/source/abiword-2.6.6.tar.gz;
+    sha256 = "1cgi6l3wd82vgni4wcqasyl2rvxwffliyqgbwvzv0nn99wasg5gx";
   };
 
   buildInputs = [pkgconfig gtk libglade libgnomeprint libgnomeprintui
diff --git a/pkgs/applications/version-management/git-and-tools/default.nix b/pkgs/applications/version-management/git-and-tools/default.nix
new file mode 100644
index 000000000000..9506e7a5f0ef
--- /dev/null
+++ b/pkgs/applications/version-management/git-and-tools/default.nix
@@ -0,0 +1,71 @@
+/* moving all git tools into one attribute set because git is unlikely to be
+ * referenced by other packages and you can get a fast overview.
+*/
+args: with args; with pkgs;
+let
+  inherit (pkgs) stdenv fetchurl getConfig;
+  inherit (pkgs.bleedingEdgeRepos) sourceByName;
+in
+rec {
+
+  git = import ./git {
+    inherit fetchurl stdenv curl openssl zlib expat perl gettext
+      asciidoc texinfo xmlto docbook2x
+      docbook_xsl docbook_xml_dtd_42 libxslt
+      cpio tcl tk makeWrapper subversion;
+    svnSupport = getConfig ["git" "svnSupport"] false; # for git-svn support
+    guiSupport = getConfig ["git" "guiSupport"] false;
+    perlLibs = [perlLWP perlURI perlTermReadKey subversion];
+  };
+
+  gitGit = import ./git/git-git.nix {
+    inherit fetchurl stdenv curl openssl zlib expat perl gettext
+      asciidoc texinfo xmlto docbook2x
+      docbook_xsl docbook_xml_dtd_42 libxslt
+      cpio tcl tk makeWrapper subversion autoconf;
+    inherit (bleedingEdgeRepos) sourceByName;
+    svnSupport = getConfig ["git" "svnSupport"] false; # for git-svn support
+    guiSupport = getConfig ["git" "guiSupport"] false;
+    perlLibs = [perlLWP perlURI perlTermReadKey subversion];
+  };
+
+  qgit = import ./qgit {
+    inherit fetchurl stdenv;
+    inherit (xlibs) libXext libX11;
+    qt = qt3;
+  };
+
+  qgitGit = import ./qgit/qgit-git.nix {
+    inherit fetchurl stdenv;
+    inherit (xlibs) libXext libX11;
+    inherit (bleedingEdgeRepos) sourceByName;
+    qt = qt4;
+  };
+
+
+  stgit = import ./stgit {
+        inherit fetchurl stdenv python git;
+  };
+
+  topGit = stdenv.mkDerivation {
+      name = "TopGit-git-patched";
+      src = sourceByName "topGit"; # destination directory is patched
+      installPhase = ''
+        mkdir -p $out/etc/bash_completion.d
+        make install
+        mv contrib/tg-completion.bash $out/etc/bash_completion.d
+      '';
+      dontPatchELF = 1;
+      meta = {
+        description = "TopGit aims to make handling of large amount of interdependent topic branches easier";
+        homepage = http://repo.or.cz/w/topgit.git; # maybe there is also another one, I haven't checked
+        license = "GPLv2";
+    };
+  };
+
+  hg2git = import ./hg2git {
+    inherit fetchurl stdenv mercurial coreutils git makeWrapper;
+    inherit (bleedingEdgeRepos) sourceByName;
+  };
+
+}
diff --git a/pkgs/applications/version-management/git/default.nix b/pkgs/applications/version-management/git-and-tools/git/default.nix
index 7824eaf69735..7824eaf69735 100644
--- a/pkgs/applications/version-management/git/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/git/default.nix
diff --git a/pkgs/applications/version-management/git-and-tools/git/docbook2texi-2.patch b/pkgs/applications/version-management/git-and-tools/git/docbook2texi-2.patch
new file mode 100644
index 000000000000..25a76ea3dd23
--- /dev/null
+++ b/pkgs/applications/version-management/git-and-tools/git/docbook2texi-2.patch
@@ -0,0 +1,28 @@
+
+make sure `gitman.info' isn't produced since it's broken (duplicate
+node names).
+
+diff --git a/Documentation/Makefile b/Documentation/Makefile
+--- a/Documentation/Makefile
++++ b/Documentation/Makefile
+@@ -84,7 +84,7 @@ man1: $(DOC_MAN1)
+ man5: $(DOC_MAN5)
+ man7: $(DOC_MAN7)
+ 
+-info: git.info gitman.info
++info: git.info
+ 
+ install: man
+ 	$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)
+@@ -96,10 +96,9 @@ install: man
+ 
+ install-info: info
+ 	$(INSTALL) -d -m 755 $(DESTDIR)$(infodir)
+-	$(INSTALL) -m 644 git.info gitman.info $(DESTDIR)$(infodir)
++	$(INSTALL) -m 644 git.info $(DESTDIR)$(infodir)
+ 	if test -r $(DESTDIR)$(infodir)/dir; then \
+ 	  $(INSTALL_INFO) --info-dir=$(DESTDIR)$(infodir) git.info ;\
+-	  $(INSTALL_INFO) --info-dir=$(DESTDIR)$(infodir) gitman.info ;\
+ 	else \
+ 	  echo "No directory found in $(DESTDIR)$(infodir)" >&2 ; \
+ 	fi
diff --git a/pkgs/applications/version-management/git/docbook2texi.patch b/pkgs/applications/version-management/git-and-tools/git/docbook2texi.patch
index b2a6fbcaec5f..b2a6fbcaec5f 100644
--- a/pkgs/applications/version-management/git/docbook2texi.patch
+++ b/pkgs/applications/version-management/git-and-tools/git/docbook2texi.patch
diff --git a/pkgs/applications/version-management/git/git-git.nix b/pkgs/applications/version-management/git-and-tools/git/git-git.nix
index cb885280b5a3..a711f399a82f 100644
--- a/pkgs/applications/version-management/git/git-git.nix
+++ b/pkgs/applications/version-management/git-and-tools/git/git-git.nix
@@ -14,11 +14,16 @@ assert svnSupport -> (subversion != null && perlLibs != [] && subversion.perlBin
 assert svnSupport -> subversion.perlBindings;
 
 stdenv.mkDerivation rec {
+  # the glob patch adds the filter [touching paths (glob)] to gitk
+  # contact marco-oweber@gmx.de if you want to know more details
   name = "git-git-with-glob-patch";
 
   src = sourceByName "git";
 
-  patches = [  ./glob-path.patch ./docbook2texi.patch ];
+  patchePhase = ''
+    patch -p1 < ${./docbook2texi-2.patch}
+    sed -i 's/docbook2x-texi/docbook2texi/gc' Documentation/Makefile
+  '';
   # maybe this introduces unneccessary dependencies ?
   patchPhase = "
     unset patchPhase; patchPhase;
diff --git a/pkgs/applications/version-management/git/glob-path.patch b/pkgs/applications/version-management/git-and-tools/git/glob-path.patch
index 7515ade57875..7515ade57875 100644
--- a/pkgs/applications/version-management/git/glob-path.patch
+++ b/pkgs/applications/version-management/git-and-tools/git/glob-path.patch
diff --git a/pkgs/applications/version-management/git-and-tools/hg2git/default.nix b/pkgs/applications/version-management/git-and-tools/hg2git/default.nix
new file mode 100644
index 000000000000..291391b67191
--- /dev/null
+++ b/pkgs/applications/version-management/git-and-tools/hg2git/default.nix
@@ -0,0 +1,26 @@
+args: with args;
+stdenv.mkDerivation {
+  name = "hg2git";
+
+  src = sourceByName "hg2git";
+
+  buildInputs =([mercurial.python mercurial makeWrapper]);
+
+  installPhase = ''
+    ensureDir $out/bin;
+    cp hg2git.sh hg2git.py $out/bin
+    cat >> $out/bin/hg2git-doc << EOF
+    #!${coreutils}/bin/cat
+    $(cat hg2git.txt)
+    EOF
+    chmod +x $out/bin/hg2git-doc
+    wrapProgram $out/bin/hg2git.sh \
+      --set PYTHONPATH "$(echo ${mercurial}/lib/python*/site-packages)"
+  '';
+
+  meta = {
+      description = "mercurial to git one way conversion";
+      homepage = "http://git.grml.org/?p=hg-to-git.git;a=summary";
+      license = "?"; # the .py file is GPLv2
+  };
+}
diff --git a/pkgs/applications/version-management/qgit/default.nix b/pkgs/applications/version-management/git-and-tools/qgit/default.nix
index e84f447f505f..e84f447f505f 100644
--- a/pkgs/applications/version-management/qgit/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/qgit/default.nix
diff --git a/pkgs/applications/version-management/git-and-tools/qgit/qgit-git.nix b/pkgs/applications/version-management/git-and-tools/qgit/qgit-git.nix
new file mode 100644
index 000000000000..b794b34052cb
--- /dev/null
+++ b/pkgs/applications/version-management/git-and-tools/qgit/qgit-git.nix
@@ -0,0 +1,17 @@
+{stdenv, fetchurl, qt, libXext, libX11, sourceByName}:
+
+stdenv.mkDerivation rec {
+  name = "qgit-git";
+  meta =
+  {
+    license = "GPLv2";
+    homepage = "http://digilander.libero.it/mcostalba/";
+    description = "Graphical front-end to Git";
+  };
+  src = sourceByName "qgit";
+  buildInputs = [qt libXext libX11];
+  buildPhase = ''
+    qmake PREFIX=$out
+    make
+  '';
+}
diff --git a/pkgs/applications/version-management/stgit/default.nix b/pkgs/applications/version-management/git-and-tools/stgit/default.nix
index f31e6ec16b03..f31e6ec16b03 100644
--- a/pkgs/applications/version-management/stgit/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/stgit/default.nix
diff --git a/pkgs/applications/version-management/subversion-1.5.x/default.nix b/pkgs/applications/version-management/subversion-1.5.x/default.nix
index bde985a64f00..b89ef9cf468a 100644
--- a/pkgs/applications/version-management/subversion-1.5.x/default.nix
+++ b/pkgs/applications/version-management/subversion-1.5.x/default.nix
@@ -20,13 +20,13 @@ assert compressionSupport -> neon.compressionSupport;
 
 stdenv.mkDerivation rec {
 
-  version = "1.5.4";
+  version = "1.5.5";
 
   name = "subversion-${version}";
 
   src = fetchurl {
-    url = http://subversion.tigris.org/downloads/subversion-1.5.4.tar.bz2;
-    sha256 = "0h7v8ngbjmxbcwjxl4y7w6qygs0qc228jdpqf5s2i21rnmbn4jz2";
+    url = http://subversion.tigris.org/downloads/subversion-1.5.5.tar.bz2;
+    sha256 = "1gkpmnwspb3x1310l97kb7n1kh5bmdb7bzq92xwm34sqbnx29kw8";
   };
 
   buildInputs = [zlib apr aprutil]
diff --git a/pkgs/applications/virtualization/virtualbox/2.1.2.nix b/pkgs/applications/virtualization/virtualbox/2.1.2.nix
new file mode 100644
index 000000000000..b33c58455fa2
--- /dev/null
+++ b/pkgs/applications/virtualization/virtualbox/2.1.2.nix
@@ -0,0 +1,47 @@
+{stdenv, fetchurl, iasl, dev86, libxslt, libxml2, libX11, xproto, libXext, libXcursor, qt3, qt4, libIDL, SDL, hal, libcap, zlib, libpng, glib, kernel}:
+
+stdenv.mkDerivation {
+  name = "virtualbox-2.1.2";
+
+  src = fetchurl {
+    url = http://download.virtualbox.org/virtualbox/2.1.2/VirtualBox-2.1.2-OSE.tar.bz2;
+    sha256 = "d3c1ae8ed7594094aaf8496204c5415479e1943e5b5179c5baae8a66885362de";
+  };
+
+  buildInputs = [iasl dev86 libxslt libxml2 xproto libX11 libXext libXcursor qt3 qt4 libIDL SDL hal libcap glib kernel];
+
+  patchPhase = "
+    set -x
+    MODULES_BUILD_DIR=`echo ${kernel}/lib/modules/*/build`
+    sed -e 's@/lib/modules/`uname -r`/build@'$MODULES_BUILD_DIR@ \\
+        -i configure
+    ls kBuild/bin/linux.x86/k* tools/linux.x86/bin/* | xargs -n 1 patchelf --set-interpreter ${stdenv.glibc}/lib/ld-linux.so.2 
+    export USER=nix
+    set +x
+  ";
+
+  configurePhase = ''
+    # It wants the qt utils from qt3, and it takes them from QTDIR
+    export QTDIR=${qt3}
+    ./configure --with-qt-dir=${qt3} --with-qt4-dir=${qt4} --disable-python --disable-alsa --disable-pulse --disable-hardening
+    sed -e 's@PKG_CONFIG_PATH=.*@PKG_CONFIG_PATH=${libIDL}/lib/pkgconfig:${glib}/lib/pkgconfig ${libIDL}/bin/libIDL-config-2@' \
+        -i AutoConfig.kmk
+    sed -e 's@arch/x86/@@' \
+        -i Config.kmk
+    cat >> AutoConfig.kmk << END_PATHS
+    VBOX_PATH_APP_PRIVATE := $out
+    VBOX_PATH_APP_DOCS := $out/doc
+    END_PATHS
+  '';
+
+  buildPhase = "
+    source env.sh
+    kmk
+  ";
+    
+  
+  meta = {
+    description = "PC emulator";
+    homepage = http://www.virtualbox.org/;
+  };
+}