about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/bristol/default.nix6
-rw-r--r--pkgs/applications/audio/cmus/default.nix4
-rw-r--r--pkgs/applications/audio/csound/default.nix4
-rw-r--r--pkgs/applications/audio/deadbeef/default.nix6
-rw-r--r--pkgs/applications/audio/ekho/default.nix4
-rw-r--r--pkgs/applications/audio/fldigi/default.nix4
-rw-r--r--pkgs/applications/audio/fluidsynth/default.nix4
-rw-r--r--pkgs/applications/audio/lmms/default.nix4
-rw-r--r--pkgs/applications/audio/mhwaveedit/default.nix4
-rw-r--r--pkgs/applications/audio/minimodem/default.nix4
-rw-r--r--pkgs/applications/audio/pamixer/default.nix4
-rw-r--r--pkgs/applications/audio/paprefs/default.nix4
-rw-r--r--pkgs/applications/audio/pavucontrol/default.nix4
-rw-r--r--pkgs/applications/audio/projectm/default.nix4
-rw-r--r--pkgs/applications/audio/qmmp/default.nix4
-rw-r--r--pkgs/applications/audio/sonic-visualiser/default.nix4
-rw-r--r--pkgs/applications/misc/gqrx/default.nix6
-rw-r--r--pkgs/applications/networking/browsers/chromium/common.nix4
-rw-r--r--pkgs/applications/networking/browsers/firefox-bin/default.nix4
-rw-r--r--pkgs/applications/networking/browsers/mozilla-plugins/google-talk-plugin/default.nix4
-rw-r--r--pkgs/applications/networking/instant-messengers/oneteam/default.nix2
-rw-r--r--pkgs/applications/networking/instant-messengers/sflphone/default.nix4
-rw-r--r--pkgs/applications/networking/instant-messengers/skype/default.nix4
-rw-r--r--pkgs/applications/networking/instant-messengers/teamspeak/client.nix4
-rw-r--r--pkgs/applications/networking/remote/freerdp/default.nix2
-rw-r--r--pkgs/applications/networking/remote/freerdp/unstable.nix6
-rw-r--r--pkgs/applications/office/zotero/firefox-bin/default.nix4
-rw-r--r--pkgs/applications/video/aegisub/default.nix6
-rw-r--r--pkgs/applications/video/bomi/default.nix6
-rw-r--r--pkgs/applications/video/kodi/default.nix6
-rw-r--r--pkgs/applications/video/mplayer/default.nix6
-rw-r--r--pkgs/applications/video/mpv/default.nix6
-rw-r--r--pkgs/applications/video/mythtv/default.nix4
-rw-r--r--pkgs/applications/video/simplescreenrecorder/default.nix4
-rw-r--r--pkgs/applications/video/vlc/default.nix4
-rw-r--r--pkgs/applications/virtualization/qemu/default.nix10
-rw-r--r--pkgs/applications/virtualization/virtualbox/default.nix4
37 files changed, 79 insertions, 89 deletions
diff --git a/pkgs/applications/audio/bristol/default.nix b/pkgs/applications/audio/bristol/default.nix
index b27ac0586025..d45ab8182731 100644
--- a/pkgs/applications/audio/bristol/default.nix
+++ b/pkgs/applications/audio/bristol/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, alsaLib, jack2, pkgconfig, pulseaudio, xlibs }:
+{ stdenv, fetchurl, alsaLib, jack2, pkgconfig, libpulseaudio, xlibs }:
 
 stdenv.mkDerivation  rec {
   name = "bristol-${version}";
@@ -10,7 +10,7 @@ stdenv.mkDerivation  rec {
   };
 
   buildInputs = [
-    alsaLib jack2 pkgconfig pulseaudio xlibs.libX11 xlibs.libXext
+    alsaLib jack2 pkgconfig libpulseaudio xlibs.libX11 xlibs.libXext
     xlibs.xproto
   ];
 
@@ -26,4 +26,4 @@ stdenv.mkDerivation  rec {
     platforms = platforms.linux;
     maintainers = [ maintainers.goibhniu ];
   };
-}
\ No newline at end of file
+}
diff --git a/pkgs/applications/audio/cmus/default.nix b/pkgs/applications/audio/cmus/default.nix
index fd252754d660..a5cfdf227bb3 100644
--- a/pkgs/applications/audio/cmus/default.nix
+++ b/pkgs/applications/audio/cmus/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchgit, ncurses, pkgconfig, alsaLib, flac, libmad, ffmpeg, libvorbis, libmpc, mp4v2, libcue, pulseaudio}:
+{ stdenv, fetchgit, ncurses, pkgconfig, alsaLib, flac, libmad, ffmpeg, libvorbis, libmpc, mp4v2, libcue, libpulseaudio}:
 
 stdenv.mkDerivation rec {
   name = "cmus-${version}";
@@ -12,7 +12,7 @@ stdenv.mkDerivation rec {
 
   configurePhase = "./configure prefix=$out";
 
-  buildInputs = [ ncurses pkgconfig alsaLib flac libmad ffmpeg libvorbis libmpc mp4v2 libcue pulseaudio ];
+  buildInputs = [ ncurses pkgconfig alsaLib flac libmad ffmpeg libvorbis libmpc mp4v2 libcue libpulseaudio ];
 
   meta = {
     description = "Small, fast and powerful console music player for Linux and *BSD";
diff --git a/pkgs/applications/audio/csound/default.nix b/pkgs/applications/audio/csound/default.nix
index 64f3f3586a36..693d8e2a6e50 100644
--- a/pkgs/applications/audio/csound/default.nix
+++ b/pkgs/applications/audio/csound/default.nix
@@ -1,6 +1,6 @@
 { stdenv, fetchurl, cmake, libsndfile, flex, bison
 , alsaLib ? null
-, pulseaudio ? null
+, libpulseaudio ? null
 , tcltk ? null
 
 # maybe csound can be compiled with support for those, see configure output
@@ -21,7 +21,7 @@ stdenv.mkDerivation {
     sha256 = "0w6ij57dbfjljpf05bb9r91jphwaq1v63rh0713vl2n11d73dy7m";
   };
 
-  buildInputs = [ cmake libsndfile flex bison alsaLib pulseaudio tcltk ];
+  buildInputs = [ cmake libsndfile flex bison alsaLib libpulseaudio tcltk ];
 
   meta = {
     description = "sound design, audio synthesis, and signal processing system, providing facilities for music composition and performance on all major operating systems and platforms";
diff --git a/pkgs/applications/audio/deadbeef/default.nix b/pkgs/applications/audio/deadbeef/default.nix
index ca8ce453e63d..9dd4db684326 100644
--- a/pkgs/applications/audio/deadbeef/default.nix
+++ b/pkgs/applications/audio/deadbeef/default.nix
@@ -18,7 +18,7 @@
 , osdSupport ? true, dbus ? null
 # output plugins
 , alsaSupport ? true, alsaLib ? null
-, pulseSupport ? true, pulseaudio ? null
+, pulseSupport ? true, libpulseaudio ? null
 # effect plugins
 , resamplerSupport ? true, libsamplerate ? null
 , overloadSupport ? true, zlib ? null
@@ -41,7 +41,7 @@ assert artworkSupport -> imlib2 != null;
 assert hotkeysSupport -> libX11 != null;
 assert osdSupport -> dbus != null;
 assert alsaSupport -> alsaLib != null;
-assert pulseSupport -> pulseaudio != null;
+assert pulseSupport -> libpulseaudio != null;
 assert resamplerSupport -> libsamplerate != null;
 assert overloadSupport -> zlib != null;
 assert wavpackSupport -> wavpack != null;
@@ -70,7 +70,7 @@ stdenv.mkDerivation rec {
     ++ optional hotkeysSupport libX11
     ++ optional osdSupport dbus
     ++ optional alsaSupport alsaLib
-    ++ optional pulseSupport pulseaudio
+    ++ optional pulseSupport libpulseaudio
     ++ optional resamplerSupport libsamplerate
     ++ optional overloadSupport zlib
     ++ optional wavpackSupport wavpack
diff --git a/pkgs/applications/audio/ekho/default.nix b/pkgs/applications/audio/ekho/default.nix
index dd9b830be841..78383eec9539 100644
--- a/pkgs/applications/audio/ekho/default.nix
+++ b/pkgs/applications/audio/ekho/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, pkgconfig
-, libsndfile, pulseaudio
+, libsndfile, libpulseaudio
 }:
 
 let
@@ -35,5 +35,5 @@ in stdenv.mkDerivation rec {
 
   nativeBuildInputs = [ pkgconfig ];
 
-  buildInputs = [ libsndfile pulseaudio ];
+  buildInputs = [ libsndfile libpulseaudio ];
 }
diff --git a/pkgs/applications/audio/fldigi/default.nix b/pkgs/applications/audio/fldigi/default.nix
index 5a4793a09c19..8e80992d7cad 100644
--- a/pkgs/applications/audio/fldigi/default.nix
+++ b/pkgs/applications/audio/fldigi/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, hamlib, fltk13, libjpeg, libpng, portaudio, libsndfile,
-  libsamplerate, pulseaudio, libXinerama, gettext, pkgconfig, alsaLib }:
+  libsamplerate, libpulseaudio, libXinerama, gettext, pkgconfig, alsaLib }:
 
 stdenv.mkDerivation rec {
   version = "3.22.02";
@@ -12,7 +12,7 @@ stdenv.mkDerivation rec {
   };
 
   buildInputs = [ libXinerama gettext hamlib fltk13 libjpeg libpng portaudio
-                  libsndfile libsamplerate pulseaudio pkgconfig alsaLib ];
+                  libsndfile libsamplerate libpulseaudio pkgconfig alsaLib ];
 
   meta = {
     description = "Digital modem program";
diff --git a/pkgs/applications/audio/fluidsynth/default.nix b/pkgs/applications/audio/fluidsynth/default.nix
index 8cba482194e5..339cccfca704 100644
--- a/pkgs/applications/audio/fluidsynth/default.nix
+++ b/pkgs/applications/audio/fluidsynth/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, alsaLib, glib, jack2, libsndfile, pkgconfig
-, pulseaudio }:
+, libpulseaudio }:
 
 stdenv.mkDerivation  rec {
   name = "fluidsynth-${version}";
@@ -21,7 +21,7 @@ stdenv.mkDerivation  rec {
     "-framework CoreAudio";
 
   buildInputs = [ glib libsndfile pkgconfig ]
-    ++ stdenv.lib.optionals (!stdenv.isDarwin) [ alsaLib pulseaudio jack2 ];
+    ++ stdenv.lib.optionals (!stdenv.isDarwin) [ alsaLib libpulseaudio jack2 ];
 
   meta = with stdenv.lib; {
     description = "Real-time software synthesizer based on the SoundFont 2 specifications";
diff --git a/pkgs/applications/audio/lmms/default.nix b/pkgs/applications/audio/lmms/default.nix
index 6d28c038f232..830d42eb91b0 100644
--- a/pkgs/applications/audio/lmms/default.nix
+++ b/pkgs/applications/audio/lmms/default.nix
@@ -1,6 +1,6 @@
 { stdenv, fetchurl, SDL, alsaLib, cmake, fftwSinglePrec, fluidsynth
 , fltk13, jack2, libvorbis , libsamplerate, libsndfile, pkgconfig
-, pulseaudio, qt4, freetype
+, libpulseaudio, qt4, freetype
 }:
 
 stdenv.mkDerivation  rec {
@@ -14,7 +14,7 @@ stdenv.mkDerivation  rec {
 
   buildInputs = [
     SDL alsaLib cmake fftwSinglePrec fltk13 fluidsynth jack2
-    libsamplerate libsndfile libvorbis pkgconfig pulseaudio qt4
+    libsamplerate libsndfile libvorbis pkgconfig libpulseaudio qt4
   ];
 
   enableParallelBuilding = true;
diff --git a/pkgs/applications/audio/mhwaveedit/default.nix b/pkgs/applications/audio/mhwaveedit/default.nix
index a1e81be3cb37..0234a1d3fe5b 100644
--- a/pkgs/applications/audio/mhwaveedit/default.nix
+++ b/pkgs/applications/audio/mhwaveedit/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, SDL , alsaLib, gtk, jack2, ladspaH
-, ladspaPlugins, libsamplerate, libsndfile, pkgconfig, pulseaudio }:
+, ladspaPlugins, libsamplerate, libsndfile, pkgconfig, libpulseaudio }:
 
 stdenv.mkDerivation  rec {
   name = "mhwaveedit-${version}";
@@ -12,7 +12,7 @@ stdenv.mkDerivation  rec {
 
   buildInputs =
    [ SDL alsaLib gtk jack2 ladspaH libsamplerate libsndfile
-     pkgconfig pulseaudio
+     pkgconfig libpulseaudio
    ];
 
   configureFlags = "--with-default-ladspa-path=${ladspaPlugins}/lib/ladspa";
diff --git a/pkgs/applications/audio/minimodem/default.nix b/pkgs/applications/audio/minimodem/default.nix
index 6f2bf8cdb1c7..af4e887d1677 100644
--- a/pkgs/applications/audio/minimodem/default.nix
+++ b/pkgs/applications/audio/minimodem/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, pkgconfig, fftw, fftwSinglePrec, alsaLib, libsndfile, pulseaudio }:
+{ stdenv, fetchurl, pkgconfig, fftw, fftwSinglePrec, alsaLib, libsndfile, linbpulseaudio }:
 
 stdenv.mkDerivation rec {
   version = "0.19";
@@ -10,7 +10,7 @@ stdenv.mkDerivation rec {
     sha256 = "003xyqjq59wcjafrdv1b8w34xsn4nvzz51wwd7mqddajh0g4dz4g";
   };
 
-  buildInputs = [ pkgconfig fftw fftwSinglePrec alsaLib libsndfile pulseaudio ];
+  buildInputs = [ pkgconfig fftw fftwSinglePrec alsaLib libsndfile libpulseaudio ];
 
   meta = {
     description = "General-purpose software audio FSK modem";
diff --git a/pkgs/applications/audio/pamixer/default.nix b/pkgs/applications/audio/pamixer/default.nix
index d665b83340cf..31353cec6a91 100644
--- a/pkgs/applications/audio/pamixer/default.nix
+++ b/pkgs/applications/audio/pamixer/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, boost, pulseaudio }:
+{ stdenv, fetchurl, boost, libpulseaudio }:
 
 stdenv.mkDerivation rec {
 
@@ -10,7 +10,7 @@ stdenv.mkDerivation rec {
     sha256 = "1ad6b46hh02hs1978pgihrm2bnq4z2v0imrfm3wy74xdkr6xjxy4";
   };
 
-  buildInputs = [ boost pulseaudio ];
+  buildInputs = [ boost libpulseaudio ];
 
   installPhase = ''
     mkdir -p $out/bin
diff --git a/pkgs/applications/audio/paprefs/default.nix b/pkgs/applications/audio/paprefs/default.nix
index f05c4068a60b..06b4b44b5963 100644
--- a/pkgs/applications/audio/paprefs/default.nix
+++ b/pkgs/applications/audio/paprefs/default.nix
@@ -1,4 +1,4 @@
-{ fetchurl, stdenv, pkgconfig, pulseaudio, gtkmm, libglademm
+{ fetchurl, stdenv, pkgconfig, libpulseaudio, gtkmm, libglademm
 , dbus_glib, gconfmm, intltool }:
 
 stdenv.mkDerivation rec {
@@ -9,7 +9,7 @@ stdenv.mkDerivation rec {
     sha256 = "1c5b3sb881szavly220q31g7rvpn94wr7ywlk00hqb9zaikml716";
   };
 
-  buildInputs = [ pulseaudio gtkmm libglademm dbus_glib gconfmm ];
+  buildInputs = [ libpulseaudio gtkmm libglademm dbus_glib gconfmm ];
 
   nativeBuildInputs = [ pkgconfig intltool ];
 
diff --git a/pkgs/applications/audio/pavucontrol/default.nix b/pkgs/applications/audio/pavucontrol/default.nix
index 7e392679c712..8db0a94a9904 100644
--- a/pkgs/applications/audio/pavucontrol/default.nix
+++ b/pkgs/applications/audio/pavucontrol/default.nix
@@ -1,4 +1,4 @@
-{ fetchurl, stdenv, pkgconfig, intltool, pulseaudio, gtkmm3
+{ fetchurl, stdenv, pkgconfig, intltool, libpulseaudio, gtkmm3
 , libcanberra_gtk3, makeWrapper, gnome3 }:
 
 stdenv.mkDerivation rec {
@@ -14,7 +14,7 @@ stdenv.mkDerivation rec {
      --prefix XDG_DATA_DIRS : "$XDG_ICON_DIRS"
   '';
 
-  buildInputs = [ pulseaudio gtkmm3 libcanberra_gtk3 makeWrapper
+  buildInputs = [ libpulseaudio gtkmm3 libcanberra_gtk3 makeWrapper
                   gnome3.defaultIconTheme ];
 
   nativeBuildInputs = [ pkgconfig intltool ];
diff --git a/pkgs/applications/audio/projectm/default.nix b/pkgs/applications/audio/projectm/default.nix
index 508b6743cc39..fcfde86f7ee3 100644
--- a/pkgs/applications/audio/projectm/default.nix
+++ b/pkgs/applications/audio/projectm/default.nix
@@ -3,7 +3,7 @@
 , withQt ? true, qt4
 , withLibvisual ? false, libvisual, SDL
 , withJack ? false, jack2
-, withPulseAudio ? true, pulseaudio
+, withPulseAudio ? true, libpulseaudio
 }:
 
 assert withJack       -> withQt;
@@ -46,6 +46,6 @@ stdenv.mkDerivation {
     ++ optional withQt qt4
     ++ optionals withLibvisual [ libvisual SDL ]
     ++ optional withJack jack2
-    ++ optional withPulseAudio pulseaudio
+    ++ optional withPulseAudio libpulseaudio
     ;
 }
diff --git a/pkgs/applications/audio/qmmp/default.nix b/pkgs/applications/audio/qmmp/default.nix
index 1a447be56b4d..1b9323c1a7ba 100644
--- a/pkgs/applications/audio/qmmp/default.nix
+++ b/pkgs/applications/audio/qmmp/default.nix
@@ -5,7 +5,7 @@
 , libmad, taglib, libvorbis, libogg, flac, libmpcdec, libmodplug, libsndfile
 , libcdio, cdparanoia, libcddb, faad2, ffmpeg, wildmidi
 # output plugins
-, alsaLib, pulseaudio
+, alsaLib, libpulseaudio
 # effect plugins
 , libsamplerate
 }:
@@ -44,7 +44,7 @@ stdenv.mkDerivation rec {
       libmad taglib libvorbis libogg flac libmpcdec libmodplug libsndfile
       libcdio cdparanoia libcddb faad2 ffmpeg wildmidi
       # output plugins
-      alsaLib pulseaudio
+      alsaLib libpulseaudio
       # effect plugins
       libsamplerate
     ];
diff --git a/pkgs/applications/audio/sonic-visualiser/default.nix b/pkgs/applications/audio/sonic-visualiser/default.nix
index 104a458d6a06..9cd1a3d03458 100644
--- a/pkgs/applications/audio/sonic-visualiser/default.nix
+++ b/pkgs/applications/audio/sonic-visualiser/default.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl, alsaLib, bzip2, fftw, jack2, libX11, liblo
 , libmad, libogg, librdf, librdf_raptor, librdf_rasqal, libsamplerate
-, libsndfile, pkgconfig, pulseaudio, qt5, redland
+, libsndfile, pkgconfig, libpulseaudio, qt5, redland
 , rubberband, serd, sord, vampSDK
 }:
 
@@ -24,7 +24,7 @@ stdenv.mkDerivation rec {
       # optional
       jack2
       # portaudio
-      pulseaudio
+      libpulseaudio
       libmad
       libogg # ?
       # fishsound
diff --git a/pkgs/applications/misc/gqrx/default.nix b/pkgs/applications/misc/gqrx/default.nix
index 169331ceb733..440d2b790c21 100644
--- a/pkgs/applications/misc/gqrx/default.nix
+++ b/pkgs/applications/misc/gqrx/default.nix
@@ -1,10 +1,10 @@
 { stdenv, fetchurl, qt4, gnuradio, boost, gnuradio-osmosdr
 # drivers (optional):
 , rtl-sdr
-, pulseaudioSupport ? true, pulseaudio
+, pulseaudioSupport ? true, libpulseaudio
 }:
 
-assert pulseaudioSupport -> pulseaudio != null;
+assert pulseaudioSupport -> libpulseaudio != null;
 
 stdenv.mkDerivation rec {
   name = "gqrx-${version}";
@@ -17,7 +17,7 @@ stdenv.mkDerivation rec {
 
   buildInputs = [
     qt4 gnuradio boost gnuradio-osmosdr rtl-sdr
-  ] ++ stdenv.lib.optionals pulseaudioSupport [ pulseaudio ];
+  ] ++ stdenv.lib.optionals pulseaudioSupport [ libpulseaudio ];
 
   configurePhase = ''qmake PREFIX="$out"'';
 
diff --git a/pkgs/applications/networking/browsers/chromium/common.nix b/pkgs/applications/networking/browsers/chromium/common.nix
index 3d85afef8f49..1f6c272aceb2 100644
--- a/pkgs/applications/networking/browsers/chromium/common.nix
+++ b/pkgs/applications/networking/browsers/chromium/common.nix
@@ -26,7 +26,7 @@
 , gnomeKeyringSupport ? false, libgnome_keyring3 ? null
 , proprietaryCodecs ? true
 , cupsSupport ? true
-, pulseSupport ? false, pulseaudio ? null
+, pulseSupport ? false, libpulseaudio ? null
 , hiDPISupport ? false
 
 , source
@@ -118,7 +118,7 @@ let
       ++ optionals gnomeSupport [ gnome.GConf libgcrypt ]
       ++ optional enableSELinux libselinux
       ++ optionals cupsSupport [ libgcrypt cups ]
-      ++ optional pulseSupport pulseaudio;
+      ++ optional pulseSupport libpulseaudio;
 
     # XXX: Wait for https://crbug.com/239107 and https://crbug.com/239181 to
     #      be fixed, then try again to unbundle everything into separate
diff --git a/pkgs/applications/networking/browsers/firefox-bin/default.nix b/pkgs/applications/networking/browsers/firefox-bin/default.nix
index 23726f5c3d18..998ea95e8da6 100644
--- a/pkgs/applications/networking/browsers/firefox-bin/default.nix
+++ b/pkgs/applications/networking/browsers/firefox-bin/default.nix
@@ -31,7 +31,7 @@
 , nss
 , pango
 , heimdal
-, pulseaudio
+, libpulseaudio
 , systemd
 }:
 
@@ -103,7 +103,7 @@ stdenv.mkDerivation {
       nss
       pango
       heimdal
-      pulseaudio
+      libpulseaudio
       systemd
     ] + ":" + stdenv.lib.makeSearchPath "lib64" [
       stdenv.cc.cc
diff --git a/pkgs/applications/networking/browsers/mozilla-plugins/google-talk-plugin/default.nix b/pkgs/applications/networking/browsers/mozilla-plugins/google-talk-plugin/default.nix
index bdccb932e1c3..6fd953636a83 100644
--- a/pkgs/applications/networking/browsers/mozilla-plugins/google-talk-plugin/default.nix
+++ b/pkgs/applications/networking/browsers/mozilla-plugins/google-talk-plugin/default.nix
@@ -1,6 +1,6 @@
 { stdenv, fetchurl, rpm, cpio, mesa, xorg, cairo
 , libpng, gtk, glib, gdk_pixbuf, fontconfig, freetype, curl
-, dbus_glib, alsaLib, pulseaudio, udev, pango
+, dbus_glib, alsaLib, libpulseaudio, udev, pango
 }:
 
 with stdenv.lib;
@@ -34,7 +34,7 @@ let
       xorg.libXrandr
       stdenv.cc.cc
       alsaLib
-      pulseaudio
+      libpulseaudio
       dbus_glib
       udev
       curl
diff --git a/pkgs/applications/networking/instant-messengers/oneteam/default.nix b/pkgs/applications/networking/instant-messengers/oneteam/default.nix
index 14d01de32458..2ab0930842bc 100644
--- a/pkgs/applications/networking/instant-messengers/oneteam/default.nix
+++ b/pkgs/applications/networking/instant-messengers/oneteam/default.nix
@@ -1,6 +1,6 @@
 x@{builderDefsPackage
   , fetchgit, perl, xulrunner, cmake, perlPackages, zip, unzip, pkgconfig
-  , pulseaudio, glib, gtk, pixman, nspr, nss, libXScrnSaver, scrnsaverproto
+  , libpulseaudio, glib, gtk, pixman, nspr, nss, libXScrnSaver, scrnsaverproto
   , ...}:
 builderDefsPackage
 (a :  
diff --git a/pkgs/applications/networking/instant-messengers/sflphone/default.nix b/pkgs/applications/networking/instant-messengers/sflphone/default.nix
index fb14782ef9f6..8b259c90fe50 100644
--- a/pkgs/applications/networking/instant-messengers/sflphone/default.nix
+++ b/pkgs/applications/networking/instant-messengers/sflphone/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, libyaml, alsaLib, openssl, libuuid, pkgconfig, pulseaudio, libsamplerate
+{ stdenv, fetchurl, libyaml, alsaLib, openssl, libuuid, pkgconfig, libpulseaudio, libsamplerate
 , commoncpp2, ccrtp, libzrtpcpp, dbus, dbus_cplusplus, expat, pcre, gsm, speex, ilbc, libopus
 , autoconf, automake, libtool, gettext, perl
 , cmake, qt4
@@ -43,7 +43,7 @@ rec {
     configureFlags = "--with-expat --with-expat-inc=${expat}/include " +
       "--with-expat-lib=-lexpat --with-opus ";
 
-    buildInputs = [ libyaml alsaLib openssl libuuid pkgconfig pulseaudio libsamplerate 
+    buildInputs = [ libyaml alsaLib openssl libuuid pkgconfig libpulseaudio libsamplerate
       commoncpp2 ccrtp libzrtpcpp dbus dbus_cplusplus expat pcre gsm speex ilbc libopus
       autoconf automake libtool gettext perl ];
   };
diff --git a/pkgs/applications/networking/instant-messengers/skype/default.nix b/pkgs/applications/networking/instant-messengers/skype/default.nix
index 218e7303807b..1e84e015bc14 100644
--- a/pkgs/applications/networking/instant-messengers/skype/default.nix
+++ b/pkgs/applications/networking/instant-messengers/skype/default.nix
@@ -1,6 +1,6 @@
 { stdenv, fetchurl, libXv, libXi, libXrender, libXrandr, zlib, glib
 , libXext, libX11, libXScrnSaver, libSM, qt4, libICE, freetype, fontconfig
-, pulseaudio, lib, ... }:
+, libpulseaudio, lib, ... }:
 
 assert stdenv.system == "i686-linux";
 
@@ -25,7 +25,7 @@ stdenv.mkDerivation rec {
     libXi
     libXrender
     libXrandr
-    pulseaudio
+    libpulseaudio
     freetype
     fontconfig
     zlib
diff --git a/pkgs/applications/networking/instant-messengers/teamspeak/client.nix b/pkgs/applications/networking/instant-messengers/teamspeak/client.nix
index df4f7054ad3b..51707d2dca65 100644
--- a/pkgs/applications/networking/instant-messengers/teamspeak/client.nix
+++ b/pkgs/applications/networking/instant-messengers/teamspeak/client.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, makeWrapper, zlib, glib, libpng, freetype, xorg
-, fontconfig, xlibs, qt5, xkeyboard_config, alsaLib, pulseaudio ? null
+, fontconfig, xlibs, qt5, xkeyboard_config, alsaLib, libpulseaudio ? null
 , libredirect, quazip, less, which
 }:
 
@@ -12,7 +12,7 @@ let
   deps =
     [ zlib glib libpng freetype xorg.libSM xorg.libICE xorg.libXrender
       xorg.libXrandr xorg.libXfixes xorg.libXcursor xorg.libXinerama
-      xlibs.libxcb fontconfig xorg.libXext xorg.libX11 alsaLib qt5.base pulseaudio
+      xlibs.libxcb fontconfig xorg.libXext xorg.libX11 alsaLib qt5.base libpulseaudio
     ];
 
 in
diff --git a/pkgs/applications/networking/remote/freerdp/default.nix b/pkgs/applications/networking/remote/freerdp/default.nix
index 092e6f53e493..f773cf6755e2 100644
--- a/pkgs/applications/networking/remote/freerdp/default.nix
+++ b/pkgs/applications/networking/remote/freerdp/default.nix
@@ -15,7 +15,7 @@
 #, xmlto, docbook_xml_dtd_412, docbook_xml_xslt
 , libXinerama
 , libXv
-, pulseaudioSupport ? true, pulseaudio
+, pulseaudioSupport ? true, libpulseaudio
 }:
 
 assert printerSupport -> cups != null;
diff --git a/pkgs/applications/networking/remote/freerdp/unstable.nix b/pkgs/applications/networking/remote/freerdp/unstable.nix
index e66f78f2602d..cc6ec9bd2315 100644
--- a/pkgs/applications/networking/remote/freerdp/unstable.nix
+++ b/pkgs/applications/networking/remote/freerdp/unstable.nix
@@ -1,7 +1,7 @@
 { stdenv, fetchFromGitHub, cmake, pkgconfig, openssl, zlib, libX11, libXcursor
 , libXdamage, libXext, glib, alsaLib, ffmpeg, libxkbfile, libXinerama, libXv
 , substituteAll
-, pulseaudio ? null, cups ? null, pcsclite ? null
+, libpulseaudio ? null, cups ? null, pcsclite ? null
 , buildServer ? true, optimize ? true
 }:
 
@@ -24,7 +24,7 @@ stdenv.mkDerivation rec {
 
   buildInputs = [
     cmake pkgconfig openssl zlib libX11 libXcursor libXdamage libXext glib
-    alsaLib ffmpeg libxkbfile libXinerama libXv cups pulseaudio pcsclite
+    alsaLib ffmpeg libxkbfile libXinerama libXv cups libpulseaudio pcsclite
   ];
 
   doCheck = false;
@@ -32,7 +32,7 @@ stdenv.mkDerivation rec {
   cmakeFlags = [
     "-DCMAKE_INSTALL_LIBDIR=lib"
     "-DWITH_CUNIT=OFF"
-  ] ++ stdenv.lib.optional (pulseaudio != null) "-DWITH_PULSE=ON"
+  ] ++ stdenv.lib.optional (libpulseaudio != null) "-DWITH_PULSE=ON"
     ++ stdenv.lib.optional (cups != null) "-DWITH_CUPS=ON"
     ++ stdenv.lib.optional (pcsclite != null) "-DWITH_PCSC=ON"
     ++ stdenv.lib.optional buildServer "-DWITH_SERVER=ON"
diff --git a/pkgs/applications/office/zotero/firefox-bin/default.nix b/pkgs/applications/office/zotero/firefox-bin/default.nix
index 0018f00a3662..52751908fa71 100644
--- a/pkgs/applications/office/zotero/firefox-bin/default.nix
+++ b/pkgs/applications/office/zotero/firefox-bin/default.nix
@@ -31,7 +31,7 @@
 , nss
 , pango
 , heimdal
-, pulseaudio
+, libpulseaudio
 , systemd
 }:
 
@@ -103,7 +103,7 @@ stdenv.mkDerivation {
       nss
       pango
       heimdal
-      pulseaudio
+      libpulseaudio
       systemd
     ] + ":" + stdenv.lib.makeSearchPath "lib64" [
       stdenv.cc.cc
diff --git a/pkgs/applications/video/aegisub/default.nix b/pkgs/applications/video/aegisub/default.nix
index e7cc9b78195f..a5c14d0888ff 100644
--- a/pkgs/applications/video/aegisub/default.nix
+++ b/pkgs/applications/video/aegisub/default.nix
@@ -9,14 +9,14 @@
 , automationSupport ? true, lua ? null
 , openalSupport ? false, openal ? null
 , alsaSupport ? true, alsaLib ? null
-, pulseaudioSupport ? true, pulseaudio ? null
+, pulseaudioSupport ? true, libpulseaudio ? null
 , portaudioSupport ? false, portaudio ? null }:
 
 assert spellcheckSupport -> (hunspell != null);
 assert automationSupport -> (lua != null);
 assert openalSupport -> (openal != null);
 assert alsaSupport -> (alsaLib != null);
-assert pulseaudioSupport -> (pulseaudio != null);
+assert pulseaudioSupport -> (libpulseaudio != null);
 assert portaudioSupport -> (portaudio != null);
 
 with stdenv.lib;
@@ -37,7 +37,7 @@ stdenv.mkDerivation rec {
     ++ optional automationSupport lua
     ++ optional openalSupport openal
     ++ optional alsaSupport alsaLib
-    ++ optional pulseaudioSupport pulseaudio
+    ++ optional pulseaudioSupport libpulseaudio
     ++ optional portaudioSupport portaudio
     ;
 
diff --git a/pkgs/applications/video/bomi/default.nix b/pkgs/applications/video/bomi/default.nix
index be0517b6376b..2f0c3070921a 100644
--- a/pkgs/applications/video/bomi/default.nix
+++ b/pkgs/applications/video/bomi/default.nix
@@ -13,7 +13,7 @@
 , libbluray
 , jackSupport ? false, jack ? null
 , portaudioSupport ? false, portaudio ? null
-, pulseSupport ? true, pulseaudio ? null
+, pulseSupport ? true, libpulseaudio ? null
 , cddaSupport ? false, libcdda ? null
 , youtubeSupport ? true, youtube-dl ? null
 }:
@@ -22,7 +22,7 @@ with stdenv.lib;
 
 assert jackSupport -> jack != null;
 assert portaudioSupport -> portaudio != null;
-assert pulseSupport -> pulseaudio != null;
+assert pulseSupport -> libpulseaudio != null;
 assert cddaSupport -> libcdda != null;
 assert youtubeSupport -> youtube-dl != null;
 
@@ -63,7 +63,7 @@ stdenv.mkDerivation rec {
                 ]
                 ++ optional jackSupport jack
                 ++ optional portaudioSupport portaudio
-                ++ optional pulseSupport pulseaudio
+                ++ optional pulseSupport libpulseaudio
                 ++ optional cddaSupport libcdda
                 ;
 
diff --git a/pkgs/applications/video/kodi/default.nix b/pkgs/applications/video/kodi/default.nix
index 0b18705e6fbe..dafa381d9eca 100644
--- a/pkgs/applications/video/kodi/default.nix
+++ b/pkgs/applications/video/kodi/default.nix
@@ -23,7 +23,7 @@
 # TODO: would be nice to have nfsSupport (needs libnfs library)
 # TODO: librtmp
 , libvdpau ? null, vdpauSupport ? true
-, pulseaudio ? null, pulseSupport ? true
+, libpulseaudio ? null, pulseSupport ? true
 , libcec ? null, cecSupport ? true
 }:
 
@@ -32,7 +32,7 @@ assert udevSupport  -> udev != null;
 assert usbSupport   -> libusb != null && ! udevSupport; # libusb won't be used if udev is avaliable
 assert sambaSupport -> samba != null;
 assert vdpauSupport -> libvdpau != null;
-assert pulseSupport -> pulseaudio != null;
+assert pulseSupport -> libpulseaudio != null;
 assert cecSupport   -> libcec != null;
 
 let
@@ -74,7 +74,7 @@ in stdenv.mkDerivation rec {
     ++ lib.optional usbSupport libusb
     ++ lib.optional sambaSupport samba
     ++ lib.optional vdpauSupport libvdpau
-    ++ lib.optional pulseSupport pulseaudio
+    ++ lib.optional pulseSupport libpulseaudio
     ++ lib.optional cecSupport libcec;
 
     dontUseCmakeConfigure = true;
diff --git a/pkgs/applications/video/mplayer/default.nix b/pkgs/applications/video/mplayer/default.nix
index ac106431240d..57f8289a1f92 100644
--- a/pkgs/applications/video/mplayer/default.nix
+++ b/pkgs/applications/video/mplayer/default.nix
@@ -18,7 +18,7 @@
 , theoraSupport ? true, libtheora ? null
 , x264Support ? false, x264 ? null
 , jackaudioSupport ? false, jack2 ? null
-, pulseSupport ? false, pulseaudio ? null
+, pulseSupport ? false, libpulseaudio ? null
 , bs2bSupport ? false, libbs2b ? null
 # For screenshots
 , libpngSupport ? true, libpng ? null
@@ -45,7 +45,7 @@ assert speexSupport -> speex != null;
 assert theoraSupport -> libtheora != null;
 assert x264Support -> x264 != null;
 assert jackaudioSupport -> jack2 != null;
-assert pulseSupport -> pulseaudio != null;
+assert pulseSupport -> libpulseaudio != null;
 assert bs2bSupport -> libbs2b != null;
 assert libpngSupport -> libpng != null;
 assert libjpegSupport -> libjpeg != null;
@@ -119,7 +119,7 @@ stdenv.mkDerivation rec {
     ++ optional jackaudioSupport jack2
     ++ optionals amrSupport [ amrnb amrwb ]
     ++ optional x264Support x264
-    ++ optional pulseSupport pulseaudio
+    ++ optional pulseSupport libpulseaudio
     ++ optional screenSaverSupport libXScrnSaver
     ++ optional lameSupport lame
     ++ optional vdpauSupport libvdpau
diff --git a/pkgs/applications/video/mpv/default.nix b/pkgs/applications/video/mpv/default.nix
index 6bb7072a4a31..03cb5154f853 100644
--- a/pkgs/applications/video/mpv/default.nix
+++ b/pkgs/applications/video/mpv/default.nix
@@ -13,7 +13,7 @@
 , speexSupport ? true, speex ? null
 , theoraSupport ? true, libtheora ? null
 , jackaudioSupport ? true, jack2 ? null
-, pulseSupport ? true, pulseaudio ? null
+, pulseSupport ? true, libpulseaudio ? null
 , bs2bSupport ? true, libbs2b ? null
 # For screenshots
 , libpngSupport ? true, libpng ? null
@@ -40,7 +40,7 @@ assert bluraySupport -> libbluray != null;
 assert speexSupport -> speex != null;
 assert theoraSupport -> libtheora != null;
 assert jackaudioSupport -> jack2 != null;
-assert pulseSupport -> pulseaudio != null;
+assert pulseSupport -> libpulseaudio != null;
 assert bs2bSupport -> libbs2b != null;
 assert libpngSupport -> libpng != null;
 assert youtubeSupport -> youtube-dl != null;
@@ -98,7 +98,7 @@ stdenv.mkDerivation rec {
     ++ optionals dvdnavSupport [ libdvdnav libdvdnav.libdvdread ]
     ++ optional bluraySupport libbluray
     ++ optional jackaudioSupport jack2
-    ++ optional pulseSupport pulseaudio
+    ++ optional pulseSupport libpulseaudio
     ++ optional screenSaverSupport libXScrnSaver
     ++ optional vdpauSupport libvdpau
     ++ optional speexSupport speex
diff --git a/pkgs/applications/video/mythtv/default.nix b/pkgs/applications/video/mythtv/default.nix
index 2bc635d510eb..cd157a473e62 100644
--- a/pkgs/applications/video/mythtv/default.nix
+++ b/pkgs/applications/video/mythtv/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, which, qt4, x11, pulseaudio, fftwSinglePrec
+{ stdenv, fetchurl, which, qt4, x11, libpulseaudio, fftwSinglePrec
 , lame, zlib, mesa, alsaLib, freetype, perl, pkgconfig
 , libX11, libXv, libXrandr, libXvMC, libXinerama, libXxf86vm, libXmu
 , yasm, libuuid, taglib, libtool, autoconf, automake, file
@@ -16,7 +16,7 @@ stdenv.mkDerivation rec {
   sourceRoot = "${name}/mythtv";
 
   buildInputs = [
-    freetype qt4 lame zlib x11 mesa perl alsaLib pulseaudio fftwSinglePrec
+    freetype qt4 lame zlib x11 mesa perl alsaLib libpulseaudio fftwSinglePrec
     libX11 libXv libXrandr libXvMC libXmu libXinerama libXxf86vm libXmu
     libuuid taglib
   ];
diff --git a/pkgs/applications/video/simplescreenrecorder/default.nix b/pkgs/applications/video/simplescreenrecorder/default.nix
index 7320a7f6d74d..453829bc580e 100644
--- a/pkgs/applications/video/simplescreenrecorder/default.nix
+++ b/pkgs/applications/video/simplescreenrecorder/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, alsaLib, ffmpeg, jack2, libX11, libXext
-, libXfixes, mesa, pkgconfig, pulseaudio, qt4
+, libXfixes, mesa, pkgconfig, libpulseaudio, qt4
 }:
 
 stdenv.mkDerivation rec {
@@ -13,7 +13,7 @@ stdenv.mkDerivation rec {
 
   buildInputs = [
     alsaLib ffmpeg jack2 libX11 libXext libXfixes mesa pkgconfig
-    pulseaudio qt4
+    libpulseaudio qt4
   ];
 
   meta = with stdenv.lib; {
diff --git a/pkgs/applications/video/vlc/default.nix b/pkgs/applications/video/vlc/default.nix
index a404ba0d1a8a..85fc6f6b6ba7 100644
--- a/pkgs/applications/video/vlc/default.nix
+++ b/pkgs/applications/video/vlc/default.nix
@@ -2,7 +2,7 @@
 , zlib, a52dec, libmad, faad2, ffmpeg, alsaLib
 , pkgconfig, dbus, fribidi, freefont_ttf, libebml, libmatroska
 , libvorbis, libtheora, speex, lua5, libgcrypt, libupnp
-, libcaca, pulseaudio, flac, schroedinger, libxml2, librsvg
+, libcaca, libpulseaudio, flac, schroedinger, libxml2, librsvg
 , mpeg2dec, udev, gnutls, avahi, libcddb, jack2, SDL, SDL_image
 , libmtp, unzip, taglib, libkate, libtiger, libv4l, samba, liboggz
 , libass, libva, libdvbpsi, libdc1394, libraw1394, libopus
@@ -28,7 +28,7 @@ stdenv.mkDerivation rec {
   buildInputs =
     [ xz bzip2 perl zlib a52dec libmad faad2 ffmpeg alsaLib libdvdnav libdvdnav.libdvdread
       libbluray dbus fribidi libvorbis libtheora speex lua5 libgcrypt
-      libupnp libcaca pulseaudio flac schroedinger libxml2 librsvg mpeg2dec
+      libupnp libcaca libpulseaudio flac schroedinger libxml2 librsvg mpeg2dec
       udev gnutls avahi libcddb jack2 SDL SDL_image libmtp unzip taglib
       libkate libtiger libv4l samba liboggz libass libdvbpsi libva
       xlibs.xlibs xlibs.libXv xlibs.libXvMC xlibs.libXpm xlibs.xcbutilkeysyms
diff --git a/pkgs/applications/virtualization/qemu/default.nix b/pkgs/applications/virtualization/qemu/default.nix
index bf722431d910..0d57a8d9f575 100644
--- a/pkgs/applications/virtualization/qemu/default.nix
+++ b/pkgs/applications/virtualization/qemu/default.nix
@@ -13,16 +13,6 @@
 # Audio libraries
 , libpulseaudio ? null, alsaLib ? null
 
-#, pixman ? null
-#, python, zlib, glib, ncurses, perl
-#, attr, libcap, vde2, alsaLib, texinfo, libuuid, flex, bison, lzo, snappy
-#, libseccomp, libaio, libcap_ng, gnutls
-#, makeWrapper
-#, pulseSupport ? true, pulseaudio
-#, sdlSupport ? true, SDL
-#, vncSupport ? true, libjpeg, libpng
-#, spiceSupport ? true, spice, spice_protocol, usbredir
-
 # Extra options
 , type ? ""
 }:
diff --git a/pkgs/applications/virtualization/virtualbox/default.nix b/pkgs/applications/virtualization/virtualbox/default.nix
index 158d99f64880..31a148300346 100644
--- a/pkgs/applications/virtualization/virtualbox/default.nix
+++ b/pkgs/applications/virtualization/virtualbox/default.nix
@@ -5,7 +5,7 @@
 , javaBindings ? false, jdk ? null
 , pythonBindings ? false, python ? null
 , enableExtensionPack ? false, requireFile ? null, patchelf ? null, fakeroot ? null
-, pulseSupport ? false, pulseaudio ? null
+, pulseSupport ? false, libpulseaudio ? null
 , enableHardening ? false
 }:
 
@@ -69,7 +69,7 @@ in stdenv.mkDerivation {
       pkgconfig which libXmu nukeReferences ]
     ++ optional javaBindings jdk
     ++ optional pythonBindings python
-    ++ optional pulseSupport pulseaudio;
+    ++ optional pulseSupport libpulseaudio;
 
   prePatch = ''
     set -x