about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/audacity/default.nix4
-rw-r--r--pkgs/applications/audio/ladspa-plugins/default.nix4
-rw-r--r--pkgs/applications/audio/ladspa-plugins/ladspah.nix4
-rw-r--r--pkgs/applications/audio/snd/default.nix93
-rw-r--r--pkgs/applications/graphics/gocr/0.44.nix4
-rw-r--r--pkgs/applications/graphics/xscreensaver/5.05.nix4
-rw-r--r--pkgs/applications/networking/p2p/ldcpp/1.0.1.nix6
-rw-r--r--pkgs/applications/virtualization/qemu/linux-img/0.2.nix4
-rw-r--r--pkgs/applications/window-managers/compiz/0.6.2.nix4
-rw-r--r--pkgs/applications/window-managers/compiz/0.7.4.nix4
-rw-r--r--pkgs/applications/window-managers/fbpanel/4.12.nix4
11 files changed, 72 insertions, 63 deletions
diff --git a/pkgs/applications/audio/audacity/default.nix b/pkgs/applications/audio/audacity/default.nix
index 950a8e93907c..644996065cd6 100644
--- a/pkgs/applications/audio/audacity/default.nix
+++ b/pkgs/applications/audio/audacity/default.nix
@@ -1,5 +1,5 @@
 args: with args;
-	let localDefs = builderDefs { 
+	let localDefs = builderDefs.meta.function { 
 	  src = 
 		fetchurl {
 			url = mirror://sourceforge/audacity/audacity-src-1.3.3.tar.gz;
@@ -8,7 +8,7 @@ args: with args;
 
   	buildInputs =[(wxGTK null) libogg libvorbis libsndfile libmad pkgconfig gtk 
 		gettext glib];
-	} null;
+	};
 	in with localDefs;
 let 
 	postInstall = FullDepEntry ("
diff --git a/pkgs/applications/audio/ladspa-plugins/default.nix b/pkgs/applications/audio/ladspa-plugins/default.nix
index 0c24a0fda454..230ee1d7de26 100644
--- a/pkgs/applications/audio/ladspa-plugins/default.nix
+++ b/pkgs/applications/audio/ladspa-plugins/default.nix
@@ -1,5 +1,5 @@
 args: with args;
-	let localDefs = builderDefs {
+	let localDefs = builderDefs.meta.function {
 		src = 
 		fetchurl {
 			url = http://plugin.org.uk/releases/0.4.15/swh-plugins-0.4.15.tar.gz;
@@ -7,7 +7,7 @@ args: with args;
 		};
 		buildInputs = [fftw ladspaH pkgconfig];
 		configureFlags = [];
-	} null;
+	};
 	in with localDefs;
 let
 	postInstall = FullDepEntry ("
diff --git a/pkgs/applications/audio/ladspa-plugins/ladspah.nix b/pkgs/applications/audio/ladspa-plugins/ladspah.nix
index 82595b4163e9..60ee6fbf4571 100644
--- a/pkgs/applications/audio/ladspa-plugins/ladspah.nix
+++ b/pkgs/applications/audio/ladspa-plugins/ladspah.nix
@@ -6,10 +6,10 @@ let
 		sha256 = "1b908csn85ng9sz5s5d1mqk711cmawain2z8px2ajngihdrynb67";
 	};
 in
-	let localDefs = builderDefs {
+	let localDefs = builderDefs.meta.function {
 		buildInputs = [];
 		inherit src;
-	} null;
+	};
 	in with localDefs;
 let
 	copyFile = FullDepEntry ("
diff --git a/pkgs/applications/audio/snd/default.nix b/pkgs/applications/audio/snd/default.nix
index 0a8bb95173f3..a8eb2de8e1a7 100644
--- a/pkgs/applications/audio/snd/default.nix
+++ b/pkgs/applications/audio/snd/default.nix
@@ -1,51 +1,60 @@
-args : with args;
-	let localDefs = builderDefs {
-		src = 
-	fetchurl {
-		url = http://downloads.sourceforge.net/snd/snd-9.4.tar.gz;
-		sha256 = "0zqgfnkvkqxby1k74mwba1r4pb520glcsz5jjmpzm9m41nqnghmm";
-	};
+args : 
+let 
+  lib = args.lib;
+  fetchurl = args.fetchurl;
+  FullDepEntry = args.FullDepEntry;
 
-		buildInputs = [gtk glib pkgconfig libXpm gmp gettext libX11 fftw]
-			++ (lib.optional (args ? ruby) args.ruby)
-			++ (lib.optional (args ? mesa) args.mesa)
-			++ (lib.optional (args ? guile) args.guile)
-			++ (lib.optional (args ? libtool) args.libtool)
-			++ (lib.optional (args ? sndlib) args.sndlib)
-			++ (lib.optional (args ? alsaLib) args.alsaLib)
-			++ (lib.optional (args ? jackaudio) args.jackaudio)
-			;
-		configureFlags = ["--with-gtk" "--with-xpm"]
-			++ (lib.optional (args ? ruby)   "--with-ruby" )
-			++ (lib.optional (args ? mesa)   "--with-gl"   )
-			++ (lib.optional (args ? guile)  "--with-guile")
-			++ (lib.optional (args ? sndlib) "--with-midi" )
-			++ (lib.optional (args ? alsaLib)  "--with-alsa")
-			++ (lib.optional (args ? jackaudio) "--with-jack" )
-                        ++ [ "--with-fftw" "--htmldir=$out/share/snd/html" "--with-doc-dir=$out/share/snd/html" ]
-			;
-	} null; /* null is a terminator for sumArgs */
-	in with localDefs;
-	let makeDocsWork = FullDepEntry ''
+  version = lib.getAttr ["version"] "9.4" args; 
+  buildInputs = with args; [gtk glib pkgconfig 
+     libXpm gmp gettext libX11 fftw]
+      ++ (lib.optional (args ? ruby) args.ruby)
+      ++ (lib.optional (args ? mesa) args.mesa)
+      ++ (lib.optional (args ? guile) args.guile)
+      ++ (lib.optional (args ? libtool) args.libtool)
+      ++ (lib.optional (args ? sndlib) args.sndlib)
+      ++ (lib.optional (args ? alsaLib) args.alsaLib)
+      ++ (lib.optional (args ? jackaudio) args.jackaudio)
+      ;
+  configureFlags = ["--with-gtk" "--with-xpm"]
+    ++ (lib.optional (args ? ruby)   "--with-ruby" )
+    ++ (lib.optional (args ? mesa)   "--with-gl"   )
+    ++ (lib.optional (args ? guile)  "--with-guile")
+    ++ (lib.optional (args ? sndlib) "--with-midi" )
+    ++ (lib.optional (args ? alsaLib)  "--with-alsa")
+    ++ (lib.optional (args ? jackaudio) "--with-jack" )
+    ++ [ "--with-fftw" "--htmldir=$out/share/snd/html" "--with-doc-dir=$out/share/snd/html" ]
+    ;
+in
+rec {
+  src = fetchurl {
+    url = "http://downloads.sourceforge.net/snd/snd-${version}.tar.gz";
+    sha256 = "0zqgfnkvkqxby1k74mwba1r4pb520glcsz5jjmpzm9m41nqnghmm";
+  };
+
+  inherit buildInputs;
+  configureFlags = [];
+
+  /* doConfigure should be specified separately */
+  phaseNames = ["doConfigure" "preBuild" "makeDocsWork" 
+    "doMakeInstall" "doForceShare"];
+
+  makeDocsWork = FullDepEntry ''
                 # hackish way to make html docs work
                 h="$out/share/snd/html"; ensureDir "$h"; cp *.html "$h"
                 patch -p1 < ${./doc.patch}
                 sed "s@HTML-DIR@$h@" -i index.scm snd-help.c
-            '' [defEnsureDir];
+            '' ["defEnsureDir"];
 
-            preBuild = FullDepEntry (''
+  preBuild = FullDepEntry (''
 		cp config.log /tmp/snd-config.log
-		export NIX_LDFLAGS="$NIX_LDFLAGS -L${libX11}/lib -lX11"
+		export NIX_LDFLAGS="$NIX_LDFLAGS -L${args.libX11}/lib -lX11"
                 
-            '') [minInit doUnpack makeDocsWork];
-in
-stdenv.mkDerivation rec {
-	name = "Snd-9.4";
-	builder = writeScript (name + "-builder")
-		(textClosure localDefs [doConfigure preBuild makeDocsWork doMakeInstall doForceShare  ]);
-	meta = {
-		description = "Snd sound editor.";
-                homepage = http://ccrma.stanford.edu/software/snd;
-		inherit src;
-	};
+            '') ["minInit" "doUnpack" "makeDocsWork"];
+
+  name = "Snd-" + version;
+  meta = {
+    description = "Snd sound editor.";
+    homepage = http://ccrma.stanford.edu/software/snd;
+    inherit src;
+  };
 }
diff --git a/pkgs/applications/graphics/gocr/0.44.nix b/pkgs/applications/graphics/gocr/0.44.nix
index 544c3b238d01..0a3c3869a1c7 100644
--- a/pkgs/applications/graphics/gocr/0.44.nix
+++ b/pkgs/applications/graphics/gocr/0.44.nix
@@ -1,5 +1,5 @@
 args : with args;
-	let localDefs = builderDefs {
+	let localDefs = builderDefs.meta.function {
 		src = /* put a fetchurl here */
 fetchurl {
 		url = http://prdownloads.sourceforge.net/jocr/gocr-0.44.tar.gz;
@@ -8,7 +8,7 @@ fetchurl {
 
 		buildInputs = [];
 		configureFlags = [];
-	} null; /* null is a terminator for sumArgs */
+	};
 	in with localDefs;
 stdenv.mkDerivation rec {
 	name = "gocr";
diff --git a/pkgs/applications/graphics/xscreensaver/5.05.nix b/pkgs/applications/graphics/xscreensaver/5.05.nix
index 9bfc3bfff7e4..2410f6938773 100644
--- a/pkgs/applications/graphics/xscreensaver/5.05.nix
+++ b/pkgs/applications/graphics/xscreensaver/5.05.nix
@@ -1,4 +1,4 @@
-args : with args; let localDefs = builderDefs (args // {
+args : with args; let localDefs = builderDefs.meta.function (args // {
 		src = /* put a fetchurl here */
 		fetchurl {
 		    url = http://www.jwz.org/xscreensaver/xscreensaver-5.05.tar.gz;
@@ -19,7 +19,7 @@ args : with args; let localDefs = builderDefs (args // {
 			"true" (" --with-x-app-defaults=\$out/share/xscreensaver/app-defaults "+
 				" --with-hackdir=\$out/share/xscreensaver-hacks ")
 		];
-	}) null; /* null is a terminator for sumArgs */
+	});
 	in with localDefs;
 let 
 	preConfigure = FullDepEntry ("
diff --git a/pkgs/applications/networking/p2p/ldcpp/1.0.1.nix b/pkgs/applications/networking/p2p/ldcpp/1.0.1.nix
index ea1f6b1b84b2..00626377e7c4 100644
--- a/pkgs/applications/networking/p2p/ldcpp/1.0.1.nix
+++ b/pkgs/applications/networking/p2p/ldcpp/1.0.1.nix
@@ -1,5 +1,5 @@
-args : with args; with builderDefs {src="";} null;
-	let localDefs = builderDefs (rec {
+args : with args; with builderDefs;
+	let localDefs = builderDefs.meta.function ((rec {
 		src = /* put a fetchurl here */
 		fetchurl {
 			url = http://download2.berlios.de/linuxdcpp/linuxdcpp-1.0.1.tar.bz2;
@@ -15,7 +15,7 @@ args : with args; with builderDefs {src="";} null;
 			scons PREFIX=$out 
 			scons PREFIX=$out install
 		'') ["minInit" "doUnpack" "addInputs" "defEnsureDir"];
-	}) args null; /* null is a terminator for sumArgs */
+	}) //  args);
 	in with localDefs;
 stdenv.mkDerivation rec {
 	name = "ldcpp-"+version;
diff --git a/pkgs/applications/virtualization/qemu/linux-img/0.2.nix b/pkgs/applications/virtualization/qemu/linux-img/0.2.nix
index b951ca866844..87e2e114becd 100644
--- a/pkgs/applications/virtualization/qemu/linux-img/0.2.nix
+++ b/pkgs/applications/virtualization/qemu/linux-img/0.2.nix
@@ -1,6 +1,6 @@
 
 args : with args;
-	let localDefs = builderDefs {
+	let localDefs = builderDefs.meta.function {
 		src = /* put a fetchurl here */
 		fetchurl {
 			url = [ http://fabrice.bellard.free.fr/qemu/linux-0.2.img.bz2 http://bellard.org/qemu/linux-0.2.img.bz2];
@@ -8,7 +8,7 @@ args : with args;
 		};
 		buildInputs = [];
 		configureFlags = [];
-	} null; /* null is a terminator for sumArgs */
+	};
 	in with localDefs;
 let 
 doCopy = FullDepEntry ("
diff --git a/pkgs/applications/window-managers/compiz/0.6.2.nix b/pkgs/applications/window-managers/compiz/0.6.2.nix
index bd63e356a652..213fc810ddf5 100644
--- a/pkgs/applications/window-managers/compiz/0.6.2.nix
+++ b/pkgs/applications/window-managers/compiz/0.6.2.nix
@@ -1,5 +1,5 @@
 args : with args;
-	let localDefs = builderDefs {
+	let localDefs = builderDefs.meta.function {
 		src = /* put a fetchurl here */
 	fetchurl {
 		url = http://releases.compiz-fusion.org/compiz/0.6.2/compiz-0.6.2.tar.bz2;
@@ -21,7 +21,7 @@ args : with args;
 			"--enable-annotate" "--enable-librsvg"] ++ 
 			(if args ? extraConfigureFlags then args.extraConfigureFlags else []);
 		patches = [ ./glx-patch-0.6.2.patch ];
-	} null; /* null is a terminator for sumArgs */
+	};
 	in with localDefs;
 let
 	postAll = FullDepEntry ("
diff --git a/pkgs/applications/window-managers/compiz/0.7.4.nix b/pkgs/applications/window-managers/compiz/0.7.4.nix
index 8e95a9031557..6ae8f9dec0d5 100644
--- a/pkgs/applications/window-managers/compiz/0.7.4.nix
+++ b/pkgs/applications/window-managers/compiz/0.7.4.nix
@@ -1,5 +1,5 @@
 args : with args;
-	let localDefs = builderDefs {
+	let localDefs = builderDefs.meta.function {
 		src = /* put a fetchurl here */
 	fetchurl {
 		url = http://releases.compiz-fusion.org/0.7.4/compiz/compiz-0.7.4.tar.bz2;
@@ -22,7 +22,7 @@ args : with args;
 			"--enable-annotate" "--enable-librsvg"] ++ 
 			(if args ? extraConfigureFlags then args.extraConfigureFlags else []);
 		patches = [ ./glx-patch-0.6.2.patch ];
-	} null; /* null is a terminator for sumArgs */
+	};
 	in with localDefs;
 let
 	postAll = FullDepEntry ("
diff --git a/pkgs/applications/window-managers/fbpanel/4.12.nix b/pkgs/applications/window-managers/fbpanel/4.12.nix
index 371e86585134..cf09e347a5dd 100644
--- a/pkgs/applications/window-managers/fbpanel/4.12.nix
+++ b/pkgs/applications/window-managers/fbpanel/4.12.nix
@@ -1,5 +1,5 @@
 args : with args;
-	let localDefs = builderDefs {
+	let localDefs = builderDefs.meta.function {
 		src = /* put a fetchurl here */
 	fetchurl {
 		url = http://garr.dl.sourceforge.net/sourceforge/fbpanel/fbpanel-4.12.tgz;
@@ -9,7 +9,7 @@ args : with args;
 		buildInputs = [libX11 gtk pkgconfig libXmu libXpm 
 		  libpng libjpeg libtiff librsvg];
 		configureFlags = [];
-	} null; /* null is a terminator for sumArgs */
+	}; /* null is a terminator for sumArgs */
 	in with localDefs;
 stdenv.mkDerivation rec {
 	name = "fbpanel";