about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/musescore/default.nix4
-rw-r--r--pkgs/applications/audio/musescore/remove_qtwebengine_install_hack.patch16
2 files changed, 7 insertions, 13 deletions
diff --git a/pkgs/applications/audio/musescore/default.nix b/pkgs/applications/audio/musescore/default.nix
index 5368fcb61656..7ef6328c02c2 100644
--- a/pkgs/applications/audio/musescore/default.nix
+++ b/pkgs/applications/audio/musescore/default.nix
@@ -6,11 +6,11 @@
 
 mkDerivation rec {
   pname = "musescore";
-  version = "3.2.3";
+  version = "3.4.2";
 
   src = fetchzip {
     url = "https://github.com/musescore/MuseScore/releases/download/v${version}/MuseScore-${version}.zip";
-    sha256 = "17mr0c8whw6vz86lp1j36rams4h8virc4z68fld0q3rpq6g05szs";
+    sha256 = "1laskvp40dncs12brkgvk7wl0qrvzy52rn7nf3b67ps1vmd130gp";
     stripRoot = false;
   };
 
diff --git a/pkgs/applications/audio/musescore/remove_qtwebengine_install_hack.patch b/pkgs/applications/audio/musescore/remove_qtwebengine_install_hack.patch
index 53a0c90ce46e..57a6092d5852 100644
--- a/pkgs/applications/audio/musescore/remove_qtwebengine_install_hack.patch
+++ b/pkgs/applications/audio/musescore/remove_qtwebengine_install_hack.patch
@@ -1,12 +1,9 @@
---- a/mscore/CMakeLists.txt
-+++ b/mscore/CMakeLists.txt
-@@ -660,22 +660,6 @@ if (MINGW)
- else (MINGW)
-
-    if ( NOT MSVC )
--## install qwebengine core
+--- a/main/CMakeLists.txt
++++ b/main/CMakeLists.txt
+@@ -220,16 +219,0 @@ else (MINGW)
+-      ## install qwebengine core
 -      if (NOT APPLE AND USE_WEBENGINE)
--         install(FILES
+-         install(PROGRAMS
 -            ${QT_INSTALL_LIBEXECS}/QtWebEngineProcess
 -            DESTINATION bin
 -            )
@@ -20,6 +17,3 @@
 -            )
 -      endif(NOT APPLE AND USE_WEBENGINE)
 -
-       target_link_libraries(mscore
-          ${ALSA_LIB}
-          ${QT_LIBRARIES}