about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rwxr-xr-xpkgs/applications/graphics/gqview/builder.sh10
-rw-r--r--pkgs/applications/graphics/gqview/default.fix22
-rwxr-xr-xpkgs/applications/networking/browsers/firebird/builder.sh30
-rw-r--r--pkgs/applications/networking/browsers/firebird/default.fix25
-rwxr-xr-xpkgs/applications/networking/mailreaders/sylpheed/builder.sh20
-rw-r--r--pkgs/applications/networking/mailreaders/sylpheed/default.fix27
-rwxr-xr-xpkgs/applications/networking/newsreaders/pan/builder.sh10
-rw-r--r--pkgs/applications/networking/newsreaders/pan/default.fix29
-rwxr-xr-xpkgs/applications/version-management/subversion/builder.sh35
-rw-r--r--pkgs/applications/version-management/subversion/default.fix36
-rwxr-xr-xpkgs/applications/video/MPlayer/builder.sh19
-rw-r--r--pkgs/applications/video/MPlayer/default.fix31
-rwxr-xr-xpkgs/applications/video/MPlayer/win32codecs/builder.sh9
-rw-r--r--pkgs/applications/video/MPlayer/win32codecs/default.fix10
-rwxr-xr-xpkgs/applications/video/mplayerplug-in/builder.sh11
-rw-r--r--pkgs/applications/video/mplayerplug-in/default.fix17
16 files changed, 341 insertions, 0 deletions
diff --git a/pkgs/applications/graphics/gqview/builder.sh b/pkgs/applications/graphics/gqview/builder.sh
new file mode 100755
index 000000000000..be377db22781
--- /dev/null
+++ b/pkgs/applications/graphics/gqview/builder.sh
@@ -0,0 +1,10 @@
+#! /bin/sh
+
+buildinputs="$pkgconfig $gtk $libpng"
+. $stdenv/setup || exit 1
+
+tar xvfz $src || exit 1
+cd gqview-* || exit 1
+./configure --prefix=$out || exit 1
+make || exit 1
+make install || exit 1
diff --git a/pkgs/applications/graphics/gqview/default.fix b/pkgs/applications/graphics/gqview/default.fix
new file mode 100644
index 000000000000..e9edb7f0bd00
--- /dev/null
+++ b/pkgs/applications/graphics/gqview/default.fix
@@ -0,0 +1,22 @@
+{stdenv, fetchurl, pkgconfig, gtk, libpng}:
+
+assert !isNull pkgconfig && !isNull gtk && !isNull png;
+# Note that we cannot just copy gtk's png attribute, since gtk might
+# not be linked against png.
+assert libpng == gtk.libpng;
+
+derivation {
+  name = "gqview-1.3.5";
+  system = stdenv.system;
+
+  builder = ./builder.sh;
+  src = fetchurl {
+    url = http://heanet.dl.sourceforge.net/sourceforge/gqview/gqview-1.3.5.tar.gz;
+    md5 = "c44687bdd636ea6e5133fb936abf880a";
+  };
+
+  stdenv = stdenv;
+  pkgconfig = pkgconfig;
+  gtk = gtk;
+  libpng = libpng;
+}
diff --git a/pkgs/applications/networking/browsers/firebird/builder.sh b/pkgs/applications/networking/browsers/firebird/builder.sh
new file mode 100755
index 000000000000..36225b5760db
--- /dev/null
+++ b/pkgs/applications/networking/browsers/firebird/builder.sh
@@ -0,0 +1,30 @@
+#! /bin/sh
+
+buildinputs="$pkgconfig $gtk $perl $zip $libIDL"
+. $stdenv/setup || exit 1
+
+tar xvfz $src || exit 1
+cd mozilla || exit 1
+
+cat > .mozconfig <<EOF
+export MOZ_PHOENIX=1
+mk_add_options MOZ_PHOENIX=1
+ac_add_options --enable-crypto
+ac_add_options --disable-tests
+ac_add_options --disable-debug
+ac_add_options --disable-mailnews
+ac_add_options --disable-composer
+ac_add_options --enable-optimize=-O2
+ac_add_options --disable-ldap
+ac_add_options --disable-mailnews
+ac_add_options --enable-extensions=default,-inspector,-irc,-venkman,-content-packs,-help
+ac_add_options --enable-xft
+ac_add_options --enable-swg
+ac_add_options --enable-strip
+ac_add_options --enable-default-toolkit=gtk2
+EOF
+echo "ac_add_options --prefix=$out" >> .mozconfig
+
+./configure || exit 1
+make -f client.mk build || exit 1
+make install || exit 1
diff --git a/pkgs/applications/networking/browsers/firebird/default.fix b/pkgs/applications/networking/browsers/firebird/default.fix
new file mode 100644
index 000000000000..b17b4a0e4731
--- /dev/null
+++ b/pkgs/applications/networking/browsers/firebird/default.fix
@@ -0,0 +1,25 @@
+{ stdenv, fetchurl, pkgconfig, gtk, perl, zip, libIDL
+}:
+
+assert !isNull pkgconfig && !isNull gtk && !isNull perl
+  && !isNull zip && !isNull libIDL;
+
+assert libIDL.glib == gtk.glib;
+
+derivation {
+  name = "MozillaFirebird-0.7";
+  system = stdenv.system;
+
+  builder = ./builder.sh;
+  src = fetchurl {
+    url = ftp://ftp.mozilla.org/pub/mozilla.org/firebird/releases/0.7/MozillaFirebird-source-0.7.tar.gz;
+    md5 = "35112566a3dca5bdf363972056afc462";
+  };
+
+  stdenv = stdenv;
+  pkgconfig = pkgconfig;
+  gtk = gtk;
+  perl = perl;
+  zip = zip;
+  libIDL = libIDL;
+}
diff --git a/pkgs/applications/networking/mailreaders/sylpheed/builder.sh b/pkgs/applications/networking/mailreaders/sylpheed/builder.sh
new file mode 100755
index 000000000000..db66df470aa2
--- /dev/null
+++ b/pkgs/applications/networking/mailreaders/sylpheed/builder.sh
@@ -0,0 +1,20 @@
+#! /bin/sh
+
+buildinputs="$gtk $gdkpixbuf $openssl"
+. $stdenv/setup || exit 1
+
+if test $sslSupport; then
+    extraflags="--enable-ssl $extraflags"
+fi
+
+if test $imageSupport; then
+    extraflags="--enable-gdk-pixbuf $extraflags"
+else
+    extraflags="--disable-gdk-pixbuf --disable-imlibtest $extraflags"
+fi    
+
+tar xvfj $src || exit 1
+cd sylpheed-* || exit 1
+./configure --prefix=$out $extraflags || exit 1
+make || exit 1
+make install || exit 1
diff --git a/pkgs/applications/networking/mailreaders/sylpheed/default.fix b/pkgs/applications/networking/mailreaders/sylpheed/default.fix
new file mode 100644
index 000000000000..c6e8cc066f8c
--- /dev/null
+++ b/pkgs/applications/networking/mailreaders/sylpheed/default.fix
@@ -0,0 +1,27 @@
+{ sslSupport ? true
+, imageSupport ? true
+, stdenv, fetchurl, gtk, openssl ? null, gdkpixbuf ? null
+}:
+
+assert !isNull gtk;
+assert sslSupport -> !isNull openssl;
+assert imageSupport -> !isNull gdkpixbuf;
+
+derivation {
+  name = "sylpheed-0.9.7";
+  system = stdenv.system;
+
+  builder = ./builder.sh;
+  src = fetchurl {
+    url = http://sylpheed.good-day.net/sylpheed/sylpheed-0.9.7.tar.bz2;
+    md5 = "399deb5abd52396d26d6475689a5ec3f";
+  };
+
+  sslSupport = sslSupport;
+  imageSupport = imageSupport;
+
+  stdenv = stdenv;
+  gtk = gtk;
+  openssl = if sslSupport then openssl else null;
+  gdkpixbuf = if imageSupport then gdkpixbuf else null;
+}
diff --git a/pkgs/applications/networking/newsreaders/pan/builder.sh b/pkgs/applications/networking/newsreaders/pan/builder.sh
new file mode 100755
index 000000000000..b2f160e155dc
--- /dev/null
+++ b/pkgs/applications/networking/newsreaders/pan/builder.sh
@@ -0,0 +1,10 @@
+#! /bin/sh
+
+buildinputs="$pkgconfig $gtk $gtkspell $gnet $libxml2 $perl"
+. $stdenv/setup || exit 1
+
+tar xvfj $src || exit 1
+cd pan-* || exit 1
+./configure --prefix=$out || exit 1
+make || exit 1
+make install || exit 1
diff --git a/pkgs/applications/networking/newsreaders/pan/default.fix b/pkgs/applications/networking/newsreaders/pan/default.fix
new file mode 100644
index 000000000000..26b7e6af2b52
--- /dev/null
+++ b/pkgs/applications/networking/newsreaders/pan/default.fix
@@ -0,0 +1,29 @@
+{ spellChecking ? true
+, stdenv, fetchurl, pkgconfig, gtk, gtkspell ? null, gnet, libxml2, perl
+}:
+
+assert !isNull pkgconfig && !isNull gtk && !isNull gnet
+  && !isNull libxml2 && !isNull perl;
+assert spellChecking -> !isNull gtkspell && gtk == gtkspell.gtk;
+assert gtk.glib == gnet.glib;
+
+derivation {
+  name = "pan-0.14.2";
+  system = stdenv.system;
+
+  builder = ./builder.sh;
+  src = fetchurl {
+    url = http://pan.rebelbase.com/download/releases/0.14.2/SOURCE/pan-0.14.2.tar.bz2;
+    md5 = "ed3188e7059bb6d6c209ee5d46ac1852";
+  };
+
+  spellChecking = spellChecking;
+
+  stdenv = stdenv;
+  pkgconfig = pkgconfig;
+  gtk = gtk;
+  gtkspell = if spellChecking then gtkspell else null;
+  gnet = gnet;
+  libxml2 = libxml2;
+  perl = perl;
+}
diff --git a/pkgs/applications/version-management/subversion/builder.sh b/pkgs/applications/version-management/subversion/builder.sh
new file mode 100755
index 000000000000..72848c795322
--- /dev/null
+++ b/pkgs/applications/version-management/subversion/builder.sh
@@ -0,0 +1,35 @@
+#! /bin/sh
+
+buildinputs="$openssl $db4 $httpd $swig $expat"
+. $stdenv/setup || exit 1
+
+if test $localServer; then
+    extraflags="--with-berkeley-db=$db4 $extraflags"
+fi
+
+if test $sslSupport; then
+    extraflags="--with-ssl --with-libs=$openssl $extraflags"
+fi
+
+if test $httpServer; then
+    extraflags="--with-apxs=$httpd/bin/apxs --with-apr=$httpd --with-apr-util=$httpd $extraflags"
+    extramakeflags="APACHE_LIBEXECDIR=$out/modules $extramakeflags"
+fi
+
+if test $swigBindings; then
+    extraflags="--with-swig=$swig $extraflags"
+fi
+
+echo "extra flags: $extraflags"
+
+tar xvfz $src || exit 1
+cd subversion-* || exit 1
+./configure --prefix=$out $extraflags \
+ --without-gdbm --disable-static || exit 1
+make $extramakeflags || exit 1
+make install $extramakeflags || exit 1
+
+if test $swigBindings; then
+    make swig-py || exit 1
+    make install-swig-py || exit 1
+fi
diff --git a/pkgs/applications/version-management/subversion/default.fix b/pkgs/applications/version-management/subversion/default.fix
new file mode 100644
index 000000000000..76a46511b271
--- /dev/null
+++ b/pkgs/applications/version-management/subversion/default.fix
@@ -0,0 +1,36 @@
+{ localServer ? false
+, httpServer ? false
+, sslSupport ? false
+, swigBindings ? false
+, stdenv, fetchurl
+, openssl ? null, httpd ? null, db4 ? null, expat, swig ? null
+}:
+
+assert !isNull expat;
+assert localServer -> !isNull db4;
+assert httpServer -> !isNull httpd && httpd.expat == expat;
+assert sslSupport -> !isNull openssl && (httpServer -> httpd.openssl == openssl);
+assert swigBindings -> !isNull swig;
+
+derivation {
+  name = "subversion-0.32.1";
+  system = stdenv.system;
+
+  builder = ./builder.sh;
+  src = fetchurl {
+    url = http://svn.collab.net/tarballs/subversion-0.32.1.tar.gz;
+    md5 = "b06717a8ef50db4b5c4d380af00bd901";
+  };
+
+  localServer = localServer;
+  httpServer = httpServer;
+  sslSupport = sslSupport;
+  swigBindings = swigBindings;
+
+  stdenv = stdenv;
+  openssl = if sslSupport then openssl else null;
+  httpd = if httpServer then httpd else null;
+  expat = expat;
+  db4 = if localServer then db4 else null;
+  swig = if swigBindings then swig else null;
+}
diff --git a/pkgs/applications/video/MPlayer/builder.sh b/pkgs/applications/video/MPlayer/builder.sh
new file mode 100755
index 000000000000..aa018e73c2ff
--- /dev/null
+++ b/pkgs/applications/video/MPlayer/builder.sh
@@ -0,0 +1,19 @@
+#! /bin/sh
+
+buildinputs="$freetype $x11 $alsa"
+. $stdenv/setup || exit 1
+
+tar xvfj $src || exit 1
+tar xvfj $fonts || exit 1
+cd MPlayer-* || exit 1
+./configure --prefix=$out --with-win32libdir=$win32codecs \
+ --with-x11incdir=$x11/include --with-x11libdir=$x11/lib \
+ --with-reallibdir=$win32codecs \
+ --disable-sdl --disable-esd --disable-xanim --disable-cdparanoia --disable-directfb \
+ --disable-lirc --disable-svga --disable-libdv \
+ --disable-vorbis --disable-png --disable-jpeg --disable-gif \
+ --enable-runtime-cpudetection \
+ || exit 1
+make || exit 1
+make install || exit 1
+cp -p ../font-arial-iso-8859-1/font-arial-18-iso-8859-1/* $out/share/mplayer/font || exit 1
diff --git a/pkgs/applications/video/MPlayer/default.fix b/pkgs/applications/video/MPlayer/default.fix
new file mode 100644
index 000000000000..065676bc2ad5
--- /dev/null
+++ b/pkgs/applications/video/MPlayer/default.fix
@@ -0,0 +1,31 @@
+{ alsaSupport ? false
+, stdenv, fetchurl, x11, freetype, alsa ? null}:
+
+assert !isNull x11 && !isNull freetype;
+assert alsaSupport -> !isNull alsa;
+
+derivation {
+  name = "MPlayer-1.0pre2";
+  system = stdenv.system;
+
+  builder = ./builder.sh;
+  src = fetchurl {
+    url = http://www2.mplayerhq.hu/MPlayer/releases/MPlayer-1.0pre2.tar.bz2;
+    md5 = "a60c179468f85e83e3f9e1922e81ad64";
+  };
+  fonts = fetchurl {
+    url = http://www2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2;
+    md5 = "1ecd31d17b51f16332b1fcc7da36b312";
+  };
+
+  alsaSupport = alsaSupport;
+
+  stdenv = stdenv;
+  x11 = x11;
+  freetype = freetype;
+  alsa = if alsaSupport then alsa else null;
+  win32codecs = (import ./win32codecs) {
+    stdenv = stdenv;
+    fetchurl = fetchurl;
+  };
+}
diff --git a/pkgs/applications/video/MPlayer/win32codecs/builder.sh b/pkgs/applications/video/MPlayer/win32codecs/builder.sh
new file mode 100755
index 000000000000..9b76079acabb
--- /dev/null
+++ b/pkgs/applications/video/MPlayer/win32codecs/builder.sh
@@ -0,0 +1,9 @@
+#! /bin/sh
+
+. $stdenv/setup || exit 1
+
+mkdir $out || exit 1
+cd $out || exit 1
+tar xvfj $src || exit 1
+mv extralite/* . || exit 1
+rmdir extralite || exit 1
diff --git a/pkgs/applications/video/MPlayer/win32codecs/default.fix b/pkgs/applications/video/MPlayer/win32codecs/default.fix
new file mode 100644
index 000000000000..699875ae1594
--- /dev/null
+++ b/pkgs/applications/video/MPlayer/win32codecs/default.fix
@@ -0,0 +1,10 @@
+{stdenv, fetchurl}: derivation {
+  name = "win32codecs-1";
+  system = stdenv.system;
+  builder = ./builder.sh;
+  src = fetchurl {
+    url = http://www2.mplayerhq.hu/MPlayer/releases/codecs/extralite.tar.bz2;
+    md5 = "4748ecae87f71e8bda9cb2e2a9bd30b4";
+  };
+  stdenv = stdenv;
+}
diff --git a/pkgs/applications/video/mplayerplug-in/builder.sh b/pkgs/applications/video/mplayerplug-in/builder.sh
new file mode 100755
index 000000000000..300a445ea0a9
--- /dev/null
+++ b/pkgs/applications/video/mplayerplug-in/builder.sh
@@ -0,0 +1,11 @@
+#! /bin/sh
+
+buildinputs="$x11"
+. $stdenv/setup || exit 1
+
+tar xvfz $src || exit 1
+cd mplayer* || exit 1
+./configure || exit 1
+make || exit 1
+mkdir -p $out/lib/mozilla/plugins || exit 1
+cp mplayerplug-in.so $out/lib/mozilla/plugins || exit 1
diff --git a/pkgs/applications/video/mplayerplug-in/default.fix b/pkgs/applications/video/mplayerplug-in/default.fix
new file mode 100644
index 000000000000..c06fc31fee42
--- /dev/null
+++ b/pkgs/applications/video/mplayerplug-in/default.fix
@@ -0,0 +1,17 @@
+{stdenv, fetchurl, x11}:
+
+assert !isNull x11;
+
+derivation {
+  name = "mplayerplug-in-1.0pre2";
+  system = stdenv.system;
+
+  builder = ./builder.sh;
+  src = fetchurl {
+    url = http://heanet.dl.sourceforge.net/sourceforge/mplayerplug-in/mplayerplug-in-1.0pre2.tar.gz;
+    md5 = "1a6eb243989c143984bb1aac63b5282e";
+  };
+
+  stdenv = stdenv;
+  x11 = x11;
+}