about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/i-score/default.nix4
-rw-r--r--pkgs/applications/editors/geany/default.nix4
-rw-r--r--pkgs/applications/graphics/antimony/default.nix39
-rw-r--r--pkgs/applications/graphics/antimony/paths-fix.patch118
-rw-r--r--pkgs/applications/graphics/feh/default.nix4
-rw-r--r--pkgs/applications/graphics/graphicsmagick/default.nix4
-rw-r--r--pkgs/applications/misc/iterm2/default.nix4
-rw-r--r--pkgs/applications/misc/lighthouse/Makefile.patch31
-rw-r--r--pkgs/applications/misc/lighthouse/default.nix49
-rw-r--r--pkgs/applications/misc/pdfmod/default.nix9
-rw-r--r--pkgs/applications/networking/browsers/firefox-bin/default.nix9
-rw-r--r--pkgs/applications/networking/browsers/firefox-bin/dev_sources.nix12
-rw-r--r--pkgs/applications/networking/browsers/firefox-bin/generate_sources_dev.rb53
-rw-r--r--pkgs/applications/networking/browsers/mozilla-plugins/bluejeans/default.nix4
-rw-r--r--pkgs/applications/networking/ftp/filezilla/default.nix4
-rw-r--r--pkgs/applications/networking/instant-messengers/zoom-us/default.nix105
-rw-r--r--pkgs/applications/networking/sniffers/wireshark/default.nix4
-rw-r--r--pkgs/applications/video/mkvtoolnix/default.nix17
-rw-r--r--pkgs/applications/video/recordmydesktop/default.nix15
-rw-r--r--pkgs/applications/video/recordmydesktop/gtk.nix37
-rw-r--r--pkgs/applications/video/recordmydesktop/qt.nix37
-rw-r--r--pkgs/applications/video/simplescreenrecorder/default.nix13
-rw-r--r--pkgs/applications/video/simplescreenrecorder/fix-paths.patch35
-rw-r--r--pkgs/applications/video/vlc/default.nix4
-rw-r--r--pkgs/applications/window-managers/i3/lock.nix4
25 files changed, 451 insertions, 168 deletions
diff --git a/pkgs/applications/audio/i-score/default.nix b/pkgs/applications/audio/i-score/default.nix
index 17fadfe8b1f0..97e8f5f1429b 100644
--- a/pkgs/applications/audio/i-score/default.nix
+++ b/pkgs/applications/audio/i-score/default.nix
@@ -3,7 +3,7 @@
   cln,
   cmake,
   fetchgit,
-  gcc5,
+  gcc,
   ginac,
   jamomacore,
   kde5,
@@ -37,7 +37,7 @@ stdenv.mkDerivation rec {
     cln
     cmake
     ginac
-    gcc5
+    gcc
     jamomacore
     kde5.kdnssd
     libsndfile
diff --git a/pkgs/applications/editors/geany/default.nix b/pkgs/applications/editors/geany/default.nix
index b4f6baa9c64a..cd93a4ed0e8f 100644
--- a/pkgs/applications/editors/geany/default.nix
+++ b/pkgs/applications/editors/geany/default.nix
@@ -1,7 +1,7 @@
 { stdenv, fetchurl, gtk2, which, pkgconfig, intltool, file }:
 
 let
-  version = "1.27";
+  version = "1.28";
 in
 
 stdenv.mkDerivation rec {
@@ -9,7 +9,7 @@ stdenv.mkDerivation rec {
 
   src = fetchurl {
     url = "http://download.geany.org/${name}.tar.bz2";
-    sha256 = "846ff699a5944c5c3c068ae0199d4c13946a668bfc6d03f8c79765667c20cadf";
+    sha256 = "0nha21rbdhl10vdpaq8d5v5fszvggl1xar555pvrnvm2y443ffpp";
   };
 
   buildInputs = [ gtk2 which pkgconfig intltool file ];
diff --git a/pkgs/applications/graphics/antimony/default.nix b/pkgs/applications/graphics/antimony/default.nix
index 8d17a290cebb..b7d9f4a81599 100644
--- a/pkgs/applications/graphics/antimony/default.nix
+++ b/pkgs/applications/graphics/antimony/default.nix
@@ -1,29 +1,25 @@
-{ stdenv, fetchgit, libpng, python3, boost, mesa, qtbase, qmakeHook, ncurses }:
+{ stdenv, fetchFromGitHub, libpng, python3, boost, mesa, qtbase, ncurses, cmake, flex, lemon }:
 
 let
-  gitRev    = "745eca3a2d2657c495d5509e9083c884e021d09c";
+  gitRev    = "e8480c718e8c49ae3cc2d7af10ea93ea4c2fff9a";
   gitBranch = "master";
-  gitTag    = "0.8.0b";
+  gitTag    = "0.9.2";
 in 
   stdenv.mkDerivation rec {
     name    = "antimony-${version}";
     version = gitTag;
 
-    src  = fetchgit {
-      url         = "git://github.com/mkeeter/antimony.git";
-      rev         = gitRev;
-      sha256      = "0azjdkbixz2pyk2yy7a0ya5xk60xgw3l2pd4pj4ijyqxx5jmh0sy";
+    src = fetchFromGitHub {
+      owner = "mkeeter";
+      repo = "antimony";
+      rev = gitTag;
+      sha256 = "0fpgy5cb4knz2z9q078206k8wzxfs8b9g76mf4bz1ic77931ykjz";
     };
 
     patches = [ ./paths-fix.patch ];
-    # fix build with glibc-2.23
+
     postPatch = ''
-      sed 's/\<isinf(/std::isinf(/g' -i \
-        src/export/export_heightmap.cpp \
-        src/fab/types/bounds.cpp \
-        src/graph/hooks/meta.cpp \
-        src/ui/dialogs/resolution_dialog.cpp \
-        src/render/render_task.cpp
+       sed -i "s,/usr/local,$out,g" app/CMakeLists.txt app/app/app.cpp app/app/main.cpp
     '';
 
     buildInputs = [
@@ -31,15 +27,13 @@ in
       mesa qtbase ncurses
     ];
 
-    nativeBuildHooks = [ qmakeHook ];
-
-    preConfigure = ''
-      export GITREV=${gitRev}
-      export GITBRANCH=${gitBranch}
-      export GITTAG=${gitTag}
+    nativeBuildInputs = [ cmake flex lemon ];
 
-      cd qt
-    '';
+    cmakeFlags= [
+      "-DGITREV=${gitRev}"
+      "-DGITTAG=${gitTag}"
+      "-DGITBRANCH=${gitBranch}"
+    ];
 
     enableParallelBuilding = true;
 
@@ -48,6 +42,5 @@ in
       homepage    = "https://github.com/mkeeter/antimony";
       license     = licenses.mit;
       platforms   = platforms.linux;
-      broken = true;
     };
   }
diff --git a/pkgs/applications/graphics/antimony/paths-fix.patch b/pkgs/applications/graphics/antimony/paths-fix.patch
index de8d9e7beb08..9235dd6cdce1 100644
--- a/pkgs/applications/graphics/antimony/paths-fix.patch
+++ b/pkgs/applications/graphics/antimony/paths-fix.patch
@@ -1,99 +1,21 @@
-diff --git a/qt/antimony.pro b/qt/antimony.pro
-index 9d586f4..b055a6d 100644
---- a/qt/antimony.pro
-+++ b/qt/antimony.pro
-@@ -12,14 +12,9 @@ QMAKE_CXXFLAGS_RELEASE += -O3
- 
- QMAKE_CXXFLAGS += -Werror=switch
- 
--GITREV = $$system(git log --pretty=format:'%h' -n 1)
--GITDIFF = $$system(git diff --quiet --exit-code || echo "+")
--GITTAG = $$system(git describe --exact-match --tags 2> /dev/null)
--GITBRANCH = $$system(git rev-parse --abbrev-ref HEAD)
--
--QMAKE_CXXFLAGS += "-D'GITREV=\"$${GITREV}$${GITDIFF}\"'"
--QMAKE_CXXFLAGS += "-D'GITTAG=\"$${GITTAG}\"'"
--QMAKE_CXXFLAGS += "-D'GITBRANCH=\"$${GITBRANCH}\"'"
-+QMAKE_CXXFLAGS += "-D'GITREV=\"$$(GITREV)\"'"
-+QMAKE_CXXFLAGS += "-D'GITTAG=\"$$(GITTAG)\"'"
-+QMAKE_CXXFLAGS += "-D'GITBRANCH=\"$$(GITBRANCH)\"'"
- 
- OLD_GL_SET = $$(OLD_GL)
- equals(OLD_GL_SET, "true") {
-@@ -125,11 +120,11 @@ macx {
- }
- 
- linux {
--    executable.path = /usr/local/bin
-+    executable.path = $$(out)/bin
-     executable.files = antimony
--    nodes_folder.path = /usr/local/bin/sb/nodes
-+    nodes_folder.path = $$(out)/bin/sb/nodes
-     nodes_folder.files = ../py/nodes/*
--    fab_folder.path = /usr/local/bin/sb/fab
-+    fab_folder.path = $$(out)/bin/sb/fab
-     fab_folder.files = ../py/fab/*
-     INSTALLS += executable nodes_folder fab_folder
- }
-diff --git a/qt/fab.pri b/qt/fab.pri
-index a54813b..b500536 100644
---- a/qt/fab.pri
-+++ b/qt/fab.pri
-@@ -54,7 +54,7 @@ DEFINES += '_STATIC_= '
- 
- linux {
-     QMAKE_CFLAGS += -std=gnu99
--    QMAKE_CXXFLAGS += $$system(/usr/bin/python3-config --includes)
-+    QMAKE_CXXFLAGS += $$system(python3-config --includes)
-     LIBS += -lpng
- }
- 
-diff --git a/qt/shared.pri b/qt/shared.pri
-index e7d0e3a..026eae3 100644
---- a/qt/shared.pri
-+++ b/qt/shared.pri
-@@ -39,41 +39,11 @@ macx {
- }
- 
- linux {
--    QMAKE_CXXFLAGS += $$system(/usr/bin/python3-config --includes)
--    QMAKE_LFLAGS   += $$system(/usr/bin/python3-config --ldflags)
-+    QMAKE_CXXFLAGS += $$system(python3-config --includes)
-+    QMAKE_LFLAGS   += $$system(python3-config --ldflags)
- 
-     # Even though this is in QMAKE_LFLAGS, the linker is picky about
-     # library ordering (so it needs to be here too).
-     LIBS += -lpython3.4m
--
--    # ldconfig is being used to find libboost_python, but it's in a different
--    # place in different distros (and is not in the default $PATH on Debian).
--    # First, check to see if it's on the default $PATH.
--    system(which ldconfig > /dev/null) {
--        LDCONFIG_BIN = "ldconfig"
--    }
--    # If that failed, then search for it in its usual places.
--    isEmpty(LDCONFIG_BIN) {
--        for(p, $$list(/sbin/ldconfig /usr/bin/ldconfig)) {
--            exists($$p): LDCONFIG_BIN = $$p
--        }
--    }
--    # If that search failed too, then exit with an error.
--    isEmpty(LDCONFIG_BIN) {
--        error("Could not find ldconfig!")
--    }
--
--    # Check for different boost::python naming schemes
--    LDCONFIG_OUT = $$system($$LDCONFIG_BIN -p|grep python)
--    for (b, $$list(boost_python-py34 boost_python3)) {
--        contains(LDCONFIG_OUT, "lib$${b}.so") {
--            LIBS += "-l$$b"
--            GOT_BOOST_PYTHON = True
--        }
--    }
+diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
+index ddc5c9b..d80728a 100644
+--- a/app/CMakeLists.txt
++++ b/app/CMakeLists.txt
+@@ -158,16 +158,6 @@ target_link_libraries(${ANTIMONY_APP}
+ 
+ ################################################################################
+ 
+-execute_process(COMMAND git log --pretty=format:'%h' -n 1
+-                OUTPUT_VARIABLE GITREV)
+-execute_process(COMMAND bash -c "git diff --quiet --exit-code || echo +"
+-                OUTPUT_VARIABLE GITDIFF)
+-execute_process(COMMAND git describe --exact-match --tags
+-                OUTPUT_VARIABLE GITTAG
+-                ERROR_QUIET)
+-execute_process(COMMAND git rev-parse --abbrev-ref HEAD
+-                OUTPUT_VARIABLE GITBRANCH)
 -
--    # If we couldn't find boost::python, exit with an error.
--    isEmpty(GOT_BOOST_PYTHON) {
--        error("Could not find boost::python3")
--    }
-+    LIBS += -lboost_python3
- }
+ add_definitions(-D'GITREV="${GITREV}${GITDIFF}"'
+                 -D'GITTAG="${GITTAG}"'
+                 -D'GITBRANCH="${GITBRANCH}"')
diff --git a/pkgs/applications/graphics/feh/default.nix b/pkgs/applications/graphics/feh/default.nix
index 2d7b88742466..a20a1be77f88 100644
--- a/pkgs/applications/graphics/feh/default.nix
+++ b/pkgs/applications/graphics/feh/default.nix
@@ -2,11 +2,11 @@
 , libXinerama, curl, libexif, perlPackages }:
 
 stdenv.mkDerivation rec {
-  name = "feh-2.15.4";
+  name = "feh-2.16.1";
 
   src = fetchurl {
     url = "http://feh.finalrewind.org/${name}.tar.bz2";
-    sha256 = "b8a9c29f37b1349228b19866f712b677e2a150837bc46be8c5d6348dd4850758";
+    sha256 = "1cxnc8dxyl7s4qnkvdjaqx7gdvc6brxpq0qbg91mljg47fd2hmbf";
   };
 
   outputs = [ "out" "doc" ];
diff --git a/pkgs/applications/graphics/graphicsmagick/default.nix b/pkgs/applications/graphics/graphicsmagick/default.nix
index 63b88ee4fb94..b780067823a9 100644
--- a/pkgs/applications/graphics/graphicsmagick/default.nix
+++ b/pkgs/applications/graphics/graphicsmagick/default.nix
@@ -2,14 +2,14 @@
 , libjpeg, libpng, libtiff, libxml2, zlib, libtool, xz
 , libX11, libwebp, quantumdepth ? 8}:
 
-let version = "1.3.23"; in
+let version = "1.3.24"; in
 
 stdenv.mkDerivation {
   name = "graphicsmagick-${version}";
 
   src = fetchurl {
     url = "mirror://sourceforge/graphicsmagick/GraphicsMagick-${version}.tar.xz";
-    sha256 = "03g6l2h8cmf231y1vma0z7x85070jm1ysgs9ppqcd3jj56jka9gx";
+    sha256 = "1q40w5hcl8rcpszm0r7rpr3a9lj390p39zfvavkvlgxyyk7bmgsj";
   };
 
   patches = [ ./disable-popen.patch ];
diff --git a/pkgs/applications/misc/iterm2/default.nix b/pkgs/applications/misc/iterm2/default.nix
index add16365324e..028e5d6b725a 100644
--- a/pkgs/applications/misc/iterm2/default.nix
+++ b/pkgs/applications/misc/iterm2/default.nix
@@ -2,13 +2,13 @@
 
 stdenv.mkDerivation rec {
   name = "iterm2-${version}";
-  version = "3.0.2";
+  version = "3.0.4";
 
   src = fetchFromGitHub {
     owner = "gnachman";
     repo = "iTerm2";
     rev = "v${version}";
-    sha256 = "121g759i814y1g1g1jwhsmxgg4wrzv08vq7a7qwc7b85a17zbd3h";
+    sha256 = "0ffg9l2jvv503h13nd5rjkn5xrahswcqqwmm052qzd6d0lmqjm93";
   };
 
   patches = [ ./disable_updates.patch ];
diff --git a/pkgs/applications/misc/lighthouse/Makefile.patch b/pkgs/applications/misc/lighthouse/Makefile.patch
new file mode 100644
index 000000000000..0207299cc2c5
--- /dev/null
+++ b/pkgs/applications/misc/lighthouse/Makefile.patch
@@ -0,0 +1,31 @@
+# Description: Fix lighthouse Makefile
+Index: Makefile
+===================================================================
+--- ./Makefile	1970-01-01 02:00:01.000000000 +0200
++++ ./Makefile	1970-01-01 02:00:01.000000000 +0200
+@@ -19,21 +19,10 @@
+ endif
+ 
+ # Library specific
+-HAS_GDK := $(shell pkg-config --exists gdk-2.0 echo $?)
+-ifdef $(HAS_GDK)
+-	CFLAGS+=`pkg-config --cflags gdk-2.0`
+-	LDFLAGS+=`pkg-config --libs gdk-2.0`
+-else
+-	CFLAGS+=-DNO_GDK
+-endif
+-HAS_PANGO := $(shell pkg-config --exists pango echo $?)
+-ifdef $(HAS_PANGO)
+-	CFLAGS+=`pkg-config --cflags pango`
+-	LDFLAGS+=`pkg-config --libs pango`
+-else
+-	CFLAGS+=-DNO_PANGO
+-endif
+-
++CFLAGS+=$(shell pkg-config --cflags gdk-2.0)
++LDFLAGS+=$(shell pkg-config --libs gdk-2.0)
++CFLAGS+=$(shell pkg-config --cflags pango)
++LDFLAGS+=$(shell pkg-config --libs pango)
+ 
+ all: lighthouse
+ 
diff --git a/pkgs/applications/misc/lighthouse/default.nix b/pkgs/applications/misc/lighthouse/default.nix
new file mode 100644
index 000000000000..8400c01665ec
--- /dev/null
+++ b/pkgs/applications/misc/lighthouse/default.nix
@@ -0,0 +1,49 @@
+{ stdenv, fetchFromGitHub, pkgconfig
+, libX11, libxcb, cairo, gtk, pango, python27, python3
+}:
+
+stdenv.mkDerivation rec {
+  name = "lighthouse-${date}";
+  date = "2016-01-26";
+
+  src = fetchFromGitHub {
+    owner = "emgram769";
+    repo = "lighthouse";
+    rev = "bf11f111572475e855b0329202a14c9e128c7e57";
+    sha256 = "1ppika61vg4sc9mczbkjqy2mhgxqg57xrnsmmq0h2lyvj0yhg3qn";
+   };
+
+  buildInputs = [
+    pkgconfig libX11 libxcb cairo gtk pango python27 python3
+  ];
+
+  patches = [ ./Makefile.patch ];
+
+  lighthouseInstaller = ''
+    #!${stdenv.shell}
+    cp -r $out/share/lighthouse/.config/lighthouse \$HOME/.config
+    chmod -R +w \$HOME/.config/lighthouse
+  '';
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp lighthouse $out/bin
+    chmod +x config/lighthouse/cmd*
+    chmod +x config/lighthouse/google.py
+    patchShebangs config/lighthouse/
+    patchShebangs config/lighthouse/scripts/
+    mkdir -p $out/share/lighthouse/.config
+    cp -r config/lighthouse $out/share/lighthouse/.config
+    echo "${lighthouseInstaller}" > $out/bin/lighthouse-install
+    chmod +x $out/bin/lighthouse-install
+  '';
+
+  meta = with stdenv.lib; {
+    description = "A simple flexible popup dialog to run on X";
+    homepage = https://github.com/emgram769/lighthouse;
+    license = licenses.mit;
+    maintainers = with maintainers; [ ramkromberg ];
+    platforms = platforms.linux;
+  };
+
+}
diff --git a/pkgs/applications/misc/pdfmod/default.nix b/pkgs/applications/misc/pdfmod/default.nix
index 24a0a8c69675..0978da3512b8 100644
--- a/pkgs/applications/misc/pdfmod/default.nix
+++ b/pkgs/applications/misc/pdfmod/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, fetchpatch, pkgconfig, gnome_doc_utils, intltool
+{ stdenv, fetchurl, fetchpatch, pkgconfig, gnome_doc_utils, intltool, lib
 , mono, gtk-sharp, gnome-sharp, hyena
 , which, makeWrapper, glib, gnome3, poppler, wrapGAppsHook
 }:
@@ -33,12 +33,7 @@ stdenv.mkDerivation rec {
       --add-flags "$out/lib/pdfmod/PdfMod.exe" \
       --prefix MONO_GAC_PREFIX : ${gtk-sharp} \
       --prefix MONO_GAC_PREFIX : ${gnome-sharp} \
-      --prefix LD_LIBRARY_PATH : ${glib}/lib \
-      --prefix LD_LIBRARY_PATH : ${gtk-sharp}/lib \
-      --prefix LD_LIBRARY_PATH : ${gnome-sharp}/lib \
-      --prefix LD_LIBRARY_PATH : ${gtk-sharp.gtk}/lib \
-      --prefix LD_LIBRARY_PATH : ${gnome3.gconf}/lib \
-      --prefix LD_LIBRARY_PATH : ${poppler.out}/lib
+      --prefix LD_LIBRARY_PATH : ${lib.makeLibraryPath [ glib gnome-sharp gnome3.gconf gtk-sharp gtk-sharp.gtk poppler ]}
   '';
 
   dontStrip = true;
diff --git a/pkgs/applications/networking/browsers/firefox-bin/default.nix b/pkgs/applications/networking/browsers/firefox-bin/default.nix
index 26030e33e488..e9f6f816be51 100644
--- a/pkgs/applications/networking/browsers/firefox-bin/default.nix
+++ b/pkgs/applications/networking/browsers/firefox-bin/default.nix
@@ -42,12 +42,9 @@ assert stdenv.isLinux;
 
 let
 
-  generated = if channel == "stable" then (import ./sources.nix)
-         else if channel == "beta"   then (import ./beta_sources.nix)
-         else if channel == "developer"   then { version = "49.0a2"; sources = [
-            { locale = "en-US"; arch = "linux-i686"; sha512 = "45dad182bf7a4e753c1be6b8f966393a06531e7b5530238d20cb67b26324e8f5d0eeec983a0855418f31187d3ae508c28810ab86269848b4e48ab2ca3b5d21e7"; }
-            { locale = "en-US"; arch = "linux-x86_64"; sha512 = "cfcbfc633b51612a62267c8a1afc25af212eb832d1fa876a1ffd82421e9378f96b3ac1488446f804518290abd99c21c9f10e4d0e0f699432aeb74b63305d7edc"; }
-          ]; }
+  generated = if channel == "stable"    then (import ./sources.nix)
+         else if channel == "beta"      then (import ./beta_sources.nix)
+         else if channel == "developer" then (import ./dev_sources.nix)
          else builtins.abort "Wrong channel! Channel must be one of `stable`, `beta` or `developer`";
 
   inherit (generated) version sources;
diff --git a/pkgs/applications/networking/browsers/firefox-bin/dev_sources.nix b/pkgs/applications/networking/browsers/firefox-bin/dev_sources.nix
new file mode 100644
index 000000000000..f43810d53f0d
--- /dev/null
+++ b/pkgs/applications/networking/browsers/firefox-bin/dev_sources.nix
@@ -0,0 +1,12 @@
+# This file is generated from generate_sources_dev.rb. DO NOT EDIT.
+# Execute the following command to update the file.
+#
+# ruby generate_sources_dev.rb 49.0a2 > dev_sources.nix
+
+{
+  version = "49.0a2";
+  sources = [
+    { locale = "en-US"; arch = "linux-i686"; sha512 = "85c4289e561d2246f96a05e3b8df011337984b9f176670826a705c2cd68a1284056ba507e4b6e4887595bf37f25386d9f7b28a20bc1f125865b9fd7b8be17eaa"; }
+    { locale = "en-US"; arch = "linux-x86_64"; sha512 = "2bf9518dbfbb48348f74929c19d03e8daf51020bf9ba6db577a202b6e98ad7ffb9e9a0b4ca92af010cd3f864ae84940b65438f4230e6de3165f72e4e7280086d"; }
+  ];
+}
diff --git a/pkgs/applications/networking/browsers/firefox-bin/generate_sources_dev.rb b/pkgs/applications/networking/browsers/firefox-bin/generate_sources_dev.rb
new file mode 100644
index 000000000000..37d5569efb01
--- /dev/null
+++ b/pkgs/applications/networking/browsers/firefox-bin/generate_sources_dev.rb
@@ -0,0 +1,53 @@
+#!/usr/bin/env ruby
+require "open-uri"
+
+version =
+  if ARGV.empty?
+    $stderr.puts("Usage: ruby generate_sources_dev.rb <version> > dev_sources.nix")
+    exit(-1)
+  else
+    ARGV[0]
+  end
+
+base_url = "http://download-installer.cdn.mozilla.net/pub/firefox/nightly/latest-mozilla-aurora"
+
+arches = ["linux-i686", "linux-x86_64"]
+locales = ["en-US"]
+sources = []
+
+Source = Struct.new(:hash, :arch, :locale, :filename)
+
+locales.each do |locale|
+  arches.each do |arch|
+    basename = "firefox-#{version}.#{locale}.#{arch}"
+    filename = basename + ".tar.bz2"
+    sha512 = open("#{base_url}/#{basename}.checksums").each_line
+      .find(filename).first
+      .split(" ").first
+    sources << Source.new(sha512, arch, locale, filename)
+  end
+end
+
+sources = sources.sort_by do |source|
+  [source.locale, source.arch]
+end
+
+puts(<<"EOH")
+# This file is generated from generate_sources_dev.rb. DO NOT EDIT.
+# Execute the following command to update the file.
+#
+# ruby generate_sources_dev.rb 49.0a2 > dev_sources.nix
+
+{
+  version = "#{version}";
+  sources = [
+EOH
+
+sources.each do |source|
+  puts(%Q|    { locale = "#{source.locale}"; arch = "#{source.arch}"; sha512 = "#{source.hash}"; }|)
+end
+
+puts(<<'EOF')
+  ];
+}
+EOF
diff --git a/pkgs/applications/networking/browsers/mozilla-plugins/bluejeans/default.nix b/pkgs/applications/networking/browsers/mozilla-plugins/bluejeans/default.nix
index 147540ed158d..574fd9efdd42 100644
--- a/pkgs/applications/networking/browsers/mozilla-plugins/bluejeans/default.nix
+++ b/pkgs/applications/networking/browsers/mozilla-plugins/bluejeans/default.nix
@@ -17,11 +17,11 @@ in
 stdenv.mkDerivation rec {
   name = "bluejeans-${version}";
 
-  version = "2.160.49.8";
+  version = "2.160.63.8";
 
   src = fetchurl {
     url = "https://swdl.bluejeans.com/skinny/bjnplugin_${version}-1_amd64.deb";
-    sha256 = "1hf4jx0d1wiv622rwck0mm8cckm121yszviw47jsw0mjnp91hqch";
+    sha256 = "1sfz9xvvrbw7gg7fxxwg9wmgbxgv3fa14p7i4m85mg10l3qxaqfc";
   };
 
   phases = [ "unpackPhase" "installPhase" "fixupPhase" ];
diff --git a/pkgs/applications/networking/ftp/filezilla/default.nix b/pkgs/applications/networking/ftp/filezilla/default.nix
index 4b7b56c69eaf..5d92f7455d62 100644
--- a/pkgs/applications/networking/ftp/filezilla/default.nix
+++ b/pkgs/applications/networking/ftp/filezilla/default.nix
@@ -1,13 +1,13 @@
 { stdenv, fetchurl, dbus, gnutls, wxGTK30, libidn, tinyxml, gettext
 , pkgconfig, xdg_utils, gtk2, sqlite, pugixml, libfilezilla, nettle }:
 
-let version = "3.18.0"; in
+let version = "3.19.0"; in
 stdenv.mkDerivation {
   name = "filezilla-${version}";
 
   src = fetchurl {
     url = "mirror://sourceforge/project/filezilla/FileZilla_Client/${version}/FileZilla_${version}_src.tar.bz2";
-    sha256 = "1qnpbx2684r529ldih6fi5anjlcgqn2xfcls0q38iadrk1qnqr1p";
+    sha256 = "0827z1jmn8pkzrcpjgh5yh2r23vgv73yb4rikraxa9i7l118g9l2";
   };
 
   configureFlags = [
diff --git a/pkgs/applications/networking/instant-messengers/zoom-us/default.nix b/pkgs/applications/networking/instant-messengers/zoom-us/default.nix
new file mode 100644
index 000000000000..7f4a27cf9a23
--- /dev/null
+++ b/pkgs/applications/networking/instant-messengers/zoom-us/default.nix
@@ -0,0 +1,105 @@
+{ alsaLib
+, fetchurl
+, gcc
+, glib
+, gst_plugins_base
+, gstreamer
+, icu_54_1
+, libpulseaudio
+, libuuid
+, libxml2
+, libxslt
+, makeQtWrapper
+, qt55
+, sqlite
+, stdenv
+, xlibs
+, xorg
+, zlib
+}:
+
+stdenv.mkDerivation rec {
+    name = "zoom-us";
+    meta = {
+      homepage = http://zoom.us;
+      description = "zoom.us instant messenger";
+      license = stdenv.lib.licenses.unfree;
+      platforms = stdenv.lib.platforms.linux;
+    };
+
+    version = "2.0.52458.0531";
+    src = fetchurl {
+      url = "https://zoom.us/client/latest/zoom_${version}_x86_64.tar.xz";
+      sha256 = "16d64pn9j27v3fnh4c9i32vpkr10q1yr26w14964n0af1mv5jf7a";
+    };
+
+    phases = [ "unpackPhase" "installPhase" ];
+    nativeBuildInputs = [ makeQtWrapper ];
+    libPath = stdenv.lib.makeLibraryPath [
+      alsaLib
+      gcc.cc
+      glib
+      gst_plugins_base
+      gstreamer
+      icu_54_1
+      libpulseaudio
+      libuuid
+      libxml2
+      libxslt
+      qt55.qtbase
+      qt55.qtdeclarative
+      qt55.qtscript
+      qt55.qtwebkit
+      sqlite
+      xlibs.xcbutilkeysyms
+      xorg.libX11
+      xorg.libxcb
+      xorg.libXcomposite
+      xorg.libXext
+      xorg.libXfixes
+      xorg.libXrender
+      xorg.xcbutilimage
+      zlib
+    ];
+    installPhase = ''
+      mkdir -p $out/share
+      cp -r \
+         application-x-zoom.png \
+         audio \
+         imageformats \
+         chrome.bmp \
+         config-dump.sh \
+         dingdong1.pcm \
+         dingdong.pcm \
+         doc \
+         Droplet.pcm \
+         Droplet.wav \
+         platforminputcontexts \
+         platforms \
+         platformthemes \
+         Qt \
+         QtMultimedia \
+         QtQml \
+         QtQuick \
+         QtQuick.2 \
+         QtWebKit \
+         QtWebProcess \
+         ring.pcm \
+         ring.wav \
+         version.txt \
+         xcbglintegrations \
+         zcacert.pem \
+         zoom \
+         Zoom.png \
+         ZXMPPROOT.cer \
+         $out/share
+
+      patchelf \
+        --set-interpreter $(cat $NIX_CC/nix-support/dynamic-linker) \
+        --set-rpath ${libPath} \
+        $out/share/zoom
+      wrapQtProgram "$out/share/zoom"
+      mkdir -p $out/bin
+      ln -s $out/share/zoom $out/bin/zoom-us
+    '';
+ }
diff --git a/pkgs/applications/networking/sniffers/wireshark/default.nix b/pkgs/applications/networking/sniffers/wireshark/default.nix
index 0febee720967..bf7c8f752450 100644
--- a/pkgs/applications/networking/sniffers/wireshark/default.nix
+++ b/pkgs/applications/networking/sniffers/wireshark/default.nix
@@ -11,7 +11,7 @@ assert withQt -> !withGtk && qt4 != null;
 with stdenv.lib;
 
 let
-  version = "2.0.3";
+  version = "2.0.4";
   variant = if withGtk then "gtk" else if withQt then "qt" else "cli";
 in
 
@@ -20,7 +20,7 @@ stdenv.mkDerivation {
 
   src = fetchurl {
     url = "http://www.wireshark.org/download/src/all-versions/wireshark-${version}.tar.bz2";
-    sha256 = "1z358k65frp9m0l07cppwxhvbcp1w9ya5sml87pzs8gyfmp3g5p1";
+    sha256 = "19g11m8m8qd7dkcvcb27lyppklg608d9ap7wr3mr88clm4nwiacy";
   };
 
   buildInputs = [
diff --git a/pkgs/applications/video/mkvtoolnix/default.nix b/pkgs/applications/video/mkvtoolnix/default.nix
index 4eeb733d9786..69e52065419a 100644
--- a/pkgs/applications/video/mkvtoolnix/default.nix
+++ b/pkgs/applications/video/mkvtoolnix/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchgit, pkgconfig, autoconf, automake
+{ stdenv, fetchFromGitHub, pkgconfig, autoconf, automake
 , ruby, file, xdg_utils, gettext, expat, qt5, boost
 , libebml, zlib, libmatroska, libogg, libvorbis, flac
 , withGUI ? true
@@ -10,18 +10,19 @@ with stdenv.lib;
 
 stdenv.mkDerivation rec {
   name = "mkvtoolnix-${version}";
-  version = "8.9.0";
+  version = "9.2.0";
 
-  src = fetchgit {
-    url = "https://github.com/mbunkus/mkvtoolnix.git";
-    rev = "54e6b52b3dde07f89da4542997ef059e18802128";
-    sha256 = "1gipydk1xisqy110rr38dgjzpxl8zxbm12kf7b2f4xh4iw17j0k2";
+  src = fetchFromGitHub {
+    owner = "mbunkus";
+    repo = "mkvtoolnix";
+    rev = "release-${version}";
+    sha256 = "02w3161iqaijs3bz5w2wily9nz55xnhq1bdm2s5qi8v3sbcqd6df";
   };
 
-  nativeBuildInputs = [ gettext ruby ];
+  nativeBuildInputs = [ pkgconfig autoconf automake gettext ruby ];
 
   buildInputs = [
-    pkgconfig autoconf automake expat
+    expat
     file xdg_utils boost libebml zlib
     libmatroska libogg libvorbis flac
     (optional withGUI qt5.qtbase)
diff --git a/pkgs/applications/video/recordmydesktop/default.nix b/pkgs/applications/video/recordmydesktop/default.nix
index 95c06d54d6e6..54dc88b452e6 100644
--- a/pkgs/applications/video/recordmydesktop/default.nix
+++ b/pkgs/applications/video/recordmydesktop/default.nix
@@ -1,18 +1,23 @@
-{ stdenv, fetchsvn, automake, autoconf, zlib, popt, xorg, libvorbis, libtheora }:
+{ stdenv, fetchsvn, autoreconfHook, zlib, popt, alsaLib, libvorbis, libtheora
+, libICE, libSM, libX11, libXext, libXfixes, libXdamage }:
 
 stdenv.mkDerivation rec {
   name = "recordmydesktop-${version}";
-  version = "0.3.8.1-svn602";
+  version = "0.3.8.1-svn${rev}";
+  rev = "602";
 
   src = fetchsvn {
     url = https://recordmydesktop.svn.sourceforge.net/svnroot/recordmydesktop/trunk/recordmydesktop;
-    rev = 602;
+    inherit rev;
     sha256 = "1avirkc4ymrd575m616pi6wpgq1i0r5sb3qahps1g18sjpxks0lf";
   };
 
-  buildInputs = [ automake autoconf zlib popt xorg.libICE xorg.libSM xorg.libX11 xorg.libXext xorg.libXfixes xorg.libXdamage libvorbis libtheora ];
+  nativeBuildInputs = [ autoreconfHook ];
 
-  preConfigure = ''./autogen.sh'';
+  buildInputs = [
+    zlib popt alsaLib libICE libSM libX11 libXext
+    libXfixes libXdamage libvorbis libtheora
+  ];
 
   meta = with stdenv.lib; {
     description = "Desktop session recorder";
diff --git a/pkgs/applications/video/recordmydesktop/gtk.nix b/pkgs/applications/video/recordmydesktop/gtk.nix
new file mode 100644
index 000000000000..f3bf714b9417
--- /dev/null
+++ b/pkgs/applications/video/recordmydesktop/gtk.nix
@@ -0,0 +1,37 @@
+{ stdenv, lib, fetchsvn, recordmydesktop, autoreconfHook, pkgconfig, glib
+, pythonPackages, jack2, xwininfo }:
+
+let
+  binPath = lib.makeBinPath [ recordmydesktop jack2 xwininfo ];
+
+in stdenv.mkDerivation rec {
+  name = "gtk-recordmydesktop-${version}";
+  version = "0.3.8-svn${recordmydesktop.rev}";
+
+  src = fetchsvn {
+    url = https://recordmydesktop.svn.sourceforge.net/svnroot/recordmydesktop/trunk/gtk-recordmydesktop;
+    inherit (recordmydesktop) rev;
+    sha256 = "010aykgjfxhyiixq9a9fg3p1a1ixz59m1vkn16hpy0lybgf4dsby";
+  };
+
+  nativeBuildInputs = [ autoreconfHook pkgconfig ];
+
+  buildInputs = with pythonPackages; [
+    python pygtk wrapPython
+  ];
+
+  pythonPath = with pythonPackages; [ pygtk ];
+
+  postInstall = ''
+    makeWrapperArgs="--prefix PATH : ${binPath}"
+    wrapPythonPrograms
+  '';
+
+  meta = with stdenv.lib; {
+    description = "GTK frontend for recordmydesktop";
+    homepage = http://recordmydesktop.sourceforge.net/;
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.DamienCassou ];
+  };
+}
diff --git a/pkgs/applications/video/recordmydesktop/qt.nix b/pkgs/applications/video/recordmydesktop/qt.nix
new file mode 100644
index 000000000000..de372c905bdb
--- /dev/null
+++ b/pkgs/applications/video/recordmydesktop/qt.nix
@@ -0,0 +1,37 @@
+{ stdenv, lib, fetchsvn, recordmydesktop, autoreconfHook, pkgconfig
+, glib, pythonPackages, qt4, jack2, xwininfo }:
+
+let
+  binPath = lib.makeBinPath [ recordmydesktop jack2 xwininfo ];
+
+in stdenv.mkDerivation rec {
+  name = "qt-recordmydesktop-${version}";
+  version = "0.3.8-svn${recordmydesktop.rev}";
+
+  src = fetchsvn {
+    url = https://recordmydesktop.svn.sourceforge.net/svnroot/recordmydesktop/trunk/qt-recordmydesktop;
+    inherit (recordmydesktop) rev;
+    sha256 = "0vz7amrmz317sbx2cv2186d0r57as4l26xa9rpim5gbvzk20caqc";
+  };
+
+  nativeBuildInputs = [ autoreconfHook pkgconfig ];
+
+  buildInputs = [ glib qt4 ] ++ (with pythonPackages; [
+    python wrapPython pyqt4
+  ]);
+
+  pythonPath = with pythonPackages; [ pyqt4 ];
+
+  postInstall = ''
+    makeWrapperArgs="--prefix PATH : ${binPath}"
+    wrapPythonPrograms
+  '';
+
+  meta = with stdenv.lib; {
+    description = "GTK frontend for recordmydesktop";
+    homepage = http://recordmydesktop.sourceforge.net/;
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.DamienCassou ];
+  };
+}
diff --git a/pkgs/applications/video/simplescreenrecorder/default.nix b/pkgs/applications/video/simplescreenrecorder/default.nix
index 3ea04a39393b..f50a41129adb 100644
--- a/pkgs/applications/video/simplescreenrecorder/default.nix
+++ b/pkgs/applications/video/simplescreenrecorder/default.nix
@@ -11,7 +11,18 @@ stdenv.mkDerivation rec {
     sha256 = "1d89ncspjd8c4mckf0nb6y3hrxpv4rjpbj868pznhvfmdgr5nvql";
   };
 
-  postPatch = "sed '1i#include <random>' -i src/Benchmark.cpp";
+  patches = [ ./fix-paths.patch ];
+
+  postPatch = ''
+    # #455
+    sed '1i#include <random>' -i src/Benchmark.cpp
+
+    for i in scripts/ssr-glinject src/AV/Input/GLInjectInput.cpp; do
+      substituteInPlace $i \
+        --subst-var out \
+        --subst-var-by sh ${stdenv.shell}
+    done
+  '';
 
   buildInputs = [
     alsaLib ffmpeg libjack2 libX11 libXext libXfixes mesa pkgconfig
diff --git a/pkgs/applications/video/simplescreenrecorder/fix-paths.patch b/pkgs/applications/video/simplescreenrecorder/fix-paths.patch
new file mode 100644
index 000000000000..ba02240ce1f2
--- /dev/null
+++ b/pkgs/applications/video/simplescreenrecorder/fix-paths.patch
@@ -0,0 +1,35 @@
+diff --git a/scripts/ssr-glinject b/scripts/ssr-glinject
+index 48be48d..5038d4c 100755
+--- a/scripts/ssr-glinject
++++ b/scripts/ssr-glinject
+@@ -59,6 +59,6 @@ do
+ 	fi
+ done
+ 
+-echo "ssr-glinject: LD_PRELOAD = $LD_PRELOAD:libssr-glinject.so"
++echo "ssr-glinject: LD_PRELOAD = $LD_PRELOAD:@out@/lib/libssr-glinject.so"
+ echo "ssr-glinject: command = $@"
+-LD_PRELOAD="$LD_PRELOAD:libssr-glinject.so" "$@"
++LD_PRELOAD="$LD_PRELOAD:@out@/lib/libssr-glinject.so" "$@"
+diff --git a/src/AV/Input/GLInjectInput.cpp b/src/AV/Input/GLInjectInput.cpp
+index 6b378f8..cbcf82b 100644
+--- a/src/AV/Input/GLInjectInput.cpp
++++ b/src/AV/Input/GLInjectInput.cpp
+@@ -96,7 +96,7 @@ void GLInjectInput::SetCapturing(bool capturing) {
+ bool GLInjectInput::LaunchApplication(const QString& channel, bool relax_permissions, const QString& command, const QString& working_directory) {
+ 
+ 	// prepare command
+-	QString full_command = "LD_PRELOAD=\"libssr-glinject.so\" ";
++	QString full_command = "LD_PRELOAD=\"@out@/lib/libssr-glinject.so\" ";
+ 	full_command += "SSR_CHANNEL=\"" + ShellEscape(channel) + "\" ";
+ 	if(relax_permissions)
+ 		full_command += "SSR_STREAM_RELAX_PERMISSIONS=1 ";
+@@ -106,7 +106,7 @@ bool GLInjectInput::LaunchApplication(const QString& channel, bool relax_permiss
+ 	QStringList args;
+ 	args.push_back("-c");
+ 	args.push_back(full_command);
+-	return QProcess::startDetached("/bin/sh", args, working_directory);
++	return QProcess::startDetached("@sh@", args, working_directory);
+ 
+ }
+ 
diff --git a/pkgs/applications/video/vlc/default.nix b/pkgs/applications/video/vlc/default.nix
index 3f883694e088..3cc4c310ed52 100644
--- a/pkgs/applications/video/vlc/default.nix
+++ b/pkgs/applications/video/vlc/default.nix
@@ -20,11 +20,11 @@ assert (!withQt5 -> qt4 != null);
 
 stdenv.mkDerivation rec {
   name = "vlc-${version}";
-  version = "2.2.3";
+  version = "2.2.4";
 
   src = fetchurl {
     url = "http://get.videolan.org/vlc/${version}/${name}.tar.xz";
-    sha256 = "0nxzspnyzlm17imlggi8ypnwiizi0f5wrj3436c3qg7i6mymimxr";
+    sha256 = "1gjkrwlg8ab3skzl67cxb9qzg4187ifckd1z9kpy11q058fyjchn";
   };
 
   # Comment-out the Qt 5.5 version check, as we do apply the relevant patch.
diff --git a/pkgs/applications/window-managers/i3/lock.nix b/pkgs/applications/window-managers/i3/lock.nix
index 56e0643811fa..d9ea14828ddd 100644
--- a/pkgs/applications/window-managers/i3/lock.nix
+++ b/pkgs/applications/window-managers/i3/lock.nix
@@ -2,11 +2,11 @@
   pam, libX11, libev, cairo, libxkbcommon, libxkbfile }:
 
 stdenv.mkDerivation rec {
-  name = "i3lock-2.7";
+  name = "i3lock-2.8";
 
   src = fetchurl {
     url = "http://i3wm.org/i3lock/${name}.tar.bz2";
-    sha256 = "1qlgafbyqjpqdfs50f2y0xphn2jdigafkqqsmpikk97cs0z1i0k8";
+    sha256 = "028fc0f74df10826514d5a4ed38f6895935d1f5d47ca9fcffc64b076aaf6e2f4";
   };
 
   buildInputs = [ which pkgconfig libxcb xcbutilkeysyms xcbutilimage pam libX11