about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/emacs-24/macport-24.5.nix4
-rw-r--r--pkgs/applications/editors/heme/default.nix2
-rw-r--r--pkgs/applications/science/logic/saw-tools/default.nix2
3 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/applications/editors/emacs-24/macport-24.5.nix b/pkgs/applications/editors/emacs-24/macport-24.5.nix
index ae0a66b30fee..23133ec262c3 100644
--- a/pkgs/applications/editors/emacs-24/macport-24.5.nix
+++ b/pkgs/applications/editors/emacs-24/macport-24.5.nix
@@ -40,7 +40,7 @@ stdenv.mkDerivation rec {
   '';
 
   configureFlags = [
-    "LDFLAGS=-L${ncurses.lib}/lib"
+    "LDFLAGS=-L${ncurses.out}/lib"
     "--with-xml2=yes"
     "--with-gnutls=yes"
     "--with-mac"
@@ -48,7 +48,7 @@ stdenv.mkDerivation rec {
   ];
 
   CFLAGS = "-O3";
-  LDFLAGS = "-O3 -L${ncurses.lib}/lib";
+  LDFLAGS = "-O3 -L${ncurses.out}/lib";
 
   postInstall = ''
     mkdir -p $out/share/emacs/site-lisp/
diff --git a/pkgs/applications/editors/heme/default.nix b/pkgs/applications/editors/heme/default.nix
index 9ced023988cc..c74e47a5243d 100644
--- a/pkgs/applications/editors/heme/default.nix
+++ b/pkgs/applications/editors/heme/default.nix
@@ -11,7 +11,7 @@ stdenv.mkDerivation rec {
     substituteInPlace Makefile \
       --replace "/usr/local" "$out" \
       --replace "CFLAGS = " "CFLAGS = -I${ncurses.dev}/include " \
-      --replace "LDFLAGS = " "LDFLAGS = -L${ncurses.lib}/lib " \
+      --replace "LDFLAGS = " "LDFLAGS = -L${ncurses.out}/lib " \
       --replace "-lcurses" "-lncurses"
   '';
   buildInputs = [ ncurses ];
diff --git a/pkgs/applications/science/logic/saw-tools/default.nix b/pkgs/applications/science/logic/saw-tools/default.nix
index 97a06bf093d3..1153c0b3cf5c 100644
--- a/pkgs/applications/science/logic/saw-tools/default.nix
+++ b/pkgs/applications/science/logic/saw-tools/default.nix
@@ -35,7 +35,7 @@ stdenv.mkDerivation rec {
     mv doc $out/share
 
     # Hack around lack of libtinfo in NixOS
-    ln -s ${ncurses.lib}/lib/libncursesw.so.5       $out/lib/libtinfo.so.5
+    ln -s ${ncurses.out}/lib/libncursesw.so.5       $out/lib/libtinfo.so.5
     ln -s ${stdenv.cc.libc}/lib/libpthread.so.0 $out/lib/libpthread.so.0
 
     # Add a clang symlink for easy building with a suitable compiler.