about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/graphics/gqview/default.nix2
-rw-r--r--pkgs/applications/networking/browsers/firefox/default.nix4
-rw-r--r--pkgs/applications/video/MPlayer/default.nix4
-rw-r--r--pkgs/applications/video/mplayerplug-in/default.nix2
-rw-r--r--pkgs/applications/video/vlc/default.nix6
-rw-r--r--pkgs/applications/video/zapping/default.nix12
6 files changed, 15 insertions, 15 deletions
diff --git a/pkgs/applications/graphics/gqview/default.nix b/pkgs/applications/graphics/gqview/default.nix
index b507c67b5f53..2fd40e983b60 100644
--- a/pkgs/applications/graphics/gqview/default.nix
+++ b/pkgs/applications/graphics/gqview/default.nix
@@ -1,6 +1,6 @@
 {stdenv, fetchurl, pkgconfig, gtk, libpng}:
 
-assert !isNull pkgconfig && !isNull gtk && !isNull libpng;
+assert pkgconfig != null && gtk != null && libpng != null;
 # Note that we cannot just copy gtk's png attribute, since gtk might
 # not be linked against png.
 assert libpng == gtk.libpng;
diff --git a/pkgs/applications/networking/browsers/firefox/default.nix b/pkgs/applications/networking/browsers/firefox/default.nix
index 9c7a434c63b4..aaee20e74814 100644
--- a/pkgs/applications/networking/browsers/firefox/default.nix
+++ b/pkgs/applications/networking/browsers/firefox/default.nix
@@ -1,8 +1,8 @@
 { stdenv, fetchurl, pkgconfig, gtk, perl, zip, libIDL
 }:
 
-assert !isNull pkgconfig && !isNull gtk && !isNull perl
-  && !isNull zip && !isNull libIDL;
+assert pkgconfig != null && gtk != null && perl != null
+  && zip != null && libIDL != null;
 
 assert libIDL.glib == gtk.glib;
 
diff --git a/pkgs/applications/video/MPlayer/default.nix b/pkgs/applications/video/MPlayer/default.nix
index d2b089bbb85f..a064162d8804 100644
--- a/pkgs/applications/video/MPlayer/default.nix
+++ b/pkgs/applications/video/MPlayer/default.nix
@@ -1,8 +1,8 @@
 { alsaSupport ? false
 , stdenv, fetchurl, x11, freetype, alsa ? null}:
 
-assert !isNull x11 && !isNull freetype;
-assert alsaSupport -> !isNull alsa;
+assert x11 != null && freetype != null;
+assert alsaSupport -> alsa != null;
 
 derivation {
   name = "MPlayer-1.0pre3";
diff --git a/pkgs/applications/video/mplayerplug-in/default.nix b/pkgs/applications/video/mplayerplug-in/default.nix
index c06fc31fee42..5337325e4269 100644
--- a/pkgs/applications/video/mplayerplug-in/default.nix
+++ b/pkgs/applications/video/mplayerplug-in/default.nix
@@ -1,6 +1,6 @@
 {stdenv, fetchurl, x11}:
 
-assert !isNull x11;
+assert x11 != null;
 
 derivation {
   name = "mplayerplug-in-1.0pre2";
diff --git a/pkgs/applications/video/vlc/default.nix b/pkgs/applications/video/vlc/default.nix
index da48bc7e46c0..3776f5a23844 100644
--- a/pkgs/applications/video/vlc/default.nix
+++ b/pkgs/applications/video/vlc/default.nix
@@ -1,9 +1,9 @@
 { stdenv, fetchurl, x11, wxGTK, libdvdcss, libdvdplay
 , mpeg2dec, a52dec, libmad, alsa}:
 
-assert !isNull x11 && !isNull wxGTK && !isNull libdvdcss
-  && !isNull libdvdplay && !isNull mpeg2dec && !isNull a52dec
-  && !isNull libmad && !isNull alsa;
+assert x11 != null && wxGTK != null && libdvdcss != null
+  && libdvdplay != null && mpeg2dec != null && a52dec != null
+  && libmad != null && alsa != null;
 assert libdvdplay.libdvdread.libdvdcss == libdvdcss;
 
 derivation {
diff --git a/pkgs/applications/video/zapping/default.nix b/pkgs/applications/video/zapping/default.nix
index 613053bd8102..809ca969d801 100644
--- a/pkgs/applications/video/zapping/default.nix
+++ b/pkgs/applications/video/zapping/default.nix
@@ -5,15 +5,15 @@
 , libglade, scrollkeeper, esound, gettext
 , zvbi ? null, libjpeg ? null, libpng ? null }:
 
-assert !isNull pkgconfig && !isNull perl && !isNull python &&
-  !isNull x11 && !isNull libgnomeui && !isNull libglade &&
-  !isNull scrollkeeper && !isNull esound && !isNull gettext;
+assert pkgconfig != null && perl != null && python != null &&
+  x11 != null && libgnomeui != null && libglade != null &&
+  scrollkeeper != null && esound != null && gettext != null;
 
-assert teletextSupport -> !isNull zvbi && zvbi.pngSupport
+assert teletextSupport -> zvbi != null && zvbi.pngSupport
   && pngSupport && zvbi.libpng == libpng;
 
-assert jpegSupport -> !isNull libjpeg;
-assert pngSupport -> !isNull libpng;
+assert jpegSupport -> libjpeg != null;
+assert pngSupport -> libpng != null;
 
 derivation {
   name = "zapping-0.7cvs6";