about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/ncmpc/default.nix2
-rw-r--r--pkgs/applications/editors/android-studio/default.nix6
-rw-r--r--pkgs/applications/editors/vim/common.nix4
-rw-r--r--pkgs/applications/networking/browsers/firefox/common.nix28
-rw-r--r--pkgs/applications/virtualization/looking-glass-client/default.nix47
-rw-r--r--pkgs/applications/window-managers/qtile/0001-Substitution-vars-for-absolute-paths.patch21
-rw-r--r--pkgs/applications/window-managers/qtile/0002-Restore-PATH-and-PYTHONPATH.patch75
-rw-r--r--pkgs/applications/window-managers/qtile/0003-Restart-executable.patch18
-rw-r--r--pkgs/applications/window-managers/qtile/default.nix4
9 files changed, 119 insertions, 86 deletions
diff --git a/pkgs/applications/audio/ncmpc/default.nix b/pkgs/applications/audio/ncmpc/default.nix
index 1b865642178f..93e909fc604b 100644
--- a/pkgs/applications/audio/ncmpc/default.nix
+++ b/pkgs/applications/audio/ncmpc/default.nix
@@ -15,6 +15,8 @@ stdenv.mkDerivation rec {
   buildInputs = [ glib ncurses mpd_clientlib ];
   nativeBuildInputs = [ meson ninja pkgconfig gettext ];
 
+  NIX_LDFLAGS = stdenv.lib.optionalString stdenv.isDarwin "-lintl";
+
   meta = with stdenv.lib; {
     description = "Curses-based interface for MPD (music player daemon)";
     homepage    = https://www.musicpd.org/clients/ncmpc/;
diff --git a/pkgs/applications/editors/android-studio/default.nix b/pkgs/applications/editors/android-studio/default.nix
index 86faeeb05334..4cd0553e4d2e 100644
--- a/pkgs/applications/editors/android-studio/default.nix
+++ b/pkgs/applications/editors/android-studio/default.nix
@@ -27,9 +27,9 @@ in rec {
 
   preview = mkStudio {
     pname = "android-studio-preview";
-    version = "3.1.0.8"; # "Android Studio 3.1 Canary 9"
-    build = "173.4559767";
-    sha256Hash = "0wy3bqd4wvvcwlqcv06mwlqgc119pjpc102ix3yacqvki9qyi1r0";
+    version = "3.1.0.9"; # "Android Studio 3.1 Beta 1"
+    build = "173.4567466";
+    sha256Hash = "01c6a46pk5zbhwk2w038nm68fkx86nafiw1v2i5rdr93mxvx9cag";
 
     meta = stable.meta // {
       description = "The Official IDE for Android (preview version)";
diff --git a/pkgs/applications/editors/vim/common.nix b/pkgs/applications/editors/vim/common.nix
index 21b0f7a85d2c..5155f94eef52 100644
--- a/pkgs/applications/editors/vim/common.nix
+++ b/pkgs/applications/editors/vim/common.nix
@@ -1,12 +1,12 @@
 { lib, fetchFromGitHub }:
 rec {
-  version = "8.0.1428";
+  version = "8.0.1451";
 
   src = fetchFromGitHub {
     owner = "vim";
     repo = "vim";
     rev = "v${version}";
-    sha256 = "0pqqh7g96w8jfc5kvv2il6fcbhccwhk4k5skk52g1c1ixsblwz3y";
+    sha256 = "1vxd5mr8c62qyf7ax7gi2wka48282yplckq91154yd55xcqw36zx";
   };
 
   enableParallelBuilding = true;
diff --git a/pkgs/applications/networking/browsers/firefox/common.nix b/pkgs/applications/networking/browsers/firefox/common.nix
index 0d72b8e55eeb..91b86a18375c 100644
--- a/pkgs/applications/networking/browsers/firefox/common.nix
+++ b/pkgs/applications/networking/browsers/firefox/common.nix
@@ -38,12 +38,25 @@
 
 ## other
 
-# If you want the resulting program to call itself
-# "Firefox"/"Torbrowser" instead of "Nightly" or whatever, enable this
-# option. However, in Firefox's case, those binaries may not be
-# distributed without permission from the Mozilla Foundation, see
-# http://www.mozilla.org/foundation/trademarks/.
-, enableOfficialBranding ? isTorBrowserLike
+# As stated by Sylvestre Ledru (@sylvestre) on Nov 22, 2017 at
+# https://github.com/NixOS/nixpkgs/issues/31843#issuecomment-346372756 we
+# have permission to use the official firefox branding.
+#
+# Fur purposes of documentation the statement of @sylvestre:
+# > As the person who did part of the work described in the LWN article
+# > and release manager working for Mozilla, I can confirm the statement
+# > that I made in
+# > https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815006
+# >
+# > @garbas shared with me the list of patches applied for the Nix package.
+# > As they are just for portability and tiny modifications, they don't
+# > alter the experience of the product. In parallel, Rok also shared the
+# > build options. They seem good (even if I cannot judge the quality of the
+# > packaging of the underlying dependencies like sqlite, png, etc).
+# > Therefor, as long as you keep the patch queue sane and you don't alter
+# > the experience of Firefox users, you won't have any issues using the
+# > official branding.
+, enableOfficialBranding ? true
 }:
 
 assert stdenv.cc ? libc && stdenv.cc.libc != null;
@@ -91,12 +104,14 @@ stdenv.mkDerivation (rec {
  '' + lib.optionalString (stdenv.lib.versionAtLeast version "58.0.0") ''
     cat >.mozconfig <<END_MOZCONFIG
     ${lib.concatStringsSep "\n" (map (flag: "ac_add_options ${flag}") configureFlags)}
+    ${lib.optionalString googleAPISupport "ac_add_options --with-google-api-keyfile=$TMPDIR/ga"}
     END_MOZCONFIG
   '' + lib.optionalString googleAPISupport ''
     # Google API key used by Chromium and Firefox.
     # Note: These are for NixOS/nixpkgs use ONLY. For your own distribution,
     # please get your own set of keys.
     echo "AIzaSyDGi15Zwl11UNe6Y-5XW_upsfyw31qwZPI" > $TMPDIR/ga
+    configureFlagsArray+=("--with-google-api-keyfile=$TMPDIR/ga")
   '' + ''
     # this will run autoconf213
     ${if (stdenv.lib.versionAtLeast version "58.0.0") then "./mach configure" else "make -f client.mk configure-files"}
@@ -171,7 +186,6 @@ stdenv.mkDerivation (rec {
   ++ flag gssSupport "negotiateauth"
   ++ lib.optional (!ffmpegSupport) "--disable-gstreamer"
   ++ flag webrtcSupport "webrtc"
-  ++ lib.optional googleAPISupport "--with-google-api-keyfile=$TMPDIR/ga"
   ++ flag crashreporterSupport "crashreporter"
   ++ lib.optional drmSupport "--enable-eme=widevine"
 
diff --git a/pkgs/applications/virtualization/looking-glass-client/default.nix b/pkgs/applications/virtualization/looking-glass-client/default.nix
new file mode 100644
index 000000000000..16be0cc5b6d2
--- /dev/null
+++ b/pkgs/applications/virtualization/looking-glass-client/default.nix
@@ -0,0 +1,47 @@
+{ stdenv, fetchFromGitHub
+, pkgconfig, SDL2, SDL, SDL2_ttf, openssl, spice_protocol, fontconfig
+, libX11, freefont_ttf
+}:
+
+stdenv.mkDerivation rec {
+  name = "looking-glass-client-${version}";
+  version = "a10";
+
+  src = fetchFromGitHub {
+    owner = "gnif";
+    repo = "LookingGlass";
+    rev = version;
+    sha256 = "10jxnkrvskjzkg86iz3hnb5v91ykzx6pvcnpy1v4436g5f2d62wn";
+  };
+
+  nativeBuildInputs = [ pkgconfig ];
+
+  buildInputs = [
+    SDL SDL2 SDL2_ttf openssl spice_protocol fontconfig
+    libX11 freefont_ttf
+  ];
+
+  enableParallelBuilding = true;
+
+  sourceRoot = "source/client";
+
+  installPhase = ''
+    mkdir -p $out
+    mv bin $out/
+  '';
+
+  meta = with stdenv.lib; {
+    description = "A KVM Frame Relay (KVMFR) implementation";
+    longDescription = ''
+      Looking Glass is an open source application that allows the use of a KVM
+      (Kernel-based Virtual Machine) configured for VGA PCI Pass-through
+      without an attached physical monitor, keyboard or mouse. This is the final
+      step required to move away from dual booting with other operating systems
+      for legacy programs that require high performance graphics.
+    '';
+    homepage = https://looking-glass.hostfission.com/;
+    license = licenses.gpl2Plus;
+    maintainers = [ maintainers.pneumaticat ];
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/applications/window-managers/qtile/0001-Substitution-vars-for-absolute-paths.patch b/pkgs/applications/window-managers/qtile/0001-Substitution-vars-for-absolute-paths.patch
index e3c88a5fa551..71d3d9cafaa3 100644
--- a/pkgs/applications/window-managers/qtile/0001-Substitution-vars-for-absolute-paths.patch
+++ b/pkgs/applications/window-managers/qtile/0001-Substitution-vars-for-absolute-paths.patch
@@ -1,15 +1,5 @@
-From 00c5af939567429d40877845dc52b54fde2d8a50 Mon Sep 17 00:00:00 2001
-From: "Alexander V. Nikolaev" <avn@avnik.info>
-Date: Thu, 26 Nov 2015 10:53:12 +0200
-Subject: [PATCH 1/3] Substitution vars for absolute paths
-
----
- libqtile/pangocffi.py | 6 +++---
- libqtile/xcursors.py  | 2 +-
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
 diff --git a/libqtile/pangocffi.py b/libqtile/pangocffi.py
-index 27691d1..25f690d 100644
+index 1e8f5c04..e860d43a 100644
 --- a/libqtile/pangocffi.py
 +++ b/libqtile/pangocffi.py
 @@ -58,9 +58,9 @@ except ImportError:
@@ -26,18 +16,15 @@ index 27691d1..25f690d 100644
  
  def CairoContext(cairo_t):
 diff --git a/libqtile/xcursors.py b/libqtile/xcursors.py
-index e0e55e1..59b6428 100644
+index f1133555..3e61204a 100644
 --- a/libqtile/xcursors.py
 +++ b/libqtile/xcursors.py
-@@ -114,7 +114,7 @@ class Cursors(dict):
+@@ -112,7 +112,7 @@ class Cursors(dict):
  
      def _setup_xcursor_binding(self):
          try:
 -            xcursor = ffi.dlopen('libxcb-cursor.so')
 +            xcursor = ffi.dlopen('@xcb-cursor@/lib/libxcb-cursor.so')
          except OSError:
-             self.log.warning("xcb-cursor not found, fallback to font pointer")
+             logger.warning("xcb-cursor not found, fallback to font pointer")
              return False
--- 
-2.6.3
-
diff --git a/pkgs/applications/window-managers/qtile/0002-Restore-PATH-and-PYTHONPATH.patch b/pkgs/applications/window-managers/qtile/0002-Restore-PATH-and-PYTHONPATH.patch
index b620bfb25014..7d184838fbaa 100644
--- a/pkgs/applications/window-managers/qtile/0002-Restore-PATH-and-PYTHONPATH.patch
+++ b/pkgs/applications/window-managers/qtile/0002-Restore-PATH-and-PYTHONPATH.patch
@@ -1,57 +1,52 @@
-From f299a0aa0eefcf16bb4990f00ac3946727f43ef3 Mon Sep 17 00:00:00 2001
-From: "Alexander V. Nikolaev" <avn@avnik.info>
-Date: Fri, 27 Nov 2015 10:49:48 +0200
-Subject: [PATCH 2/3] Restore PATH and PYTHONPATH
-
----
- bin/qtile         | 1 +
- bin/qtile-run     | 1 +
- bin/qtile-session | 2 ++
- libqtile/utils.py | 7 +++++++
- 4 files changed, 11 insertions(+)
-
+diff --git a/bin/qshell b/bin/qshell
+index 2ba7e61c..0ac2a2ef 100755
+--- a/bin/qshell
++++ b/bin/qshell
+@@ -28,5 +28,6 @@ base_dir = os.path.abspath(os.path.join(this_dir, ".."))
+ sys.path.insert(0, base_dir)
+ 
+ if __name__ == '__main__':
++    __import__("importlib").import_module("libqtile.utils").restore_os_environment()
+     from libqtile.scripts import qshell
+     qshell.main()
 diff --git a/bin/qtile b/bin/qtile
-index 66034fe..ce3fcd1 100755
+index 3e82814d..335b5cea 100755
 --- a/bin/qtile
 +++ b/bin/qtile
-@@ -131,6 +131,7 @@ def make_qtile():
- 
+@@ -29,5 +29,6 @@ base_dir = os.path.abspath(os.path.join(this_dir, ".."))
+ sys.path.insert(0, base_dir)
  
- if __name__ == "__main__":
+ if __name__ == '__main__':
 +    __import__("importlib").import_module("libqtile.utils").restore_os_environment()
-     rename_process()
-     q = make_qtile()
-     try:
+     from libqtile.scripts import qtile
+     qtile.main()
 diff --git a/bin/qtile-run b/bin/qtile-run
-index ccedb96..646a476 100755
+index e4b121be..1c203bc9 100755
 --- a/bin/qtile-run
 +++ b/bin/qtile-run
-@@ -50,6 +50,7 @@ def main():
-     proc.wait()
+@@ -8,5 +8,6 @@ base_dir = os.path.abspath(os.path.join(this_dir, ".."))
+ sys.path.insert(0, base_dir)
  
- if __name__ == "__main__":
+ if __name__ == '__main__':
 +    __import__("importlib").import_module("libqtile.utils").restore_os_environment()
-     try:
-         main()
-     except KeyboardInterrupt:
-diff --git a/bin/qtile-session b/bin/qtile-session
-index 84f6a2d..da31b12 100755
---- a/bin/qtile-session
-+++ b/bin/qtile-session
-@@ -25,6 +25,8 @@
- Qtile session manager.
- """
+     from libqtile.scripts import qtile_run
+     qtile_run.main()
+diff --git a/bin/qtile-top b/bin/qtile-top
+index 5316e0e7..272c6430 100755
+--- a/bin/qtile-top
++++ b/bin/qtile-top
+@@ -8,5 +8,6 @@ base_dir = os.path.abspath(os.path.join(this_dir, ".."))
+ sys.path.insert(0, base_dir)
  
-+__import__("importlib").import_module("libqtile.utils").restore_os_environment()
-+
- from libqtile.log_utils import init_log
- import logging
- import os
+ if __name__ == '__main__':
++    __import__("importlib").import_module("libqtile.utils").restore_os_environment()
+     from libqtile.scripts import qtile_top
+     qtile_top.main()
 diff --git a/libqtile/utils.py b/libqtile/utils.py
-index 284089b..ec3539e 100644
+index 36ed0a58..bca9eab3 100644
 --- a/libqtile/utils.py
 +++ b/libqtile/utils.py
-@@ -227,3 +227,11 @@ def describe_attributes(obj, attrs, func=None):
+@@ -240,3 +240,11 @@ def describe_attributes(obj, attrs, func=None):
              pairs.append('%s=%s' % (attr, value))
  
      return ', '.join(pairs)
diff --git a/pkgs/applications/window-managers/qtile/0003-Restart-executable.patch b/pkgs/applications/window-managers/qtile/0003-Restart-executable.patch
index d9377897fc69..c9ae57c8615c 100644
--- a/pkgs/applications/window-managers/qtile/0003-Restart-executable.patch
+++ b/pkgs/applications/window-managers/qtile/0003-Restart-executable.patch
@@ -1,17 +1,8 @@
-From b560c11078fecc35df2c62f34beda06c4e80a10d Mon Sep 17 00:00:00 2001
-From: "Alexander V. Nikolaev" <avn@avnik.info>
-Date: Fri, 27 Nov 2015 10:54:35 +0200
-Subject: [PATCH 3/3] Restart executable
-
----
- libqtile/manager.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
 diff --git a/libqtile/manager.py b/libqtile/manager.py
-index b1a38e2..110f7d8 100644
+index 36518a74..9b6bdd02 100644
 --- a/libqtile/manager.py
 +++ b/libqtile/manager.py
-@@ -1339,7 +1339,7 @@ class Qtile(command.CommandObject):
+@@ -1386,7 +1386,7 @@ class Qtile(command.CommandObject):
          argv = [s for s in argv if not s.startswith('--with-state')]
          argv.append('--with-state=' + buf.getvalue().decode())
  
@@ -19,7 +10,4 @@ index b1a38e2..110f7d8 100644
 +        self.cmd_execute(os.environ.get("QTILE_WRAPPER", "@out@/bin/qtile"), argv[1:])
  
      def cmd_spawn(self, cmd):
-         """
--- 
-2.6.3
-
+         """Run cmd in a shell.
diff --git a/pkgs/applications/window-managers/qtile/default.nix b/pkgs/applications/window-managers/qtile/default.nix
index a7b9a77b3dbf..79752829e2a5 100644
--- a/pkgs/applications/window-managers/qtile/default.nix
+++ b/pkgs/applications/window-managers/qtile/default.nix
@@ -7,13 +7,13 @@ in
 
 python27Packages.buildPythonApplication rec {
   name = "qtile-${version}";
-  version = "0.10.4";
+  version = "0.10.7";
 
   src = fetchFromGitHub {
     owner = "qtile";
     repo = "qtile";
     rev = "v${version}";
-    sha256 = "0rwklzgkp3x242xql6qmfpfnhr788hd3jc1l80pc5ybxlwyfx59i";
+    sha256 = "18szgplyym0b65vnaa8nqzadq6q0mhsiky9g5hqhn7xzf4kykmj8";
   };
 
   patches = [