about summary refs log tree commit diff
path: root/overlays/personal/pushmail/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/personal/pushmail/default.nix')
-rw-r--r--overlays/personal/pushmail/default.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/overlays/personal/pushmail/default.nix b/overlays/personal/pushmail/default.nix
deleted file mode 100644
index 98b504fc3510..000000000000
--- a/overlays/personal/pushmail/default.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ lib, rustPlatform, fetchurl, makeWrapper, pkg-config, openssl, gitMinimal }:
-
-rustPlatform.buildRustPackage rec {
-  pname = "pushmail";
-  version = "0.1.0";
-
-  src = fetchurl {
-    url = "https://git.qyliss.net/pushmail/snapshot/pushmail-${version}.tar.xz";
-    sha256 = "1lbz6nggzzaq9wgsscgv6ypn74mh5fc5z48pw0f5p0bl73vn2n17";
-  };
-
-  cargoSha256 = "1nr4gdnkzaafbl5xlzx3wz1lyax63g8qrdiq4i5dh1s585pxmvr0";
-
-  nativeBuildInputs = [ makeWrapper pkg-config ];
-  buildInputs = [ openssl ];
-  strictDeps = true;
-
-  postInstall = ''
-    wrapProgram $out/bin/pushmail \
-        --prefix PATH : ${lib.makeBinPath [ gitMinimal ]}
-  '';
-
-  meta = with lib; {
-    homepage = "https://git.qyliss.net/pushmail/about/";
-    description = "Send notification emails for direct pushes to a GitHub repository";
-    maintainers = with maintainers; [ qyliss ];
-    license = licenses.gpl2Plus; # with linking exception for OpenSSL
-    platforms = platforms.unix;
-  };
-}