about summary refs log tree commit diff
path: root/overlays/patches/youtube-dl/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/patches/youtube-dl/default.nix')
-rw-r--r--overlays/patches/youtube-dl/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/overlays/patches/youtube-dl/default.nix b/overlays/patches/youtube-dl/default.nix
new file mode 100644
index 000000000000..b9f20e7592c8
--- /dev/null
+++ b/overlays/patches/youtube-dl/default.nix
@@ -0,0 +1,21 @@
+{ youtube-dl, ... } @ args:
+
+let
+  inherit (builtins) removeAttrs;
+in
+
+(youtube-dl.override (removeAttrs args [ "youtube-dl" ])).overrideAttrs (
+  { patches ? [], ... }:
+  {
+    patches = patches ++ [
+      ./0001-bandcamp-fix-regexp-for-JSON-matching-on-bandcamp.patch
+      ./0002-bandcamp-use-unescapeHTML-instead-of-a-simple-replac.patch
+      ./0003-bandcamp-match-album-titles-inside-the-new-JSON-data.patch
+      ./0004-bandcamp-fix-the-freeDownloadPage-JSON-lookup-and-us.patch
+      ./0005-bandcamp-update-youtuble-dl-test-song-information-to.patch
+      ./0006-bandcamp-fix-test-song-uploader-name-cleanup-remanin.patch
+      ./0007-bandcamp-Revert-test-song-title-and-extract-title-ge.patch
+      ./0008-bandcamp-fix-album-downloading.patch    
+    ];
+  }
+)