about summary refs log tree commit diff
path: root/overlays/patches/emacs/overlay/hydra/pkgs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/patches/emacs/overlay/hydra/pkgs.nix')
-rw-r--r--overlays/patches/emacs/overlay/hydra/pkgs.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/overlays/patches/emacs/overlay/hydra/pkgs.nix b/overlays/patches/emacs/overlay/hydra/pkgs.nix
new file mode 100644
index 000000000000..79f889beb980
--- /dev/null
+++ b/overlays/patches/emacs/overlay/hydra/pkgs.nix
@@ -0,0 +1,10 @@
+nixpkgs:
+
+import nixpkgs {
+  overlays = [
+    (import ../default.nix)
+    (self: super: {
+      mkEmacsSet = emacs: { emacsPackages = super.recurseIntoAttrs (self.emacsPackagesFor emacs); };
+    })
+  ];
+}