about summary refs log tree commit diff
path: root/overlays/patches/emacs/overlay/hydra/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/patches/emacs/overlay/hydra/default.nix')
-rw-r--r--overlays/patches/emacs/overlay/hydra/default.nix18
1 files changed, 15 insertions, 3 deletions
diff --git a/overlays/patches/emacs/overlay/hydra/default.nix b/overlays/patches/emacs/overlay/hydra/default.nix
index da4eb56c7fa2..97d015f8ed4d 100644
--- a/overlays/patches/emacs/overlay/hydra/default.nix
+++ b/overlays/patches/emacs/overlay/hydra/default.nix
@@ -21,12 +21,12 @@ let
     inputs = {
       src = {
         type = "git";
-        value = "git://github.com/nix-community/emacs-overlay.git";
+        value = "https://github.com/nix-community/emacs-overlay.git";
         emailresponsible = false;
       };
       nixpkgs = {
         type = "git";
-        value = "git://github.com/NixOS/nixpkgs.git ${nixpkgsRelease}";
+        value = "https://github.com/NixOS/nixpkgs.git ${nixpkgsRelease}";
         emailresponsible = false;
       };
     };
@@ -41,11 +41,23 @@ let
     };
 
     stable = mkJobset {
-      nixpkgsRelease = "nixos-21.05";
+      nixpkgsRelease = "nixos-22.05";
       nixFile = "emacsen.nix";
       descriptionNote = "emacs";
     };
 
+    unstable-cross = mkJobset {
+      nixpkgsRelease = "nixos-unstable";
+      nixFile = "emacsen-cross.nix";
+      descriptionNote = "emacs cross builds";
+    };
+
+    stable-cross = mkJobset {
+      nixpkgsRelease = "nixos-22.05";
+      nixFile = "emacsen-cross.nix";
+      descriptionNote = "emacs cross builds";
+    };
+
     unstable-pkgs = mkJobset {
       nixpkgsRelease = "nixos-unstable";
       nixFile = "packages.nix";