about summary refs log tree commit diff
path: root/nixos/tests/zsh-history.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/zsh-history.nix')
-rw-r--r--nixos/tests/zsh-history.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/zsh-history.nix b/nixos/tests/zsh-history.nix
index 3109c3f65081..355687798406 100644
--- a/nixos/tests/zsh-history.nix
+++ b/nixos/tests/zsh-history.nix
@@ -23,7 +23,7 @@ import ./make-test-python.nix ({ pkgs, ...} : {
     # Login
     default.wait_until_tty_matches(1, "login: ")
     default.send_chars("root\n")
-    default.wait_until_tty_matches(1, "root@default>")
+    default.wait_until_tty_matches(1, r"\nroot@default\b")
 
     # Generate some history
     default.send_chars("echo foobar\n")