about summary refs log tree commit diff
path: root/nixos/tests/xdg-desktop-portal.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/xdg-desktop-portal.nix')
-rw-r--r--nixos/tests/xdg-desktop-portal.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/nixos/tests/xdg-desktop-portal.nix b/nixos/tests/xdg-desktop-portal.nix
new file mode 100644
index 000000000000..d954b07f73d6
--- /dev/null
+++ b/nixos/tests/xdg-desktop-portal.nix
@@ -0,0 +1,17 @@
+# run installed tests
+import ./make-test.nix ({ pkgs, ... }:
+
+{
+  name = "xdg-desktop-portal";
+  meta = {
+    maintainers = pkgs.xdg-desktop-portal.meta.maintainers;
+  };
+
+  machine = { config, pkgs, ... }: {
+    environment.systemPackages = with pkgs; [ gnome-desktop-testing ];
+  };
+
+  testScript = ''
+    $machine->succeed("gnome-desktop-testing-runner -d '${pkgs.xdg-desktop-portal.installedTests}/share'");
+  '';
+})