about summary refs log tree commit diff
path: root/nixos/tests/sddm.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/sddm.nix')
-rw-r--r--nixos/tests/sddm.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/tests/sddm.nix b/nixos/tests/sddm.nix
index ac91a89f6695..7b9fdc0b3441 100644
--- a/nixos/tests/sddm.nix
+++ b/nixos/tests/sddm.nix
@@ -9,7 +9,7 @@ let
     default = {
       name = "sddm";
 
-      machine = { lib, ... }: {
+      machine = { ... }: {
         imports = [ ./common/user-account.nix ];
         services.xserver.enable = true;
         services.xserver.displayManager.sddm.enable = true;
@@ -39,7 +39,7 @@ let
         maintainers = [ ttuegel ];
       };
 
-      machine = { lib, ... }: {
+      machine = { ... }: {
         imports = [ ./common/user-account.nix ];
         services.xserver.enable = true;
         services.xserver.displayManager.sddm = {
@@ -54,7 +54,7 @@ let
         services.xserver.desktopManager.default = "none";
       };
 
-      testScript = { nodes, ... }: ''
+      testScript = { ... }: ''
         startAll;
         $machine->waitForFile("/home/alice/.Xauthority");
         $machine->succeed("xauth merge ~alice/.Xauthority");