about summary refs log tree commit diff
path: root/nixos/tests/prowlarr.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/prowlarr.nix')
-rw-r--r--nixos/tests/prowlarr.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/nixos/tests/prowlarr.nix b/nixos/tests/prowlarr.nix
index af669afd5700..663743546459 100644
--- a/nixos/tests/prowlarr.nix
+++ b/nixos/tests/prowlarr.nix
@@ -11,6 +11,8 @@ import ./make-test-python.nix ({ lib, ... }:
   testScript = ''
     machine.wait_for_unit("prowlarr.service")
     machine.wait_for_open_port(9696)
-    machine.succeed("curl --fail http://localhost:9696/")
+    response = machine.succeed("curl --fail http://localhost:9696/")
+    assert '<title>Prowlarr</title>' in response, "Login page didn't load successfully"
+    machine.succeed("[ -d /var/lib/prowlarr ]")
   '';
 })