about summary refs log tree commit diff
path: root/nixos/tests/pdns-recursor.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/pdns-recursor.nix')
-rw-r--r--nixos/tests/pdns-recursor.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/tests/pdns-recursor.nix b/nixos/tests/pdns-recursor.nix
index fb24cfc72f14..bf6e6093d69c 100644
--- a/nixos/tests/pdns-recursor.nix
+++ b/nixos/tests/pdns-recursor.nix
@@ -1,4 +1,4 @@
-import ./make-test.nix ({ pkgs, lib, ... }: {
+import ./make-test.nix ({ pkgs, ... }: {
   name = "powerdns";
 
   nodes.server = { ... }: {
@@ -7,6 +7,6 @@ import ./make-test.nix ({ pkgs, lib, ... }: {
 
   testScript = ''
     $server->waitForUnit("pdns-recursor");
-    $server->succeed("echo | ${lib.getBin pkgs.netcat}/bin/nc -v localhost 53")
+    $server->waitForOpenPort("53");
   '';
 })