about summary refs log tree commit diff
path: root/nixos/tests/jellyfin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/jellyfin.nix')
-rw-r--r--nixos/tests/jellyfin.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/nixos/tests/jellyfin.nix b/nixos/tests/jellyfin.nix
new file mode 100644
index 000000000000..b60c6eb94f46
--- /dev/null
+++ b/nixos/tests/jellyfin.nix
@@ -0,0 +1,16 @@
+import ./make-test.nix ({ lib, ...}:
+
+{
+  name = "jellyfin";
+  meta.maintainers = with lib.maintainers; [ minijackson ];
+
+  machine =
+    { ... }:
+    { services.jellyfin.enable = true; };
+
+  testScript = ''
+    $machine->waitForUnit('jellyfin.service');
+    $machine->waitForOpenPort('8096');
+    $machine->succeed("curl --fail http://localhost:8096/");
+  '';
+})