about summary refs log tree commit diff
path: root/nixos/tests/installer.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/installer.nix')
-rw-r--r--nixos/tests/installer.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/nixos/tests/installer.nix b/nixos/tests/installer.nix
index 6e06b544d258..bebd6c04374b 100644
--- a/nixos/tests/installer.nix
+++ b/nixos/tests/installer.nix
@@ -174,6 +174,11 @@ let
 
       $machine->succeed("nixos-rebuild switch >&2");
 
+      # Test nixos-option.
+      $machine->succeed("nixos-option boot.initrd.kernelModules | grep virtio_console");
+      $machine->succeed("nixos-option -d boot.initrd.kernelModules | grep 'List of modules'");
+      $machine->succeed("nixos-option -l boot.initrd.kernelModules | grep /etc/nixos/configuration.nix");
+
       $machine->shutdown;
 
       # And just to be sure, check that the machine still boots after