about summary refs log tree commit diff
path: root/nixos/tests/hibernate.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/hibernate.nix')
-rw-r--r--nixos/tests/hibernate.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/tests/hibernate.nix b/nixos/tests/hibernate.nix
index 787929f8904d..7616a75b0214 100644
--- a/nixos/tests/hibernate.nix
+++ b/nixos/tests/hibernate.nix
@@ -13,7 +13,7 @@ import ./make-test.nix (pkgs: {
 
       networking.firewall.allowedTCPPorts = [ 4444 ];
 
-      systemd.services.listener.serviceConfig.ExecStart = "${pkgs.netcat}/bin/nc -l -p 4444";
+      systemd.services.listener.serviceConfig.ExecStart = "${pkgs.netcat}/bin/nc -l 4444";
     };
 
     probe = { config, lib, pkgs, ...}: {
@@ -36,7 +36,7 @@ import ./make-test.nix (pkgs: {
       $machine->waitForShutdown;
       $machine->start;
       $probe->waitForUnit("network.target");
-      $probe->waitUntilSucceeds("echo test | nc -c machine 4444");
+      $probe->waitUntilSucceeds("echo test | nc machine 4444");
     '';
 
 })