about summary refs log tree commit diff
path: root/nixos/tests/fwupd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/fwupd.nix')
-rw-r--r--nixos/tests/fwupd.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/nixos/tests/fwupd.nix b/nixos/tests/fwupd.nix
new file mode 100644
index 000000000000..bf4ef25130b3
--- /dev/null
+++ b/nixos/tests/fwupd.nix
@@ -0,0 +1,19 @@
+# run installed tests
+import ./make-test.nix ({ pkgs, ... }: {
+  name = "fwupd";
+
+  meta = {
+    maintainers = pkgs.fwupd.meta.maintainers;
+  };
+
+  machine = { config, pkgs, ... }: {
+    services.fwupd.enable = true;
+    environment.systemPackages = with pkgs; [ gnome-desktop-testing ];
+    environment.variables.XDG_DATA_DIRS = [ "${pkgs.fwupd.installedTests}/share" ];
+    virtualisation.memorySize = 768;
+  };
+
+  testScript = ''
+    $machine->succeed("gnome-desktop-testing-runner");
+  '';
+})