about summary refs log tree commit diff
path: root/nixos/tests/firewall.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/firewall.nix')
-rw-r--r--nixos/tests/firewall.nix53
1 files changed, 34 insertions, 19 deletions
diff --git a/nixos/tests/firewall.nix b/nixos/tests/firewall.nix
index 9faf19f0359f..1119a5312eb5 100644
--- a/nixos/tests/firewall.nix
+++ b/nixos/tests/firewall.nix
@@ -15,6 +15,16 @@ import ./make-test.nix ( { pkgs, ... } : {
           services.httpd.adminAddr = "foo@example.org";
         };
 
+      # Dummy configuration to check whether firewall.service will be honored
+      # during system activation. This only needs to be different to the
+      # original walled configuration so that there is a change in the service
+      # file.
+      walled2 =
+        { config, pkgs, nodes, ... }:
+        { networking.firewall.enable = true;
+          networking.firewall.rejectPackets = true;
+        };
+
       attacker =
         { config, pkgs, ... }:
         { services.httpd.enable = true;
@@ -23,28 +33,33 @@ import ./make-test.nix ( { pkgs, ... } : {
         };
     };
 
-  testScript =
-    { nodes, ... }:
-    ''
-      startAll;
+  testScript = { nodes, ... }: let
+    newSystem = nodes.walled2.config.system.build.toplevel;
+  in ''
+    $walled->start;
+    $attacker->start;
+
+    $walled->waitForUnit("firewall");
+    $walled->waitForUnit("httpd");
+    $attacker->waitForUnit("network.target");
 
-      $walled->waitForUnit("firewall");
-      $walled->waitForUnit("httpd");
-      $attacker->waitForUnit("network.target");
+    # Local connections should still work.
+    $walled->succeed("curl -v http://localhost/ >&2");
 
-      # Local connections should still work.
-      $walled->succeed("curl -v http://localhost/ >&2");
+    # Connections to the firewalled machine should fail, but ping should succeed.
+    $attacker->fail("curl --fail --connect-timeout 2 http://walled/ >&2");
+    $attacker->succeed("ping -c 1 walled >&2");
 
-      # Connections to the firewalled machine should fail.
-      $attacker->fail("curl --fail --connect-timeout 2 http://walled/ >&2");
-      $attacker->fail("ping -c 1 walled >&2");
+    # Outgoing connections/pings should still work.
+    $walled->succeed("curl -v http://attacker/ >&2");
+    $walled->succeed("ping -c 1 attacker >&2");
 
-      # Outgoing connections/pings should still work.
-      $walled->succeed("curl -v http://attacker/ >&2");
-      $walled->succeed("ping -c 1 attacker >&2");
+    # If we stop the firewall, then connections should succeed.
+    $walled->stopJob("firewall");
+    $attacker->succeed("curl -v http://walled/ >&2");
 
-      # If we stop the firewall, then connections should succeed.
-      $walled->stopJob("firewall");
-      $attacker->succeed("curl -v http://walled/ >&2");
-    '';
+    # Check whether activation of a new configuration reloads the firewall.
+    $walled->succeed("${newSystem}/bin/switch-to-configuration test 2>&1" .
+                     " | grep -qF firewall.service");
+  '';
 })