about summary refs log tree commit diff
path: root/nixos/tests/ec2.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/ec2.nix')
-rw-r--r--nixos/tests/ec2.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/nixos/tests/ec2.nix b/nixos/tests/ec2.nix
index db959a63e40f..384fce67c227 100644
--- a/nixos/tests/ec2.nix
+++ b/nixos/tests/ec2.nix
@@ -41,6 +41,10 @@ let
       ];
     }).config.system.build.amazonImage;
 
+  sshKeys = import ./ssh-keys.nix pkgs;
+  snakeOilPrivateKey = sshKeys.snakeOilPrivateKey.text;
+  snakeOilPublicKey = sshKeys.snakeOilPublicKey;
+
 in {
   boot-ec2-nixops = makeEc2Test {
     name         = "nixops-userdata";