about summary refs log tree commit diff
path: root/nixos/tests/atd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/atd.nix')
-rw-r--r--nixos/tests/atd.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/nixos/tests/atd.nix b/nixos/tests/atd.nix
new file mode 100644
index 000000000000..5260c8ddfb82
--- /dev/null
+++ b/nixos/tests/atd.nix
@@ -0,0 +1,30 @@
+import ./make-test.nix ({ pkgs, lib, ... }:
+
+{
+  name = "atd";
+  meta = with pkgs.stdenv.lib.maintainers; {
+    maintainers = [ bjornfor ];
+  };
+
+  machine =
+    { config, pkgs, ... }:
+    { services.atd.enable = true;
+      users.extraUsers.alice = { isNormalUser = true; };
+    };
+
+  # "at" has a resolution of 1 minute
+  testScript = ''
+    startAll;
+
+    $machine->fail("test -f ~root/at-1");
+    $machine->fail("test -f ~alice/at-1");
+
+    $machine->succeed("echo 'touch ~root/at-1' | at now+1min");
+    $machine->succeed("su - alice -c \"echo 'touch at-1' | at now+1min\"");
+
+    $machine->succeed("sleep 1.5m");
+
+    $machine->succeed("test -f ~root/at-1");
+    $machine->succeed("test -f ~alice/at-1");
+  '';
+})