about summary refs log tree commit diff
path: root/nixos/modules/virtualisation/oci-common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/virtualisation/oci-common.nix')
-rw-r--r--nixos/modules/virtualisation/oci-common.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/nixos/modules/virtualisation/oci-common.nix b/nixos/modules/virtualisation/oci-common.nix
index 19e4c9fa898b..ac9405e3ecfa 100644
--- a/nixos/modules/virtualisation/oci-common.nix
+++ b/nixos/modules/virtualisation/oci-common.nix
@@ -53,4 +53,8 @@ in
   networking.timeServers = [ "169.254.169.254" ];
 
   services.openssh.enable = true;
+
+  # Otherwise the instance may not have a working network-online.target,
+  # making the fetch-ssh-keys.service fail
+  networking.useNetworkd = true;
 }