about summary refs log tree commit diff
path: root/nixos/modules/tasks/network-interfaces-scripted.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/tasks/network-interfaces-scripted.nix')
-rw-r--r--nixos/modules/tasks/network-interfaces-scripted.nix11
1 files changed, 3 insertions, 8 deletions
diff --git a/nixos/modules/tasks/network-interfaces-scripted.nix b/nixos/modules/tasks/network-interfaces-scripted.nix
index 30fcb3a80104..12be812c71cb 100644
--- a/nixos/modules/tasks/network-interfaces-scripted.nix
+++ b/nixos/modules/tasks/network-interfaces-scripted.nix
@@ -33,8 +33,8 @@ let
       done
       [ "$UPDATED" -eq "1" ] && break
     done
-    ip link set "${i}" down || true
-    ip link del "${i}" || true
+    ip link set "${i}" down 2>/dev/null || true
+    ip link del "${i}" 2>/dev/null || true
   '';
 
 in
@@ -43,12 +43,6 @@ in
 
   config = mkIf (!cfg.useNetworkd) {
 
-    systemd.targets."network-interfaces" =
-      { description = "All Network Interfaces";
-        wantedBy = [ "network.target" ];
-        unitConfig.X-StopOnReconfiguration = true;
-      };
-
     systemd.services =
       let
 
@@ -240,6 +234,7 @@ in
               # Bring up the bond and enslave the specified interfaces
               ip link set "${n}" up
               ${flip concatMapStrings v.interfaces (i: ''
+                ip link set "${i}" down
                 ip link set "${i}" master "${n}"
               '')}
             '';