about summary refs log tree commit diff
path: root/nixos/modules/tasks/filesystems/f2fs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/tasks/filesystems/f2fs.nix')
-rw-r--r--nixos/modules/tasks/filesystems/f2fs.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/nixos/modules/tasks/filesystems/f2fs.nix b/nixos/modules/tasks/filesystems/f2fs.nix
new file mode 100644
index 000000000000..8655107360c1
--- /dev/null
+++ b/nixos/modules/tasks/filesystems/f2fs.nix
@@ -0,0 +1,21 @@
+{ config, pkgs, ... }:
+
+with pkgs.lib;
+
+let
+  inInitrd = any (fs: fs == "f2fs") config.boot.initrd.supportedFilesystems;
+in
+{
+  config = mkIf (any (fs: fs == "f2fs") config.boot.supportedFilesystems) {
+
+    system.fsPackages = [ pkgs.f2fs-tools ];
+
+    boot.initrd.availableKernelModules = mkIf inInitrd [ "f2fs" ];
+
+    boot.initrd.extraUtilsCommands = mkIf inInitrd ''
+      mkdir -p $out/bin $out/lib
+      cp -v   ${pkgs.f2fs-tools}/sbin/fsck.f2fs $out/bin
+      cp -pdv ${pkgs.f2fs-tools}/lib/lib*.so.* $out/lib
+    '';
+  };
+}