about summary refs log tree commit diff
path: root/nixos/modules/system/boot/kexec.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/system/boot/kexec.nix')
-rw-r--r--nixos/modules/system/boot/kexec.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/kexec.nix b/nixos/modules/system/boot/kexec.nix
index 3e5d7b40f2c5..61f9c6d0e7eb 100644
--- a/nixos/modules/system/boot/kexec.nix
+++ b/nixos/modules/system/boot/kexec.nix
@@ -1,7 +1,7 @@
 { pkgs, lib, ... }:
 
 {
-  config = lib.mkIf (pkgs.kexectools.meta.available) {
+  config = lib.mkIf (lib.any (lib.meta.platformMatch pkgs.stdenv.hostPlatform) pkgs.kexectools.meta.platforms) {
     environment.systemPackages = [ pkgs.kexectools ];
 
     systemd.services."prepare-kexec" =