about summary refs log tree commit diff
path: root/nixos/modules/system/boot/kernel.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/system/boot/kernel.nix')
-rw-r--r--nixos/modules/system/boot/kernel.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/nixos/modules/system/boot/kernel.nix b/nixos/modules/system/boot/kernel.nix
index cf70a891c0ca..cc68be781fc4 100644
--- a/nixos/modules/system/boot/kernel.nix
+++ b/nixos/modules/system/boot/kernel.nix
@@ -57,6 +57,7 @@ in
       type = types.listOf types.str;
       default = [ ];
       description = "Parameters added to the kernel command line.";
+      apply = list: attrNames (genAttrs list (_: true)); # dedup and sort to avoid restarting services on eval order change
     };
 
     boot.consoleLogLevel = mkOption {