about summary refs log tree commit diff
path: root/nixos/modules/services/x11/xfs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/x11/xfs.nix')
-rw-r--r--nixos/modules/services/x11/xfs.nix46
1 files changed, 0 insertions, 46 deletions
diff --git a/nixos/modules/services/x11/xfs.nix b/nixos/modules/services/x11/xfs.nix
deleted file mode 100644
index ea7cfa1aa43c..000000000000
--- a/nixos/modules/services/x11/xfs.nix
+++ /dev/null
@@ -1,46 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-let
-
-  configFile = ./xfs.conf;
-
-in
-
-{
-
-  ###### interface
-
-  options = {
-
-    services.xfs = {
-
-      enable = mkOption {
-        type = types.bool;
-        default = false;
-        description = "Whether to enable the X Font Server.";
-      };
-
-    };
-
-  };
-
-
-  ###### implementation
-
-  config = mkIf config.services.xfs.enable {
-    assertions = singleton
-      { assertion = config.fonts.enableFontDir;
-        message = "Please enable fonts.enableFontDir to use the X Font Server.";
-      };
-
-    systemd.services.xfs = {
-      description = "X Font Server";
-      after = [ "network.target" ];
-      wantedBy = [ "multi-user.target" ];
-      path = [ pkgs.xorg.xfs ];
-      script = "xfs -config ${configFile}";
-    };
-  };
-}