about summary refs log tree commit diff
path: root/nixos/modules/services/x11/xbanish.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/x11/xbanish.nix')
-rw-r--r--nixos/modules/services/x11/xbanish.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/modules/services/x11/xbanish.nix b/nixos/modules/services/x11/xbanish.nix
index e1e3cbc8e441..b95fac68f165 100644
--- a/nixos/modules/services/x11/xbanish.nix
+++ b/nixos/modules/services/x11/xbanish.nix
@@ -20,7 +20,8 @@ in {
   config = mkIf cfg.enable {
     systemd.user.services.xbanish = {
       description = "xbanish hides the mouse pointer";
-      wantedBy = [ "default.target" ];
+      wantedBy = [ "graphical-session.target" ];
+      partOf = [ "graphical-session.target" ];
       serviceConfig.ExecStart = ''
         ${pkgs.xbanish}/bin/xbanish ${cfg.arguments}
       '';