about summary refs log tree commit diff
path: root/nixos/modules/services/x11/window-managers/metacity.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/x11/window-managers/metacity.nix')
-rw-r--r--nixos/modules/services/x11/window-managers/metacity.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/nixos/modules/services/x11/window-managers/metacity.nix b/nixos/modules/services/x11/window-managers/metacity.nix
deleted file mode 100644
index 600afe759b2c..000000000000
--- a/nixos/modules/services/x11/window-managers/metacity.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-let
-
-  cfg = config.services.xserver.windowManager.metacity;
-  inherit (pkgs) gnome;
-in
-
-{
-  options = {
-    services.xserver.windowManager.metacity.enable = mkEnableOption "metacity";
-  };
-
-  config = mkIf cfg.enable {
-
-    services.xserver.windowManager.session = singleton
-      { name = "metacity";
-        start = ''
-          ${gnome.metacity}/bin/metacity &
-          waitPID=$!
-        '';
-      };
-
-    environment.systemPackages = [ gnome.metacity ];
-
-  };
-
-}