about summary refs log tree commit diff
path: root/nixos/modules/services/x11/window-managers/herbstluftwm.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/x11/window-managers/herbstluftwm.nix')
-rw-r--r--nixos/modules/services/x11/window-managers/herbstluftwm.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/nixos/modules/services/x11/window-managers/herbstluftwm.nix b/nixos/modules/services/x11/window-managers/herbstluftwm.nix
deleted file mode 100644
index 7edaf4e980ec..000000000000
--- a/nixos/modules/services/x11/window-managers/herbstluftwm.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-let
-  cfg = config.services.xserver.windowManager.herbstluftwm;
-in
-
-{
-  options = {
-    services.xserver.windowManager.herbstluftwm = {
-      enable = mkEnableOption "herbstluftwm";
-
-      package = mkPackageOption pkgs "herbstluftwm" { };
-
-      configFile = mkOption {
-        default     = null;
-        type        = with types; nullOr path;
-        description = ''
-          Path to the herbstluftwm configuration file.  If left at the
-          default value, $XDG_CONFIG_HOME/herbstluftwm/autostart will
-          be used.
-        '';
-      };
-    };
-  };
-
-  config = mkIf cfg.enable {
-    services.xserver.windowManager.session = singleton {
-      name = "herbstluftwm";
-      start =
-        let configFileClause = optionalString
-            (cfg.configFile != null)
-            ''-c "${cfg.configFile}"''
-            ;
-        in "${cfg.package}/bin/herbstluftwm ${configFileClause} &";
-    };
-    environment.systemPackages = [ cfg.package ];
-  };
-}