about summary refs log tree commit diff
path: root/nixos/modules/services/x11/window-managers/cwm.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/x11/window-managers/cwm.nix')
-rw-r--r--nixos/modules/services/x11/window-managers/cwm.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/nixos/modules/services/x11/window-managers/cwm.nix b/nixos/modules/services/x11/window-managers/cwm.nix
deleted file mode 100644
index 03375a226bb6..000000000000
--- a/nixos/modules/services/x11/window-managers/cwm.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-let
-  cfg = config.services.xserver.windowManager.cwm;
-in
-{
-  options = {
-    services.xserver.windowManager.cwm.enable = mkEnableOption "cwm";
-  };
-  config = mkIf cfg.enable {
-    services.xserver.windowManager.session = singleton
-      { name = "cwm";
-        start =
-          ''
-            cwm &
-            waitPID=$!
-          '';
-      };
-    environment.systemPackages = [ pkgs.cwm ];
-  };
-}