about summary refs log tree commit diff
path: root/nixos/modules/services/x11/urxvtd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/x11/urxvtd.nix')
-rw-r--r--nixos/modules/services/x11/urxvtd.nix43
1 files changed, 0 insertions, 43 deletions
diff --git a/nixos/modules/services/x11/urxvtd.nix b/nixos/modules/services/x11/urxvtd.nix
deleted file mode 100644
index 618db85d477b..000000000000
--- a/nixos/modules/services/x11/urxvtd.nix
+++ /dev/null
@@ -1,43 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-# maintainer: siddharthist
-
-with lib;
-
-let
-  cfg = config.services.urxvtd;
-in {
-  options.services.urxvtd = {
-    enable = mkOption {
-      type = types.bool;
-      default = false;
-      description = ''
-        Enable urxvtd, the urxvt terminal daemon. To use urxvtd, run
-        "urxvtc".
-      '';
-    };
-
-    package = mkPackageOption pkgs "rxvt-unicode" { };
-  };
-
-  config = mkIf cfg.enable {
-    systemd.user.services.urxvtd = {
-      description = "urxvt terminal daemon";
-      wantedBy = [ "graphical-session.target" ];
-      partOf = [ "graphical-session.target" ];
-      path = [ pkgs.xsel ];
-      serviceConfig = {
-        ExecStart = "${cfg.package}/bin/urxvtd -o";
-        Environment = "RXVT_SOCKET=%t/urxvtd-socket";
-        Restart = "on-failure";
-        RestartSec = "5s";
-      };
-    };
-
-    environment.systemPackages = [ cfg.package ];
-    environment.variables.RXVT_SOCKET = "/run/user/$(id -u)/urxvtd-socket";
-  };
-
-  meta.maintainers = with lib.maintainers; [ rnhmjoj ];
-
-}