about summary refs log tree commit diff
path: root/nixos/modules/services/x11/display-managers/lightdm-greeters/tiny.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/x11/display-managers/lightdm-greeters/tiny.nix')
-rw-r--r--nixos/modules/services/x11/display-managers/lightdm-greeters/tiny.nix90
1 files changed, 0 insertions, 90 deletions
diff --git a/nixos/modules/services/x11/display-managers/lightdm-greeters/tiny.nix b/nixos/modules/services/x11/display-managers/lightdm-greeters/tiny.nix
deleted file mode 100644
index 835cf049e4ee..000000000000
--- a/nixos/modules/services/x11/display-managers/lightdm-greeters/tiny.nix
+++ /dev/null
@@ -1,90 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-let
-
-  dmcfg = config.services.xserver.displayManager;
-  ldmcfg = dmcfg.lightdm;
-  cfg = ldmcfg.greeters.tiny;
-
-in
-{
-  options = {
-
-    services.xserver.displayManager.lightdm.greeters.tiny = {
-
-      enable = mkOption {
-        type = types.bool;
-        default = false;
-        description = ''
-          Whether to enable lightdm-tiny-greeter as the lightdm greeter.
-
-          Note that this greeter starts only the default X session.
-          You can configure the default X session using
-          [](#opt-services.displayManager.defaultSession).
-        '';
-      };
-
-      label = {
-        user = mkOption {
-          type = types.str;
-          default = "Username";
-          description = ''
-            The string to represent the user_text label.
-          '';
-        };
-
-        pass = mkOption {
-          type = types.str;
-          default = "Password";
-          description = ''
-            The string to represent the pass_text label.
-          '';
-        };
-      };
-
-
-      extraConfig = mkOption {
-        type = types.lines;
-        default = "";
-        description = ''
-          Section to describe style and ui.
-        '';
-      };
-
-    };
-
-  };
-
-  config = mkIf (ldmcfg.enable && cfg.enable) {
-
-    services.xserver.displayManager.lightdm.greeters.gtk.enable = false;
-
-    services.xserver.displayManager.lightdm.greeter =
-    let
-      configHeader = ''
-        #include <gtk/gtk.h>
-        static const char *user_text = "${cfg.label.user}";
-        static const char *pass_text = "${cfg.label.pass}";
-        static const char *session = "${dmcfg.defaultSession}";
-      '';
-      config = optionalString (cfg.extraConfig != "") (configHeader + cfg.extraConfig);
-      package = pkgs.lightdm-tiny-greeter.override { conf = config; };
-    in
-      mkDefault {
-        package = package.xgreeters;
-        name = "lightdm-tiny-greeter";
-      };
-
-    assertions = [
-      {
-        assertion = dmcfg.defaultSession != null;
-        message = ''
-          Please set: services.displayManager.defaultSession
-        '';
-      }
-    ];
-
-  };
-}