about summary refs log tree commit diff
path: root/nixos/modules/services/x11/compton.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/x11/compton.nix')
-rw-r--r--nixos/modules/services/x11/compton.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/x11/compton.nix b/nixos/modules/services/x11/compton.nix
index c02c9bfd94e8..a94a76ff0c0f 100644
--- a/nixos/modules/services/x11/compton.nix
+++ b/nixos/modules/services/x11/compton.nix
@@ -215,7 +215,7 @@ in {
     };
 
     settings = let
-      configTypes = with types; either bool (either int (either float str));
+      configTypes = with types; oneOf [ bool int float str ];
       # types.loaOf converts lists to sets
       loaOf = t: with types; either (listOf t) (attrsOf t);
     in mkOption {