about summary refs log tree commit diff
path: root/nixos/modules/services/x11/colord.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/x11/colord.nix')
-rw-r--r--nixos/modules/services/x11/colord.nix41
1 files changed, 0 insertions, 41 deletions
diff --git a/nixos/modules/services/x11/colord.nix b/nixos/modules/services/x11/colord.nix
deleted file mode 100644
index 31ccee6aa33f..000000000000
--- a/nixos/modules/services/x11/colord.nix
+++ /dev/null
@@ -1,41 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-let
-
-  cfg = config.services.colord;
-
-in {
-
-  options = {
-
-    services.colord = {
-      enable = mkEnableOption "colord, the color management daemon";
-    };
-
-  };
-
-  config = mkIf cfg.enable {
-
-    environment.systemPackages = [ pkgs.colord ];
-
-    services.dbus.packages = [ pkgs.colord ];
-
-    services.udev.packages = [ pkgs.colord ];
-
-    systemd.packages = [ pkgs.colord ];
-
-    systemd.tmpfiles.packages = [ pkgs.colord ];
-
-    users.users.colord = {
-      isSystemUser = true;
-      home = "/var/lib/colord";
-      group = "colord";
-    };
-
-    users.groups.colord = {};
-
-  };
-
-}