about summary refs log tree commit diff
path: root/nixos/modules/services/web-servers/fcgiwrap.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/web-servers/fcgiwrap.nix')
-rw-r--r--nixos/modules/services/web-servers/fcgiwrap.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/web-servers/fcgiwrap.nix b/nixos/modules/services/web-servers/fcgiwrap.nix
index 2c5e433003c8..a64a187255a4 100644
--- a/nixos/modules/services/web-servers/fcgiwrap.nix
+++ b/nixos/modules/services/web-servers/fcgiwrap.nix
@@ -21,7 +21,7 @@ in {
       };
 
       socketType = mkOption {
-        type = types.addCheck types.str (t: t == "unix" || t == "tcp" || t == "tcp6");
+        type = types.enum [ "unix" "tcp" "tcp6" ];
         default = "unix";
         description = "Socket type: 'unix', 'tcp' or 'tcp6'.";
       };