about summary refs log tree commit diff
path: root/nixos/modules/services/networking/xray.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/networking/xray.nix')
-rw-r--r--nixos/modules/services/networking/xray.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/nixos/modules/services/networking/xray.nix b/nixos/modules/services/networking/xray.nix
index 83655a2f88ef..56c7887b3308 100644
--- a/nixos/modules/services/networking/xray.nix
+++ b/nixos/modules/services/networking/xray.nix
@@ -16,14 +16,7 @@ with lib;
         '';
       };
 
-      package = mkOption {
-        type = types.package;
-        default = pkgs.xray;
-        defaultText = literalExpression "pkgs.xray";
-        description = lib.mdDoc ''
-          Which xray package to use.
-        '';
-      };
+      package = mkPackageOption pkgs "xray" { };
 
       settingsFile = mkOption {
         type = types.nullOr types.path;