about summary refs log tree commit diff
path: root/nixos/modules/services/networking/v2ray.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/networking/v2ray.nix')
-rw-r--r--nixos/modules/services/networking/v2ray.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/nixos/modules/services/networking/v2ray.nix b/nixos/modules/services/networking/v2ray.nix
index ba2aa5bc1de7..3e1895fbe20c 100644
--- a/nixos/modules/services/networking/v2ray.nix
+++ b/nixos/modules/services/networking/v2ray.nix
@@ -16,14 +16,7 @@ with lib;
         '';
       };
 
-      package = mkOption {
-        type = types.package;
-        default = pkgs.v2ray;
-        defaultText = literalExpression "pkgs.v2ray";
-        description = lib.mdDoc ''
-          Which v2ray package to use.
-        '';
-      };
+      package = mkPackageOption pkgs "v2ray" { };
 
       configFile = mkOption {
         type = types.nullOr types.str;