about summary refs log tree commit diff
path: root/nixos/modules/services/networking/squid.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/networking/squid.nix')
-rw-r--r--nixos/modules/services/networking/squid.nix7
1 files changed, 1 insertions, 6 deletions
diff --git a/nixos/modules/services/networking/squid.nix b/nixos/modules/services/networking/squid.nix
index f93bcf19f2b3..68f4dc3d6dc1 100644
--- a/nixos/modules/services/networking/squid.nix
+++ b/nixos/modules/services/networking/squid.nix
@@ -111,12 +111,7 @@ in
         description = lib.mdDoc "Whether to run squid web proxy.";
       };
 
-      package = mkOption {
-        default = pkgs.squid;
-        defaultText = literalExpression "pkgs.squid";
-        type = types.package;
-        description = lib.mdDoc "Squid package to use.";
-      };
+      package = mkPackageOption pkgs "squid" { };
 
       proxyAddress = mkOption {
         type = types.nullOr types.str;