about summary refs log tree commit diff
path: root/nixos/modules/services/networking/imaginary.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/networking/imaginary.nix')
-rw-r--r--nixos/modules/services/networking/imaginary.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/nixos/modules/services/networking/imaginary.nix b/nixos/modules/services/networking/imaginary.nix
index 5437da572778..a655903d1031 100644
--- a/nixos/modules/services/networking/imaginary.nix
+++ b/nixos/modules/services/networking/imaginary.nix
@@ -10,9 +10,12 @@ in {
 
     address = mkOption {
       type = types.str;
-      default = "";
-      description = mdDoc "Bind address. Corresponds to the `-a` flag.";
-      example = "localhost";
+      default = "localhost";
+      description = mdDoc ''
+        Bind address. Corresponds to the `-a` flag.
+        Set to `""` to bind to all addresses.
+      '';
+      example = "[::1]";
     };
 
     port = mkOption {